Pinch Zoom from Windows to Mac

Hey guys,

I'm starting to despair. I have a vocal booth with a tiny windows PC and want to remote control my MacBook Pro with Logic Pro X on it.

The most important feature for me is to navigate through the tracks. This includes zooming in and out via Apple's Magic Trackpad 2.

I already got the Trackpad working on Windows. And the pinch zoom with two fingers zooms in on websites for example on Windows.

But neither TeamViewer nor any other remote software transfers the zoom gesture to the Mac, when using it. Other touch gestures like scrolling work just fine.

Has anyone any idea why this is not working or any other software tip? :/ Without touch gestures it would be a pain to use Logic.

Thank you very very much in advance!

Best regards

Nick

Answers

  • NickHatBoecker
    NickHatBoecker Posts: 6 ✭✭

    Anyone please? :/

  • Esther
    Esther Posts: 4,054 Former Community Manager

    Hi @NickHatBoecker

    Interesting use case! We were just launching two new articles that are focussing on cross-platform commands (well, key commands), but touch gestures are also important for sure.

    👉 Use key commands in sessions (Win -> Mac)

    👉 Use key commands in sessions (Mac -> Win)

    Do I get your setup right, that you connect from Windows to Mac, but you have the Magic Trackpad 2 connected with your Windows device?

    I do not have a trackpad myself to test your setup, but maybe we can find a solution anyways together!

    Does anyone else have a trackpad who can give us a hint?

    Thanks in advance,

    Esther

    Former Community Manager

  • NickHatBoecker
    NickHatBoecker Posts: 6 ✭✭

    Hi @Esther

    Thanks for responding. Yup you got that setup right.

    Interesting article about key commands. I can confirm that these are working just fine. It's really just the pinch zoom gesture, that doesn't seem to work. Also 3-finger-gestures like showing all open applications are not working.

    I guess the problem is, that the Windows machine tries to interpret these multi touch gestures, instead of sending them to the remote device (in my case the macbook pro).

    So I think TW needs a checkbox for "Send multi touch gestures" just like with the key command option "Send key combinations".

    Best regards

    Nick

  • Esther
    Esther Posts: 4,054 Former Community Manager

    That sounds plausible to me.

    @TV_Benjamin have you ever had a case like this?

    Fun fact: This morning I was looking for a new keyboard for my Windows and found one with a trackpad. But I interpreted it more as usable with Smart TVs than with the computer. However - this tells me, that Windows also has some trackpad parts available and the likelihood that people use it is high, right?

    Former Community Manager

  • Esther
    Esther Posts: 4,054 Former Community Manager

    HI again @NickHatBoecker

    QUick Question: Do you have a TeamViewer license so that you could send in logfiles via our ticket portal?

    Former Community Manager

  • NickHatBoecker
    NickHatBoecker Posts: 6 ✭✭

    Hey Esther, unfortunately no. I use the free TW Version for personal use only.

  • Esther
    Esther Posts: 4,054 Former Community Manager

    OK - thanks for your quick reply.

    But I think we can just say that TeamViewer transmits all "commands" via the trackpad to the Mac except for the zoom gestures. So something is holding these specific "commands" from being transmitted.

    Former Community Manager

  • Thank you for writing to Teamviewer Community Forums.   

    Pinch zoom can be disabled for your touchpad from the gesture utility software that comes installed from your manufacturer, you can try the below steps to access it.

    Method 1: Enable/Disable Pinch Zoom.

    1. Search for Mouse & Touchpad on the start menu or you can access from Settings > Devices > Mouse & Touchpad.
    2. Click on Additional mouse option from the right pane.
    3. Click on the Device Settings tab and click on Settings button.
    4. Click on Pinch Zoom option and uncheck/check  the box Enable Pinch Zoom to enable or disable it.
    5. Click on Apply and OK.

    If you still face the issue, reply to this post with more information.

    Regards,

  • NickHatBoecker
    NickHatBoecker Posts: 6 ✭✭

    @tylerpage Thanks for the reply but I think you didn't get the problem.

    Pinch zoom is working just fine on the host as well as on the client pc by itself.

    But when using TW the pinch zoom (and other multi touch gestures) on the client is not being sent to the host. So I cannot zoom into an application on my Mac, while remotely connect via TW and a windows PC.

    I don't know if it's the same for Mac to Mac connection. But I will try it out this evening with a friend and will report back.

  • NickHatBoecker
    NickHatBoecker Posts: 6 ✭✭

    So today I could finally test if using Teamviewer from Mac Mini (late 2018, Catalina) to Macbook Pro (2018, also Catalina) would work with pinch zoom. Unfortunately this also does not work.