teamviewer.com link icon
or
Ask The Community

Remote mouse no longer working

aaciii
aaciii Posts: 4 ✭✭
edited March 27 in General Questions

All of a sudden for no apparent reason... i cant control the mouse on my Win11 desktop (it neither moves nor registers clicks).

I cant control the mouse from my laptop, nor from my iphone (both of which have worked for years).

Tried uninstall/reinstall, went thru all settings, etc. Nothing helps -- the remote mouse just sits there unresponsive. Keyboard works fine.

Also, I can use [removed per Community Guidelines] to the very same machine, and it works fine mouse and all.

So TeamViewer seems to have gone mouse-dead.

Tagged:

Answers

  • It's sort of the same problem on my side actually, it's been working for a long time without issues and then suddenly a few weeks ago with an update of TeamViewer I can see my mouse moving on my side but it doesn't do anything on the remote side, it only allows him to move his mouse and do what I tell him to do but mine is useless.

  • aaciii
    aaciii Posts: 4 ✭✭

    Yes exactly. I have given up trying to resolve. It’s just no longer working on the remote device for no apparent reason. Haven’t changed a thing on that machine.