teamviewer.com link icon
or
Ask The Community

Incoming connections to Ubuntu 22.04 seems broken in some cases

zwcolin
zwcolin Posts: 3 ✭✭
edited September 13 in Linux only

I have TeamViewer 15.30.3 installed on Ubuntu 22.04 and I'm not able to connect to it using another computer. However, I'm able to use it to connect to other computers. This is what the log says:

...

2022/05/27 19:10:02.636 147214 140317227468352 S  WoL: CWakeOnLanUpdate::PerformUpdate: New ethernet information detected, no update necessary as WOL is deactivated

2022/05/27 19:10:02.668 147214 140317515826752 S  AsyncMessaging::RegisterAtAsyncMessageProvider(): Register successful

2022/05/27 19:10:02.798 147214 140317566182976 S  MoveRestrictionsManagement: Synchronization of the restriction was successful!

2022/05/27 19:10:02.806 147214 140317499041344 S  ManagedDeviceController::HandleGetOwnerInformation(): Owner company: 

2022/05/27 19:10:03.164 147214 140317666895424 S  WoL: CWakeOnLanUpdate::ResetWakeUpResult WakeOnLan hasn't been configured, inconsistent

2022/05/27 19:10:03.164 147214 140317666895424 S!! MDv2::Sync::RemovePropertiesOperation::Run(): No device state found, Errorcode=11

2022/05/27 19:10:03.164 147214 140317666895424 S  UpdateStates::Start(): Device has been marked unmanaged. Stopping sync.

2022/05/27 19:10:03.164 147214 140317666895424 S  ManagedDeviceController::OnSyncFinished(): Sync finished

2022/05/27 19:10:03.164 147214 140317666895424 S  tvwol::utility::StoreMDv2WoLFlag(bool, const IManagedDeviceClientModuleWeakPtr&)::<lambda(bool)>::<lambda()>: WakeOnLan flag updated on ManagedDeviceV2 device state to WolActive = 0.

2022/05/27 19:10:03.706 147214 140317683680832 S  SendCompleteStatus::HandleResponse(): Success

2022/05/27 19:10:03.706 147214 140317683680832 S  CMachineStatus::OnCheckSendResult(): Successfully sent check data, updating local cache

2022/05/27 19:10:04.393 147214 140317549397568 S  ControlCenterImplementation::SyncManagersCallback()

2022/05/27 19:10:04.393 147214 140317549397568 S  SyncManagersFunction::Start: current managerlist size: 1

2022/05/27 19:10:04.577 147214 140317675288128 S  DeviceStorageProviderCommunication::HasManagerListChanged: hashes differ. Update ManagerList.

2022/05/27 19:10:04.577 147214 140317675288128 S  SyncManagersFunction::Start: manager list has changed

2022/05/27 19:10:04.766 147214 140317641717312 S  SyncManagersFunction::GetListResponse called

2022/05/27 19:10:04.767 147214 140317641717312 S  SyncManagersFunction::GetListResponse: ManagerCount on BuddyProvider: 1 ManagerCount locally: 1

2022/05/27 19:11:04.256 147214 140317566182976 S  Carrier[4]::CmdEndSession(): Received CMD_ENDSESSION with reason: LoginFailed

2022/05/27 19:11:04.260 147214 140317507434048 S  ConnectionGuard: no restrictions

2022/05/27 19:11:07.020 147214 140317692073536 S  Activating Router Carrier

2022/05/27 19:11:07.020 147214 140317692073536 S  CommandHandlerRouting[5]::CreatePassiveSession(): incoming session via US-LAX-ANX-R005.teamviewer.com, protocol Port443

2022/05/27 19:11:07.037 147214 140317557790272 S  DesktopProcessStarterLinux::StartSystemProcessInSession(450215437,/opt/teamviewer/tv_bin/TeamViewer_Desktop)

2022/05/27 19:11:07.039 147214 140317557790272 S  DesktopProcessStarterLinux: user for process launch: colin (1000)

2022/05/27 19:11:07.065 147214 140317557790272 S  StartServiceByName: Starting com.teamviewer.TeamViewer.Desktop

2022/05/27 19:11:14.087 147214 140317557790272 S!! StartServiceByName: com.teamviewer.TeamViewer.Desktop - DBus: 'org.freedesktop.DBus.Error.Spawn.ChildExited' (Process com.teamviewer.TeamViewer.Desktop exited with status 1) when calling 'org.freedesktop.DBus.StartServiceByName' on '/org/freedesktop/DBus', Errorcode=11

2022/05/27 19:11:14.088 147214 140317557790272 S  CreateProcess '/opt/teamviewer/tv_bin/TeamViewer_Desktop' as user colin (1000), marked with 'TV_SPAWNED'

2022/05/27 19:11:14.090 147214 140317557790272 S  ProcessControlBase[4]: Start Desktop process in session [Removed per Community Guidelines], pid [Removed per Community Guidelines]

...


It seems that the two lines with S!! are what caused the trouble. The computer attempting to connect to this machine got stuck on the status "connection" and will finally time out. I did some search but it doesn't seem there is any active discussion relating to the above errors with TeamViewer. Does anyone have any insights on this? Thank you!

Answers

  • cli644
    cli644 Posts: 2 ✭✭


    I've wasted almost 2 days figuring this out and just recently found out to which version to upgrade.

    I just sudo apt install and confirmed the "downgrade" when asked by apt.

    Cheers

  • zwcolin
    zwcolin Posts: 3 ✭✭

    Thank you for the comments. I downgraded the version to 15.18.4 and the same error still appears. I'm not sure if there is another workaround that would fix it.

  • IgorPevac
    IgorPevac Posts: 1 Newbie

    I'd like to confirm downgrade to 15.18.4 solves the issue. Required restart in my case.

  • zwcolin
    zwcolin Posts: 3 ✭✭

    No, the idea to remove the teamviewer then install the 15.18.4 won't work for my situation even after reboot. I highly suspect that the line with

    2022/05/27 19:11:14.087 147214 140317557790272 S!! StartServiceByName: com.teamviewer.TeamViewer.Desktop - DBus: 'org.freedesktop.DBus.Error.Spawn.ChildExited' (Process com.teamviewer.TeamViewer.Desktop exited with status 1) when calling 'org.freedesktop.DBus.StartServiceByName' on '/org/freedesktop/DBus', Errorcode=11

    caused the problem.

  • Tijs
    Tijs Posts: 2 ✭✭

    Did you get it solved in the end? Same problem here. Downgrade to 15.18.4 also doesn't do the trick.

  • rangsiman
    rangsiman Posts: 2

    It works for me but restarting a computer is needed.

  • wxzhao7
    wxzhao7 Posts: 1 Newbie

    For me, any version before 15.30.3 worked properly. I have tried 15.30.3, 15.31.5 and 15.32.3 :(


    teamviewer-host/stable 15.32.3 amd64 [upgradable from: 15.25.5]

    teamviewer-host/stable 15.31.5 amd64

    teamviewer-host/stable 15.30.3 amd64

    teamviewer-host/stable,now 15.25.5 amd64 [installed,upgradable to: 15.32.3]

    teamviewer-host/stable 15.20.6 amd64

    teamviewer-host/stable 15.10.5 amd64

  • flstaats
    flstaats Posts: 1

    Has anyone seen any updates on this (I downgrade to 15.18.4 and everything worked but everything current is still broken for incoming connections in my configuration too).

    At this point my work around for connecting to Ubuntu 22.04 from a Mac is to use the built in RDP server. I've actually now have to use 3 different screen sharing programs (Mac native screen sharing client which is the only approved option for my work laptop, Mac RDP client to my Ubuntu 22.04 laptop, and Mac TeamViewer client for everything else.)

    I mostly use the "free" TeamViewer to support extended family (parents and other non-technical relatives) where a paid commercial solution just isn't an option. Most of those folks are Mac or PC so the existing TeamViewer solution works well. It would be nice if it also worked for my LAN networking sharing between personal machines too... sad to see I may have to migrate back to RDP across the board now that Linux, MAC, and PC all support it.

  • MoldAnatomist
    MoldAnatomist Posts: 2 ✭✭
    edited August 15

    Something similar has been happening on Fedora 34. When I power on my machine I'm able to login to teamviewer from my phone just fine but if I close the connection and try to start it again then it can't connect. Restarting the teamviewer service wasn't enough to get it to work again because it was leaving other processes running that might be what is triggering the issue (I imagine there's a faulty connection cleanup somewhere). I believe manually killing all processes and starting the teamviewer service again might have caused it to work again but the same would repeat if I close that connection. I simply downgraded to 15.10.5 which was the closest to 15.18.4 available for downgrade in my system and everything is working as expected now.

  • Alex_tvu
    Alex_tvu Posts: 1 Newbie
    edited August 25

    Hi

    I've similar case that started to happen some weeks ago

    I'm not able to tv to Ubuntu 18.04 x64 LTS from any other PC (incoming connection) - all I see is never ending "Connecting" or "Initialising session" string which timeouts after some time - thats all!


    But at the same time I'm able to do tv from within same Ubuntu to any outgoing PC..

    the bug appeared in some latest Linux flavour (definitely present in 15.32.3 and some previous builds)

    Reboot/restart - nothing hellped out...

    Please let me know where could I find logs to share with you so you'll be able to get some clues and fix this blocking issue!

    Thank you!


    PS Just tried 15.33.7 x64 deb on the same Ubunt 18.04 LTS x64 - same result...

    @zwcolin could you hint me please where did you find the tv logs in Ubuntu OS? thanks

  • Ghibli
    Ghibli Posts: 1

    Hi all,

    I faced the same issue after moving to Ubuntu 22.04 which seems to be non compatible with the latest version of Teamviewer and I temporarily solved it by downgrading as well.

    Here is what I have done:

    1- Once Teamviewer 15.33 installed, open a terminal and write: "apt-cache showpkg teamviewer"

    you will see all the possible previous version to which you can downgrade to (15.18.4 is no more available):

    15.33.7 -

    15.32.3 -

    15.31.5 -

    15.30.3 -

    15.25.5 -

    15.20.6 -

    15.10.5 -

    15.1.3937 -

    14.7.1965 -

    14.0.14470 -

    13.2.153441 -

    12.0.258841 -

    11.0.258840 -

    Reverse Provides

    2 - Downgrade to 15.1.3937 by : "sudo apt-get install teamviewer=15.1.3937" . The higher versions did not work.

    3 -try to connect to your Ubuntu from another laptop (mine windows); it worked :)


    Thanks again for the support guys!

  • rangsiman
    rangsiman Posts: 2

    Agree. In my case trying to connect to a remote machine (Ubuntu 22.04) the latest release of Teamviewer does not work. So I need to downgrade to 15.1.3937 and it works!