link icon
Ask The Community

Linux - downgrade to version 15.27.3

Gigi183 Posts: 6 ✭✭
edited September 2022 in Linux only

The newest version (15.28.6) doesn't work on my Linux Mint installation. I have 15.27.3 on another machine and it is still working fine with the target computer. How can I downgrade to version 15.27.3?



  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @Gigi183 ,

    Welcome to TeamViewer Community! 🎉😃

    Could you provide us more details on the issue? What exactly is not working? Like it's no installing, or it installs, but it doesn't connect... Any error messages?

    I will wait for your feedback to attempt to better assist you.

    Have a good one! 🌞🌴


    Carol 🙋‍♀️

    Portuguese Community Moderator

  • Gigi183
    Gigi183 Posts: 6 ✭✭

    Sure thing. So I open teamviewer from the command line. The GUI opens up, but when I click connect nothing happens. It's unresponsive to that one action. (doesn't matter whether I try "remote control" or "file transfer", whether I use the connect button up top next to "insert partner ID" or the "Connect" button the Control Remove Computer panel. It is not like the program responds to the click and fails - it is acting as if it is not responding to the click at all. I can interact with the GUI to change settings in the Extra->Options menu.

    Hope that helps!

    Here's my general info:


     Kernel: 5.4.0-105-generic x86_64 bits: 64 compiler: gcc v: 9.4.0

     Desktop: Cinnamon 4.8.6 wm: muffin 4.8.1 dm: LightDM 1.30.0

     Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal


     Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05

     serial: <filter> Chassis: type: 10 v: Lenovo Legion 5 15ARH05

     serial: <filter>

     Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter>

     UEFI [Legacy]: LENOVO v: EUCN31WW date: 01/01/2021


     ID-1: BAT0 charge: 59.5 Wh condition: 59.5/60.0 Wh (99%) volts: 17.1/15.4

     model: SMP L19M4PC0 type: Li-poly serial: <filter> status: Full cycles: 6

     Device-1: hidpp_battery_0 model: Logitech M510 serial: <filter>

     charge: 55% (should be ignored) rechargeable: yes status: Discharging


     Topology: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64

     type: MT MCP arch: Zen rev: 1 L2 cache: 3072 KiB

     flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm

     bogomips: 71863

     Speed: 1397 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz):

     1: 1311 2: 1324 3: 1397 4: 1397 5: 1460 6: 1448 7: 1357 8: 1397 9: 1397

     10: 1397 11: 1397 12: 1397


     Device-1: NVIDIA vendor: Lenovo driver: nvidia v: 470.103.01

     bus ID: 01:00.0 chip ID: 10de:1f99

     Display: x11 server: X.Org 1.20.13 driver: modesetting,nouveau,nvidia

     unloaded: fbdev,vesa

     resolution: 1920x1080~120Hz, 1920x1080~60Hz, 1920x1080~60Hz

     OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2

     v: 4.6.0 NVIDIA 470.103.01 direct render: Yes


     Device-1: NVIDIA driver: snd_hda_intel v: kernel bus ID: 01:00.1

     chip ID: 10de:10fa

     Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor

     vendor: Lenovo driver: N/A bus ID: 05:00.5 chip ID: 1022:15e2

     Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel

     v: kernel bus ID: 05:00.6 chip ID: 1022:15e3

     Device-4: Logitech Headset H390 type: USB

     driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-1.1.3:7

     chip ID: 046d:0a44

     Sound Server: ALSA v: k5.4.0-105-generic


     Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet

     vendor: Lenovo driver: r8169 v: kernel port: 1000 bus ID: 03:00.0

     chip ID: 10ec:8168

     IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>

     Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 1000

     bus ID: 04:00.0 chip ID: 8086:2723

     IF: wlp4s0 state: up mac: <filter>


     Local Storage: total: 1.38 TiB used: 284.40 GiB (20.2%)

     ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM512GDHTNI-87A0B

     size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11010C00

     scheme: MBR

     ID-2: /dev/sda vendor: Western Digital model: WD10SPSX-08A6W

     size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter>

     rev: 1A01 temp: 35 C scheme: GPT


     ID-1: / size: 467.96 GiB used: 284.40 GiB (60.8%) fs: ext4

     dev: /dev/nvme0n1p5


     System Temperatures: cpu: 43.9 C mobo: N/A gpu: nvidia temp: 45 C

     Fan Speeds (RPM): N/A


     Processes: 369 Uptime: 1d 5h 31m Memory: 7.64 GiB used: 5.49 GiB (71.9%)

     Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9 Shell: bash

     v: 5.0.17 running in: gnome-terminal inxi: 3.0.38


  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @Gigi183 , 😃

    Thanks for taking the time to provide all the additional information!

    At this moment, the only thing that comes to my mind is a dependency issue.

    Did you already tried to check/update dependencies?



    Portuguese Community Moderator

  • Gigi183
    Gigi183 Posts: 6 ✭✭

    I appreciate the response, but I'm pretty sure everything is clean and in order and updated as packages go. Is there no way to install the previous version? 15.27.3 is working great for me on another computer.

  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @Gigi183 ,

    Thanks for your reply! 😊

    To keep TeamViewer as secure as possible, and with all the newest functionalities, only the newest version of the software is available for download.

    Therefore, we would need to look after other ways to troubleshoot the issue. 🤔🍀

    What did you tried doing already?

    Also, you mentioned that this device can't do connections, but does this device receive connections?

    Does the ID display or it shows just as a dash "-"?

    Portuguese Community Moderator

  • Gigi183
    Gigi183 Posts: 6 ✭✭

    Inbound connections are fine. The GUI is just dead on the connect button on the one computer running linux mint. I click, and the program is unresponsive - there is no sign that it is even attempting to connect.

    As far as what to do to fix: I installed and re-installed. I tried teamviewer 14 (which is available on your website, btw), but that won't work unless I switch to teamviewer 14 on all computers in the house as well. Right now I'm just not updating from 15.27.3 on any other computers.

  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @Gigi183 ,

    Thanks for the additional feedback!

    I could not simulate the issue on my side. 🤔

    I also verified that our support team did not receive similar cases reporting this issue... Therefore, I'm not to sure why you're having troubles with the GUI on the newest version. (On our website we offer the newest version of any major version which the services are still supported.)

    I'm grateful that v14 is working on your system, and I agree with you that it makes sense use it for now.

    If I get any new updates about what could be causing you this issue, I will let you know 😉

    If in the mean time you get to a solution, please share here with us. This may be of great help for other users 😃🍀


    Carol 🙋‍♀️

    Portuguese Community Moderator

  • Gigi183
    Gigi183 Posts: 6 ✭✭

    Ok. Just FYI, you almost certainly have a problem on your end. My office setup is like this:

    A Windows machine

    A Linux machine running Fedora

    A Linux machine running Linux Mint

    I use teamviewer, exclusively with LAN connections, to control each computer from the other, though the typical workflow is to target the Windows machine from either the Fedora or Mint machine.

    Here's what works: Fedora (15.27.3) can control Mint (15.28.6). Fedora (15.27.3) can control Windows (15.28.4). Mint (15.28.6) cannot connect to anything. I updated Fedora to 15.28.6, and that broke the ability of Fedora to control anything - the exact same problem existed on the Fedora box on 15.28.6 that exited on the Mint box: I click on the connect button and Teamviewer does not respond. There is no indication that the connection is failing. It is simply not getting going.

    Then I downgraded every computer to 14 and I'm back to full functionality. I will wait a few update cycles before I try version 15 again.

  • Gigi183
    Gigi183 Posts: 6 ✭✭

    One more for anyone who finds this: do a google search for how to install specific versions of a package. You can find what you need to roll back teamviewrer to 15.27.3 from the command line and then hold it so that it doesn't update.

  • KMNug53
    KMNug53 Posts: 6 ✭✭

    Just to confirm Gigi183's findings.

    Mint Kernel: 5.4.0 - 109, TeamViewer 15.28.6, Windows 10 Home 21H2 OS build 19044.1645

    With 'Incoming LAN connections' set to 'accept exclusively':

    Windows 10 can connect to Mint.

    Mint cannot connect to Windows 10 (no error thrown) Clicking 'Connect' yields no response.

    With 'Incoming LAN connections' set to 'accept':

    Windows 10 can connect to Mint

    Mint cannot connect to Windows 10 (error msg: 'Could not connect to partner')

  • KMNug53
    KMNug53 Posts: 6 ✭✭

    15.29.4 appears to have resolved the issue. TV on Mint now connects to Windows as expected.

  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @KMNug53 ,

    Thank you for your feedback and for testing it in your system as well! 💯✨

    I am grateful the issue got corrected on our side with version 15.29.4.

    @Gigi183 you may want to try v15.29.4 as well.

    Please let us know if it also corrected the connectivity on our side. 🍀🤞

    👉 This new version also had a few improvements for compatibility with Wayland. You can read more about it here:


    Carol 🙋‍♀️🌷

    Portuguese Community Moderator

  • FF123456
    FF123456 Posts: 17 ✭✭
    edited May 2022

    Sorry for reactivating this topic but I fear I have to report the exact same problem on LinuxMint 20.3, but the latest version still does not cure it. Any Teamviewer version higher than 15.21.4 starts fine, but does not register any mouse interaction at all.

    Tested with Teamviewer 15.29.4 (both .deb and the tar file and the host), 15.25.5 (.deb file only) and, 15.21.4 (.deb file and host) and 15.16.8 (again, .deb file only). I uninstalled the previous version in all cases but also treid to install 15.21.4 first and then upgrade to 15.29.4. A "sudo apt –fix-missing update" does not find any missing dependencies.

    My system information:

    System:    Kernel: 5.4.0-110-generic x86_64 bits: 64 compiler: gcc v: 9.4.0 
               Desktop: Cinnamon 5.2.7 wm: muffin dm: LightDM Distro: Linux Mint 20.3 Una 
               base: Ubuntu 20.04 focal 
    Machine:   Type: Desktop Mobo: ASRock model: B450 Gaming-ITX/ac serial: <filter> 
               UEFI: American Megatrends v: P3.70 date: 11/18/2019 
    CPU:       Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ rev: 2 
               L2 cache: 3072 KiB 
               flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 81594 
               Speed: 1550 MHz min/max: 1550/3400 MHz Core speeds (MHz): 1: 1548 2: 1549 3: 1541 
               4: 1550 5: 1550 6: 1550 7: 1550 8: 1549 9: 1550 10: 1549 11: 1550 12: 1539 
    Graphics:  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Micro-Star MSI driver: nvidia 
               v: 510.73.05 bus ID: 0a:00.0 chip ID: 10de:1f82 
               Display: x11 server: X.Org 1.20.13 driver: nvidia 
               resolution: 1280x1024~60Hz, 2560x1440~60Hz 
               OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 510.73.05 
               direct render: Yes 
    Audio:     Device-1: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 0a:00.1 
               chip ID: 10de:10fa 
               Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
               bus ID: 0c:00.3 chip ID: 1022:1457 
               Sound Server: ALSA v: k5.4.0-110-generic 
    Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel 
               bus ID: 08:00.0 chip ID: 8086:24fb 
               IF: wlp8s0 state: down mac: <filter> 
               Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: 5.6.0-k port: f000 
               bus ID: 09:00.0 chip ID: 8086:1539 
               IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
               IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
               IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
    Drives:    Local Storage: total: 2.29 TiB used: 711.40 GiB (30.4%) 
               ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 PRO 512GB size: 476.94 GiB 
               speed: 31.6 Gb/s lanes: 4 serial: <filter> 
               ID-2: /dev/sda vendor: Samsung model: SSD 870 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s 
               serial: <filter> 
               ID-3: /dev/sdb vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s 
               serial: <filter> 
               ID-4: /dev/sdc type: USB model: USB007 mini-USB6BU size: 28.0 MiB serial: <filter> 
    Partition: ID-1: / size: 139.17 GiB used: 55.21 GiB (39.7%) fs: ext4 dev: /dev/nvme0n1p5 
               ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p6 
    Sensors:   System Temperatures: cpu: 48.6 C mobo: N/A gpu: nvidia temp: 41 C 
               Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
    Repos:     No active apt repos in: /etc/apt/sources.list 
               Active apt repos in: /etc/apt/sources.list.d/anonbeat-guayadeque-focal.list 
               1: deb http: // focal main
               No active apt repos in: /etc/apt/sources.list.d/appimagelauncher-team-stable-focal.list 
               Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
               1: deb https: // una main upstream import backport
               2: deb http: // focal main restricted universe multiverse
               3: deb http: // focal-updates main restricted universe multiverse
               4: deb http: // focal-backports main restricted universe multiverse
               5: deb http: // focal-security main restricted universe multiverse
               6: deb http: // focal partner
               Active apt repos in: /etc/apt/sources.list.d/signal-xenial.list 
               1: deb [arch=amd64 signed-by=/usr/share/keyrings/signal-desktop-keyring.gpg] https: // xenial main
               Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
               1: deb [arch=amd64] https: // stable main
               Active apt repos in: /etc/apt/sources.list.d/teamviewer.list 
               1: deb https: // stable main
               Active apt repos in: /etc/apt/sources.list.d/termius.list 
               1: deb [arch=amd64] https: // squeeze main
    Info:      Processes: 419 Uptime: 5h 52m Memory: 31.35 GiB used: 4.91 GiB (15.6%) Init: systemd 
               v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 7/9 Client: Unknown python3.8 client 
               inxi: 3.0.38 

  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @FF123456 ,

    Welcome to the TeamViewer Community! 🎉

    So if it is "starting fine, but does not register any mouse interaction at all" this sounds a bit different from the previous issue where the connection was not happening.

    👉 Do you have Wayland on? Did you try to disable it and use the Xorg?

    (TeamViewer v15.29.4 had improvements with Wayland, but there are still a few issues reported.)

    👉 Also, please make sure that the configuration on the Advanced Options on both devices (the one that starts the connection, and the one that receives the connection) is set to Full access. Please also consider checking on the TeamViewer toolbar if Disable remote input is not checked.

    Let me know how if you need further help 😊



    Portuguese Community Moderator

  • CedricGannet
    CedricGannet Posts: 1 Newbie

    I'm Afraid I had the same problem on version 15.29.4. I'm running Linux Mint 20.2 as follows:


    Kernel      : Linux 5.4.0-110-generic (x86_64)

    Version      : #124-Ubuntu SMP Thu Apr 14 19:46:19 UTC 2022

    C Library      : GNU C Library / (Ubuntu GLIBC 2.31-0ubuntu9.9) 2.31

    Distribution      : Linux Mint 20.2

    I had version 15.29.4 installed and it wasn't working as a client in a way very similar to what Gigi183 described. After much investigation, I decided to go back to 15.27.3. Not easy, as I couldn't find a way of downloading the earlier version. Eventually, I googled "teamviewer_15.27.3_amd64.deb" and downloaded it from a mirror (VERY DANGEROUS). I uninstalled and purged the later version and nervously installed the earlier. It worked fine.

    I then upgraded back to version 15.29.4 and IT STILL WORKED! There is certainly an issue here but I suspect a clean re-install would have sorted the problem.

  • FF123456
    FF123456 Posts: 17 ✭✭

    Hello @.Carol.fg. and thanks for the welcome!

    LinuxMint 20.3 does not use Wayland, so I can safely exclude that possible reason (I also doublechecked to be 100% sure, my session type is reported as "X11").

    Your second hint tells me I might have written my explanation in way that it is misunderstandable - with "starting fine but does not register any mouse interaction at all" I meant that I can start the teamviewer program on my computer and the program window looks perfectly fine, but when I try to do interact with it (i.e. try to click onto anything in the Teamviewer program window with the mouse - menu, "Partner ID" entry field, "Connect" button - in short any GUI elements), nothing happens. This is the behaviour mentioned in the beginning of the thread.

    Thus, I am afraid I cannot even open the options menu you showed.

    With the other posts here, it seems that the current versions of Teamviewer runs fine on LinuxMint 20.2 but does not run correctly for some reason on Mint 20.3.

  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @FF123456 and @CedricGannet ,

    Thank you for the additional feedback, and detailed information! 💯

    I firstly would like to apologize for any possible misunderstanding on my part.

    👉 I attempted to contact our support team once again regarding this issue.

    However, my colleagues in the support department could not reproduce the issue reported. They did multiple tests and no issue was found on TeamViewer GUI, connectivity, nor with the remote control. 🤔

    💭 At this point, I can only think that it may be a thirds party app (like a bank app), firewall, or antivirus blocking TeamViewer and freezing the GUI... Regarding connectivity issues, it could be caused by a great variety of issues including IPv6 and DNS.

    I know you all looking for a solution, and I appreciate every single comment with further details, however, this issue doesn't seem to be affecting all users, so we will need to keep investigating. 🔍

    If you get to the bottom of this issue during this time being, I would highly appreciate if you could share the solution with others here in the Community. 🔔🌟

    We will keep in touch.



    Portuguese Community Moderator

  • FF123456
    FF123456 Posts: 17 ✭✭

    Hello @.Carol.fg., thank you for your continued investigation.

    In the meantime, I tested the new version 15.30.3 and could narrow down the topic a little. The basic problem (program does not react to mouse interaction) persists, so it is back to 15.21.4 for me.

    But I found the following thing: Even if the Teamviewer window seems to be unresponsive, it does work perfectly well - when the program window is active, you can use the keyboard to switch between the GUI elements and e.g. open the menu or type in a partner id. This means that Teamviewer really only fails to catch any mouse click events on Mint 20.3 Cinnamon here.

    Maybe this helps a little. If there is something I can do from my side to support your developers, please do not hesitate to contact me.

    I also tried to start Teamviewer with Xephyr in a separate X session to check if maybe some Cinnamon settings cause the problem, but failed miserably - Teamviewer seems to happily ignore the DISPLAY environment variable set in the shell and thus starts in the main X session (i.e. my Cinnamon Desktop) nevertheless.

  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @FF123456,😃

    Thanks for the additional information! I appreciate it! 🙌✨

    I could gather some information too in the meantime... but nothing concrete just yet...

    ... Would you mind testing it?

    So basically a new feature that was recently implemented had some reports of "connection issues" and "TeamViewer stop responding". The feature is Play computer sounds and music

    I wish I could just say for you to open the Options and check if it's marked or not, but since GUI is not clickable, you would need to try downgrading to version 15.18.4 using the command line below → uncheck this feature → update TeamViewer to the newest version again, and check if it's any better.

    (for Debian-Ubuntu-Linux mint-Deepin-Raspberry Pi only)

    • the command to downgrade TeamViewer is:
    sudo apt install teamviewer=15.18.4
    • if you have the TeamViewer Host then it be
    sudo apt install teamviewer-host=15.18.4

    Once again I appreciate your kindness and patience during the resolution of this issue. 🌷



    Portuguese Community Moderator

  • FF123456
    FF123456 Posts: 17 ✭✭
    edited May 2022

    Thanks for the information @.Carol.fg. !

    I have to report though that I already had that setting disabled.

    However, while doing so I finally thought about the obvious thing to help you:

    1. deleted all Teamviewer configuration data that I could find by searching my harddisk for "teamviewer", leaving only the data used by the APT package manager.
    2. installed a clean Teamviewer 15.21.4 directly from your apt package source (I completely had forgotten that these sources offer all the old versions - no need for digging for old deb installers in ominous places :-) )
    3. changed the log file in Teamviewer to log everything
    4. started Teamviewer, checked if it reacted to my mouse, closed it again and moved the resulting the log files from /opt/teamviewer/logfiles/[my Login] to a safe location
    5. then worked my way upwards through all the old versions that you offer in your "stable" package source until I found the first one that did not work: 15.22.3 (okay), 15.23.9 (okay), 15.24.5 (okay), 15.25.5 (not okay) and for sake of completeness 15.30.3 (not okay). I repeated the "open-check-close-save logfiles" process for each version.

    This means: I can now safely say that a change that has been made between version 15.24.5 and 15.25.5 causes these mouse problems.

    Then, I checked the logfiles:

    • gui.log shows some errors, but it is identical for both version 15.24.5 and 15.25.5.
    • startup.log has only the Teamviewer version number as a difference, so I left these out
    • Teamviewer15_logfile.log however shows one interesting error in line 29 of the logfile that might help your R&D: "unable to increase the thread priority for thread 7fef663fc700". This error (with differing thread id's) occurs on every version that I tested here and that works on my computer, while it does not occur on the versions that do not work as they should. I have no clue however what that thread might do, but if it does not throw this error, it seems to have a negative effect on mouse detection.

    I have attached the logfiles for version 15.24.5 and 15.25.5 for your convenience als PDF files, with the relevant line in the "Teamviewer15_Logfile" files marked and comments added.

    Edit: if you find it helpful, I can provide you with the log files for the other versions I tested as well.

  • cli644
    cli644 Posts: 2 ✭✭

    I am usually never joining on any forums however

    Could not connect from Android device and Windows and other Linux machines to that specific 15.30.3. Either it would get stuck on "Initialising session" from Windows to Linux and just drop the connection without any error message and from Android to Linux it would just hang forever until it times out. No difference weather using TV ID, VPN IP or LAN IP. Any other machines were working properly.

    Therefore that sudo apt install teamviewer=15.18.4 solved the critical problem!

    Upgrade to 15.18.4 successfully solves the problem that the latest defective downgrade 15.30.3 introduced (or as it appears even few versions before).

    Best regards

  • FF123456
    FF123456 Posts: 17 ✭✭

    @cli644 This is a little offtopic here, but please note that you mixed "upgrade" and "downgrade" in your post. By trying the command mentioned above you basically found out that an outdated version of Teamviewer works for you (which you might want to avoid using however due to possible security reasons) while the current one does not.

    You might want to create a different thread though instead of hijacking this one since your connection problem does not have anything to do with the topic dicussed here from what I can tell.

  • DCJ
    DCJ Posts: 2 Newbie

    TV 15.30.3 wouldn't let me connect to a  Linux Mint 20.3 Una if the screen was locked. Downgrading to 15.18.4 worked - thanks

  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello everybody!

    I hope you're all doing well 😊

    Just to provide some updates regarding the case:

    👉 Thanks to all the data provided we could get more attention to this issue that it's now being investigated by our development team directly. This is great news, but please keep in mind this process can take some time.

    In the meantime, if you noticed relevant information, or found a solution, please share it with us in this discussion. 🙏🔔

    Thanks again for the contributions, patience, and understanding.


    Carol 👩🏻‍🦰🌷

    Portuguese Community Moderator

  • FF123456
    FF123456 Posts: 17 ✭✭

    @.Carol.fg. This is good news, thank you very much! If there is anything I can help you your developers with please tell me, I will gladly run any test software and send you its output if that helps.

  • FF123456
    FF123456 Posts: 17 ✭✭
    edited August 2022

    Hi @.Carol.fg. Carol.f , are there any news about the topic? The current teamviewer version 15.32.3 still does not solve the issue - the only change I found was that the last working version 15.24.5 was removed from the "stable" repository which ist not what I had expected. 😒

    Thankfully I have a working local backup...

  • .Carol.fg.
    .Carol.fg. Posts: 444 Community Manager 🌍

    Hello @FF123456 ,

    Thanks for your message, I hope you doing well. 😄

    Today I contacted our support team regarding this case for updates.

    👉 They confirmed to me that the case is still open and under investigation by our development team.

    Therefore, we don't have a solution to share just yet.

    We appreciate your patience and understanding during this processing time.

    Please let us know if you have any further questions.



    Portuguese Community Moderator

  • sebastien2
    sebastien2 Posts: 1

    Dears I have to say that I had a similar issue with 15.33.7.

    the UI is just DEAD.

    after searching a while I realize that that was my WACOM Tablet (intuos pro pth-451 in my case) . When using the tablet and clicking with the pen it didn´t work at all.

    I found a mouse, and manage then to click on the different part of the interfaces.

    If would be also user friendly to have the standard shortkeys like ALT+C for connection, ALT+E for Extra, as the menu was not even accessible at first

    I was able to replicate the problem on 2x different PC.

    Hope this helps someone.

  • FF123456
    FF123456 Posts: 17 ✭✭

    Okay, now I finally could borrow a standard mouse and could test this. This is really weird - but I can confirm your finding and your workaround! Thanks!

    @.Carol.fg. that might help your development team as we can specify the problem better now: Teamviewer 15.25.5 and up ignore any events (both mouse movements and clicks) sent to them from the Linux driver for graphic tablets. This means a Wacom tablet cannot be used as a mouse replacement in Teamviewer for Linux as I do for the sake of my hand. It works for any other software I tried - but not for Teamviewer. Could you update the ticket you had opened to include this information?

    I can also confirm that this applies to the updated driver used in Linux Mint 21 as well.