teamviewer.com link icon
or
Ask The Community

Deploy TeamViewer Host with .msi file or .exe file with scripts

KT_Supportari_FO
KT_Supportari_FO Posts: 7 ✭✭
edited June 20 in General Questions

Dear all

I am new to TeamViewer and the guides seems to be a little difficult to understand.

There seemes not to be a complete guide that shows you all the steps from Custom Module to Deploying TeamViewer Host. Or the one they made does not work.

I have created a Custom Module with following options:

  • Name
  • Automaticcaly add users to a group in your Contact list
  • Automatically apply TeamViewer policy
  • Allow account assignment

I have downloaded the .exe file and it seems to work.

I have then downloaded the .msi file and looked at this guide, but the scripts does not work under the installation - just a clean TeamViewer Host is installed.

The scripts I use is as following:

If bStatus and Not(gbWTS) Then 
    sMsiOption="REBOOT=REALLYSUPPRESS ALLUSERS=2 APITOKEN=xxxxxx CUSTOMCONFIGID=xxxxxx"

Can someone please help me? Or do you have a complete guide for this?

Thank you!

Best regards.


Edit: It does not work any time. If the PC has been known in our TV Env. then it does not connect to our TV Env. automatically when installing. Why is this service so unreliable??


Edit: We do have a Corporate licens.

Best Answers

  • KT_Supportari_FO
    KT_Supportari_FO Posts: 7 ✭✭
    Answer ✓

    I'm deeply sorry because I've now found my error. 🙄

    Unfortunately, I have only focused on your guide. In the guide you write that CustomConfigID is the last in the permanent link, but this is wrong IF you choose to change the permanent link. It stands in a point of its own: Configuration ID.

    It is working. 😀

    I am using this script in my installation script of the TeamViewer Host .msi file: "APITOKEN=xxxxxxx CUSTOMCONFIGID=xxxxxxx"

    Thanks!

  • JeanK
    JeanK Posts: 6,435 Community Manager 🌍
    Answer ✓

    Hello @KT_Supportari_FO,

    I'm happy to hear that you could deploy your devices (almost) successfully.

    If you want to remove a device from the Managed device list, you might be looking for this article:

    How to remove a device from the Managed Devices list?

    Let me know if this could help.

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

Answers

  • JeanK
    JeanK Posts: 6,435 Community Manager 🌍

    Hello @KT_Supportari_FO,

    We do have a complete guide on how to deploy TeamViewer.

    You'll find it here:

    📄 Mass deployment on Windows - Overview

    Let me know if you have any questions after following the guide.

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • KT_Supportari_FO
    KT_Supportari_FO Posts: 7 ✭✭
    Answer ✓

    I'm deeply sorry because I've now found my error. 🙄

    Unfortunately, I have only focused on your guide. In the guide you write that CustomConfigID is the last in the permanent link, but this is wrong IF you choose to change the permanent link. It stands in a point of its own: Configuration ID.

    It is working. 😀

    I am using this script in my installation script of the TeamViewer Host .msi file: "APITOKEN=xxxxxxx CUSTOMCONFIGID=xxxxxxx"

    Thanks!

  • KT_Supportari_FO
    KT_Supportari_FO Posts: 7 ✭✭

    Though... 🤷‍♂️

    Account Assignment seems not working as it should be if you uninstall the .msi pack and install it again (the Account Assignment to the specific Computer will not be removed automatically). Therefore the computer must manually be removed/deleted in the "Computers and Contacts" view BEFORE the .msi file is installed again with the scripts "APITOKEN=xxxxxxx CUSTOMCONFIGID=xxxxxxx".

    Therefore you must include the following script as part of the installation script: ASSIGNMENTOPTIONS =" - reassign "

    My finale script is therefore as following (not tested though): "APITOKEN=<my API token> CUSTOMCONFIGID=<my CustomconfigID> ASSIGNMENTOPTIONS ="--reassign""

    Am I right? 👨‍💻

  • KT_Supportari_FO
    KT_Supportari_FO Posts: 7 ✭✭

    Just to confirm that it is working now. Or Almost. 💁‍♂️

    I have the following script: CUSTOMCONFIGID=xxxxx APITOKEN=xxxxx ASSIGNMENTOPTIONS=""--reassign --grant-easy-access --group-id gxxxxx""

    But it seems, that the reassign is not working or I am wrong? When the computer gets a new name, the old device continue to be in the view as Managed Device - and it counts as a license (1 of 1.000). I have tried to delete the computer from our Groups but the count does not decrease.

    Can you help me with this one?

    Thanks!

    Best regards,


  • JeanK
    JeanK Posts: 6,435 Community Manager 🌍
    Answer ✓

    Hello @KT_Supportari_FO,

    I'm happy to hear that you could deploy your devices (almost) successfully.

    If you want to remove a device from the Managed device list, you might be looking for this article:

    How to remove a device from the Managed Devices list?

    Let me know if this could help.

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • KT_Supportari_FO
    KT_Supportari_FO Posts: 7 ✭✭

    Well... thank you very much.

    It works like a charm. 🤩

    @JeanK Thank you for all your help.

  • JeanK
    JeanK Posts: 6,435 Community Manager 🌍

    You're welcome, it's always a pleasure to help.

    Hope to see you posting soon again! 🙌

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer