No "Wake up" button on Ubuntu/Linux - Wake on LAN

Quin452 Posts: 2 ✭✭

Similar to

That post was from Jan '21, and nothing seems to come of it.

I have everything tested and set up on 3 devices. 2x Win10 desktops, connected with Ethernet cables, and 1x Ubuntu laptop over WiFi.

I can use the second desktop to "Wake up" the first desktop (the remote machine), but there is no "Wake up" button on the Ubuntu version of the client.

Windows are both running 15.36.9 and Ubuntu is running 15.36.8, however the UI is noticeably different between the 2.

Both Windows computers have "Wake on LAN" enabled in the network adapter properties, and the BIOS (so theoretically I can wake either up). The Ubuntu laptop does not; is it a requirement even though the laptop will never need to be woken up remotely?


  • Quin452
    Quin452 Posts: 2 ✭✭
    edited December 2022

    Update: Now, if you're like me and have a very complicated setup, I've got some solutions.

    Installing gWakeOnLan for a nice UI works a treat, or etherwake (I had to use the wakeonlan command) if you're using CLI/Terminal/Bash. For both these options, you need to get the Mac address for the remote machine. This is for Ubuntu/Linux.

    Extra steps if you like punishment

    Now, that is the easy part and only works if you're on the same network as them. I've not tried to get it working "externally" (using DDNS/Public address). I think it has something to do with using the physical network adapter (so if not connected locally, it doesn't work).

    For me, I run a VPN on my router (because I host servers for work) and this VPN allows me to connect to the internal network.

    gWakeOnLan nor etherwake didn't work in this instance, but when connected to the VPN, I am able to SSH into the servers. From there I used etherwake (wakeonlan command) on an Ubuntu server, on the same network as the remote machine, and it works.

    From there, I just use TeamViewer to connect.