Can't connect to Mac using iOS on LAN

Hi there, apologies if this has been covered before

MBP on macOS 12.6.2 running TV 15.32.3. MBP has a wired connection to an Access Point via a switch. I can connect wirelessly using TeamViewer to this MBP using another MBP and using a Windows Surface tablet

When I try to connect using my iPad or iPhone using the TeamViewer app I get a 'Waiting for Network' notification at the top of the screen. Using the same iPad I can connect to the MBP using the same setup but with VNC Viewer and I can ping either way

Is there a setting somewhere I need to enable to use an iPad to remote view over a LAN?




  • Dominic_DOT
    Dominic_DOT Posts: 4 ✭✭

    On my iPhone I did manage to remote view into the MBP, but that's when both are connected to my home wifi.

    Does the iOS/ipadOS app require an internet connection even to only make connection over LANs? Would be a shame if so

  • Dominic_DOT
    Dominic_DOT Posts: 4 ✭✭
    edited January 2023

    Still no luck with this if anyone can help? Tried getting some form of support from TeamViewer on Twitter but they only refer me back to here

    Screenshot below of issue. All the same network settings work fine on any device that's not an iOS device. That exact iPad with the same settings works with other VNC apps (although visually they're a bit laggy hence preferring TeamViewer.

    Is there a setting I need to enable somewhere in the iPad app that I'm missing?

  • Dominic_DOT
    Dominic_DOT Posts: 4 ✭✭

    No one have any insight on this? TeamViewer support certainly doesn't