How can I stop the account assignment prompt

ParisCM
ParisCM Posts: 2 ✭✭

I'm using the assignment config which seems to be the way to roll out teamviewer.

Deploy TeamViewer (Host or full client) - 9/9 - TeamViewer Support

start /wait MSIEXEC.EXE /i "c:\temp\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=YOUR_CUSTOM_CONFIG_ID

timeout /t 30 /nobreak

"C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assignment --id YOUR_ASSIGNMENT_ID

Once installed it prompts if I want to allowed account assignment to the 5 admins I've setup.

How can I avoid this?

I read this https://community.teamviewer.com/English/discussion/122068/how-to-stop-account-assignment-prompt

But adding reassign doesn't help?

Best Answers

  • Lenander
    Lenander Posts: 2 ✭✭
    Answer ✓

    Hi ParisCM

    I had the exact same issue. I found out that if I had activated Use Managed Group assignment in my custom host client, it will show the prompt.

    But if I removed it, it did not prompt me anymore and it will still be assigned to the correct group using the assignment --id YOUR_ASSIGNMENT_ID command and if that group has Easy Access set, it will still apply it.

    Hope this will help you.😁

  • Lenander
    Lenander Posts: 2 ✭✭
    Answer ✓

    @ParisCM

    If you place bat and MSI in same folder, this should be put in the bat file:

    start /wait MSIEXEC.EXE /i "%~dp0TeamViewer_Host.msi" /qn CUSTOMCONFIGID=xxxxx

    timeout /t 30 /nobreak

    "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assignment --id xxxxxxxxxxxxxxxxxxxxxxxxxxxx


    Instead of using full filepath %~dp0 will tell the bat-file that the MSI is in the same folder as the bat.

    I hope I understood your question correctly.

Answers

  • Lenander
    Lenander Posts: 2 ✭✭
    Answer ✓

    Hi ParisCM

    I had the exact same issue. I found out that if I had activated Use Managed Group assignment in my custom host client, it will show the prompt.

    But if I removed it, it did not prompt me anymore and it will still be assigned to the correct group using the assignment --id YOUR_ASSIGNMENT_ID command and if that group has Easy Access set, it will still apply it.

    Hope this will help you.😁

  • ParisCM
    ParisCM Posts: 2 ✭✭

    Perfect that has worked, thankyou.

    So now if I run this as a bat file it works perfectly.

    start /wait MSIEXEC.EXE /i "\\ServerLocation\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=xxxxx

    timeout /t 30 /nobreak

    "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assignment --id xxxxxxxxxxxxxxxxxxxxxxxxxxxx

    I'm not sure how to get this working via sccm. How can I run the 2nd cmd post install of the msi?

  • Lenander
    Lenander Posts: 2 ✭✭
    Answer ✓

    @ParisCM

    If you place bat and MSI in same folder, this should be put in the bat file:

    start /wait MSIEXEC.EXE /i "%~dp0TeamViewer_Host.msi" /qn CUSTOMCONFIGID=xxxxx

    timeout /t 30 /nobreak

    "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assignment --id xxxxxxxxxxxxxxxxxxxxxxxxxxxx


    Instead of using full filepath %~dp0 will tell the bat-file that the MSI is in the same folder as the bat.

    I hope I understood your question correctly.

  • Tony750
    Tony750 Posts: 8 ✭✭

    I am encountering the same issues, but I do not wish to disable the "Use Managed Group Assignment" feature. Currently, I am using the script provided below ;


    start /wait MSIEXEC.EXE /i "%SYSTEMDRIVE%\Temp\TeamViewer_Host.msi" /quiet /qn CUSTOMCONFIGID=YOUR_CUSTOM_CONFIG_ID ENABLEOUTLOOKPLUGIN=false

    timeout /t 30 /nobreak

    "%PROGRAMFILES(x86)\TeamViewer\TeamViewer.exe" assignment --id YOUR_ASSIGNMENT_ID --retries=3 --timeout=120


    However, upon installation, I receive a prompt asking if I want to allow account assignment for the one admin account that I have set up.

  • AntonDobschensky
    AntonDobschensky Posts: 18 ✭✭

    Yeah, I'm in the same situation. Its absurd to have a mass deployment that then prompts. This will be installed on hundreds of machines automatically without user intervention. This needs to be changed.

  • Theseis
    Theseis Posts: 3 ✭✭

    Hello,


    Same here, i'm using this procedure https://community.teamviewer.com/English/kb/articles/109373-deploy-teamviewer-host-or-full-client-9-9 and and the procedure is blocked by the prompt for assignment confirmation.


    disabling "Use Managed Group Assignment" gets around the problem but does not solve it


    Please fix it