TeamViewer Remote’s Free Version Redesign

Options
JeanK
JeanK Posts: 6,991 Community Manager 🌍
edited February 13 in Announcements

Dear TeamViewer Community,

We are excited to announce that we have listened to your feedback and made changes to our free version accordingly. We have adjusted the free version’s feature set to make it easier and more accessible for you to connect with your friends and family remotely.


Changes to the free version

With the free version redesign, free users can now:

  • Use our brand-new web app to establish outgoing connections directly from your browser. No installation is needed. Try it out now!
  • Connect from an unlimited number of devices to establish outgoing connections.
  • Add up to 3 managed devices to their device list.


We have also made some changes to our remote session features set:

  • The Video Conferencing and collaboration functionality is no longer available to free users.
  • The VPN functionality is no longer available to free users.
  • The Wake-On-LAN (WOL) functionality is no longer available to free users.
  • During remote sessions, free users can no longer use VoIP, video, and chat.
  • During file transfer sessions, free users can transfer one file at a time.
  • To connect to Android QuickSupport, free users must use Android QuickSupport 15.37 or higher.


These changes were made to serve our free users better, and we are confident that they will help make your remote connections even more reliable, efficient, and secure.

Thank you for your continued support and feedback.

Happy connecting,

/JeanK

Community Manager

Comments

  • Tony3138
    Tony3138 Posts: 2 ✭✭
    Options

    I use the TeamViewer free account for personnel use. I have 8 devices. I'm trying to set them up for unattended remote access so no one has to be at the desktop when I'm connecting to one of the devices through TeamViewer. It works great of 3 devices but when I try to register the 4th device I get the error that I all ready have 3 active registered devices. What I'm trying to do is register all 8 desktops for unattended remote access but I only need to remote login to 1 desktop at a time. Is there anyway to set this up or am I limited to 3 devices setup as "unattended access" even though I would only need to remote into 1 or 2 at any moment in time?

  • JeanK
    JeanK Posts: 6,991 Community Manager 🌍
    Options

    Hi @Tony3138,

    Thank you for your message!

    You are limited to 3 devices set up as "unattended access" using TeamViewer for personal use, even though you only need to remote into 1 or 2 at any moment in time.

    Let me know if you have any further questions! I'll be happy to assist.

    /JeanK

    Community Manager

  • revaero
    revaero Posts: 1
    Options

    I'm really confused on the wording. It seems like it is saying that we now have the ability to connect up to three devices for unattended access. The wording should reflect the fact that this is actually a limitation and not a new feature, done to try to force free users to pay up or switch software.

  • lovelybaghelary
    lovelybaghelary Posts: 1
    Options

    Thnaks for this information.

  • NRR
    NRR Posts: 9 ✭✭
    Options

    Sorry to tell everyone, but even if you switched to a paid version the new UI is terrible and just doesn't work! Don't waste your money. Find something else..

  • bazbsg
    bazbsg Posts: 112 ✭✭
    Options

    @JeanK there were two messages after my post above that got deleted. One was from you saying thanks for explaining my VPN usage and you would talk to the development team about adding it back in. I said something like if they did I would apologize for jumping to the wrong conclusion. Can I asked if you spoke with the team and what are the chances of getting the VPN restored for free users and how soon? As you can see VPN has legitimate uses for free users in supporting family, friends and themselves. Thanks

  • JeanK
    JeanK Posts: 6,991 Community Manager 🌍
    Options

    Hi @bazbsg,

    Thanks a lot for bringing back the context of the messages. We are still trying to figure out how to bring them back.

    I talked with the team, and at the moment, there is no plan to bring the VPN functionality back for the free license.

    We thank you in advance for your understanding.

    /JeanK

    Community Manager

  • bazbsg
    bazbsg Posts: 112 ✭✭
    Options

    I understand, but I'm afraid I can't say that I'm understanding.

    Now that you have removed the way that I used to do backups between a local and a remote computer, is there any other way to do that with Teamviewer? I used to connect to the remote PC then start the VPN. At that point, I could access the files on the remote PC. I ran a third party program that would first compare two directories and show the differences. Then I could copy the files that are different with the same program.

    I know I can transfer files using Teamviewer without VPN. But if there are a lot of changes then it's easy to miss some files and then they are not backed up. Without the VPN, there is no way I know of that the program can compare the two directories since it can't access the files on the remote PC. Even if it could just read the directory of the remote files then it could run the compare, then I could manually backup using Teamviewer file transfer.

    Thanks...

  • Richard83
    Richard83 Posts: 2 ✭✭
    Options

    If you removed the VPN for the free users could you please advertise that on the app.

    Something like, "Sorry the VPN option is no longer available for free user, but you can upgrade by clicking here." I spent 3 weeks trying to figure out how to get my VPN setting to work and finally found it here, smh. There should not be an option to install VPN adapter if you are a free user. FYI, if you want to be profitable you should advertise that you have to upgrade to use this future on your app.

    Please advertise that on your Teamviewer app, so you don't waste everyone's time. If it was advertised on you app, I would of upgraded by clicking on it.

    Thank You have a great day.

  • ConeWH
    ConeWH Posts: 14 ✭✭
    Options

    I had to reload my PC. When I installed Teamviewer I installed version 15.45.3. WOL works if I go to the web page. I can not find the WOL in the Teamviewer app. Can you tell me where it is?

  • Ronanza
    Ronanza Posts: 1
    edited September 2023
    Options

    What a shame. Why can you please please let us have audio on remote control sessions? We often need to explain what is happening through a dialog....I need to connect to only one remote device. Not multiple.... Please listen to the voice of the customer. Free Personal use should have audio talk enabled!! THat is a very basic feature. I cant afford to pay [removed per Community Guidelines] just for this. I will have to go elsewhere. Really appreciate your support here.

  • anothercalifornian
    anothercalifornian Posts: 2 ✭✭
    edited September 2023
    Options

    I have used TV for many years and now my email account is a Free mode (personal use).

    1. A vendor tried to remotely support me with their software and I could not get the lightweight version to be able to allow them to connect. So I installed the logon version I had used on another computer. It seemed to be good. It even showed my old laptop on the LAN was still running TV. I tried to test connect and it also will not connect. Both sides now logon to my account and are in Free mode. I cannot seem to use it on my LAN, even if it connects it times out and closes fast.
    2. The vendor gave up on my new computer attempt as well and said it just would not connect.

    Should I create a new TV account or am I missing something? I also use TV at work but I know I should not use that account here at home (licensing). I have my old Free account set up at home. Is TV still useable locally on my LAN (Free mode) and for remote support by one of my personal software support agents? I know I have not used it in awhile at home but its up to date. I just seem to be unable to connect. BTW ipv6 is not turned on.


    Regards,

    Michael

  • Logician
    Logician Posts: 10 ✭✭
    Options

    This thread should be pinned, JeanK.

    And theoldmusicman, you should start/have started a new thread. Good luck.

  • jimmccathren
    jimmccathren Posts: 2 ✭✭
    Options

    I would like to hear what is going on at the remote computer and have a USB microphone plugged into it. Remote computer is a Beelink mini PC and the microphone is working. Nothing I've tried is getting sound to the laptop controlling it. Can you please help?

    Thanks!

  • Arjestin
    Arjestin Posts: 4 ✭✭
    edited January 21
    Options

    Hi,

    I'm using a free TeamViewer licence.

    I've reinstalled Windows on my kid's PC and now cannot connect TeamViewer on that device to my account. When adding it as a remote computer, or adding my kid's account as a contact to my TeamViewer client, I get an error message. I am not trying to add a new device. This is an old device, and my kid's account was previously connected to my TeamViewer client. How can I fix this?



  • WhatHappen
    WhatHappen Posts: 2 ✭✭
    edited March 15
    Options

    Yes guys, TeamViewer "listened to us" just like politicians say they listen to the people, that is to say they really don't care.

    First just to write here, read this message:

    ----------------

    Log in to Your Account

    To ensure the continued security of your account, you need to first confirm this browser is a trusted device. We have sent you a confirmation email containing a device authorization link. If you don't receive this verification email within a reasonable amount of time, please check your junk or spam folder. Read further information about trusted devices.

    --------------

    Now, it's not enough for TeamViewer. If you uninstall the "old" version and install the new one, you will need an Account.

    And you will need to confirm at least 3 times before to be able to run the software.


    But it's not enough for TeamViewer. They spy you and look first if you run Windows Enterprise. If so, they are sure at 100% you have your own company.


    But it's not enough for TeamViewer.


    If like in the past, you help, so for free, all miser hate this word, people that you know, well it's not more possible.

    Nah. TeamViewer say you use a "commercial version".

    And so after 15 seconds they disconnect you.


    Yes, they want you to spend [removed per Community Guidelines]/ year to buy their "free" version.


    Want to continue with the "free" version?

    Well, TeamViewer is there for you, of course.


    For the moment, he does not yet ask for a passport, driving license, a blood test to get your DNA, but the way things are going, and the way in which the people don't care about giving out all their personal data and biometrics, another five years and TeamViewer will ask for it.

    Of course, this is all for your own good!


    1984 is really cat pee now, and the funny thing is that the smartphone generation sees absolutely nothing, too absorbed to read all the stupidity, the propaganda, on the Internet.


    So give to TeamViewer (or NSA, CIA, FBI, etc., they pay well to have all information concerning you) your address, phone number, why not your age too and your salary.


    We like so much message from TeamViewer:


    TeamViewer - Unable to connect. Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license. Connections to this partner will be blocked until xx:xx.

    ────────────

    Session timeout! Your TeamViewer session has timed out and will be closed.


    Yes guys, TeamViewer "listened to us" and very deeply...

    God bless Capitalist !!!

  • TedK2121
    TedK2121 Posts: 2 ✭✭
    edited March 22
    Options

    I am using the latest version of Team Viewer and cannot get the VPN to work correctly, seems to connect but will not ping or connect to remote device. have tried re-installing TV and VPN function, disabling firewall. No luck, same on virtual or real machine. I know the remote location is ok because I can access with my old computer. Old computer is using same TV version and OS, W10. Any suggestions are greatly appreciated.

  • Sorinf
    Sorinf Posts: 1
    Options

    I understood that the wol is free, but , when i try to use this function to wakeup a pc from iphone it return error 35 in logs with mention error: no license. So, this service is free and i got an issue or is under some paid license?

    thank you

  • JeanK
    JeanK Posts: 6,991 Community Manager 🌍
    Options

    Hi @Sorinf,

    as mentioned in the post above:

    The Wake-On-LAN (WOL) functionality is no longer available to free users.

    Using WOL requires a license.

    I hope this answered at least your question. 🙂

    /JeanK

    Community Manager

  • Vastmeridian
    Vastmeridian Posts: 1
    edited April 3
    Options

    So much has been removed from the free version that I now have to look for an alternative remote control software - just to look after my 94-year old father in law.

    I've used TeamViewer for many years, but I will have to stop using it now. Your 'basic' plan ([removed per Community Guidelines]/month) is far, far too expensive to even consider for my use.

    You've lost another customer to your company's capitalist greed.

    Thanks and goodbye.

  • Psyllicon
    Psyllicon Posts: 4 ✭✭
    edited April 4
    Options

    @JeanK -- please note that the Free version (at least using the 'old interface') is still 'prompting' for the WOL

    I have attempted to employ it (running another client locally) but confirmed that I must 'go upstairs' to take my laptop out of Sleep mode manually.. - will we be Forced to 'migrate' eventually?

    I can start a new thread, if you'd like - probably not necessary, but I'm not the Boss.

  • JeanK
    JeanK Posts: 6,991 Community Manager 🌍
    Options

    Hi @Psyllicon,

    Thank you for posting here. 🙂

    Hmm... it's weird that you still see the button. Is the button displayed when using the new interface?

    But in the end, WOL is not working, right? This means that the system is preventing you from using WOL with the free version, which is the expected behavior.

    /JeanK

    Community Manager

  • harrryharrry
    harrryharrry Posts: 1
    Options

    Hallo,

    I have exactly same issue. I can connect via TV remote session, but VPN with TV is not working. Cannot even ping. IPv6 is off on both computers.

    Does anyone have an idea?