Updating Devices w/ New UI

Options
jbush
jbush Posts: 46 ✭✭

@JeanK I'd like to add some more to the new UI issues and feedback. So I'm really attempting to adjust, but keep getting taken down at the knees. So devices get added into old and new groups. New groups being updated devices. The UI jsut notes the other devices require an update to "become full functional" which I can only assume will let them join the others in the new group club.

Few things attempted...first it's documented that you can remote to the machine, in the menus is an option to Remote Update. Doesn't work, or nothing launches for me. In another menu, there are options to install hosts and custom hosts...didn't work or launch any installer. Love that idea..if it will work. Last option, I decided to just go to the device and manually re-install the latest host installer over the current. It took the new version, but the device still shows up in the UI as requiring an update and the device still lives in the old group. So far for me at least, it seems the only way I can get my devices in the new cool kid club is to uninstall and reinstall the host client. Not fun.

Any guidance to help get over these issues would be greatly appreciated.

Best Answers

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Answer ✓
    Options

    Hi @jbush,

    Thank you for your message.

    I can see where the confusion comes from.

    The update process that is required for the devices you are mentioning is not about the version that is installed.

    It's a different update that is required: an update from the old to the new device management system.

    You can update your devices to the device management system by following these instructions: Update your devices

    Let me know if this has worked for you!

    /JeanK

    Community Manager

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Answer ✓
    Options

    Now I understand. Indeed, older versions are not compatible with the automated update.

    Performing the update is only possible on devices running TeamViewer (Classic) 15.36 or above.

    For these devices, you might need to:

    This should fix it. If not, please let me know. We'll keep searching for a solution.

    /JeanK

    Community Manager

Answers

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Answer ✓
    Options

    Hi @jbush,

    Thank you for your message.

    I can see where the confusion comes from.

    The update process that is required for the devices you are mentioning is not about the version that is installed.

    It's a different update that is required: an update from the old to the new device management system.

    You can update your devices to the device management system by following these instructions: Update your devices

    Let me know if this has worked for you!

    /JeanK

    Community Manager

  • jbush
    jbush Posts: 46 ✭✭
    Options

    That's just it. I was trying to update a device that says it needs updating because of outdated software. The automated update of newer devices worked as it should. I run that periodically to grab machines as they are online.

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Options

    Indeed, in this context, update can be a confusing term.

    I'm happy that the update worked as expected. 🙌

    I hope to see you around soon again!

    /JeanK

    Community Manager

  • jbush
    jbush Posts: 46 ✭✭
    Options

    No it didn't. I was attempting to update an older device because of outdated software. That is the machine I tried the multiple different avenues to update.


    Machines that do have more current version installed will accept the pushed update. Older versions do not even when remoted into the device and using the install tools in the menus.

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Answer ✓
    Options

    Now I understand. Indeed, older versions are not compatible with the automated update.

    Performing the update is only possible on devices running TeamViewer (Classic) 15.36 or above.

    For these devices, you might need to:

    This should fix it. If not, please let me know. We'll keep searching for a solution.

    /JeanK

    Community Manager

  • jbush
    jbush Posts: 46 ✭✭
    Options

    That's it. The uninstall/reinstall is where I where I landed to fix it. I was hoping there was a better solution, but I guess it is what is. Thanks Jean.