Auto Device Assignment (Modern)

TVAC9
TVAC9 Posts: 2 ✭✭
edited February 16 in Deployment & Integrations

Hello, I'm doing a mass upgrade to v15 and I'm building custom module and policy in the console 15.43.8 not in the classic management console (web)

I am able to install the module, which has a Rollout Setup selected. The rollout setup (which could only be configured in web) assigns all devices to the Master TV account, and inherits policy from a device group.

The device group has policies assigned, created in the console (back to the 15.43.8 console)

I install the module and get my customisations, but also this..

NOTE it says TWO managers. Click allow and finish I'm left with "Manage this device"



When clicking manage this device as a standard user..


Everytime the computer restarts, you get the 2 managers allow and finish window, and the "manage this device" you can't at this point remote the device even using the teamviewer ID and password, doesn't work.


UNTIL....

So I fully close teamviewer and run it once as an administrator (just a desktop admin - nothing to do with teamviewer)

Click "Allow and finish" and...


Managed by FIVE managers. (which is actually correct) everything works as expected. (I didn't have to do any login, just worked when I clicked Manage this device)

Questions..

1) I need a silent method of installing this module. In 15 I only get the option to download an exe. I did find this article..

Deploy TeamViewer (Host or full client) - 9/9 - TeamViewer Support

But this doesn't work either, infact it doesn't look like it's applying the assignment ID (I used the first example for simplicty)

I note there are NO API keys for a "Modern" Module either?


2) How can I get the module to just register the without having to run it once as an admin?


Tried this on 2 test vms a dozen times trying various tweaks and I simply cannot get new installs to drop into device management.


Thanks for any assistance!


FYI - the policy settings frequently just disappear in the console, like none have been created but are visible in the classic management portal. That's an issue too.

Tagged:

Answers

  • He have exactly the same case here, any support tech can reply us ?

  • BenvicJulienDijon
    BenvicJulienDijon Posts: 5 ✭✭
    edited September 2023

    support answer :

    Older deployment methods such as GPO and .mst transformation files are unfortunately not supported by TeamViewer and could have issues.

    We advise to install .MSI packages either via directly running/pushing a .bat file which have the install command and all the parameters or through MDM deployment software such as Microsoft Endpoint Manager ( inTune ). 

    As per the screenshot seems that the module is not set up for mass deployment. If the “Use Managed Group Assignment” is ticked - a pop-up will appear to confirm the account assignment at the end of the installation;if is unticked - no pop-up will appear to confirm the account assignment at the end of the installation 

    I added [removed per Community Guidelines] a example script which has the uninstall and install command.

    You need to modify these variables with your own:

    %~dp0TeamViewer_Host.msi - the location of the file( if the script is not in the same location with the msi)

    YOUR_CUSTOM_CONFIG_ID - how to create it https://community.teamviewer.com/English/kb/articles/109367-create-your-module-3-9

    1. Log into the Management Console: https://login.teamviewer.com/
    2. Click on Design and Deploy
    3. Click on the plus sign (+), then select Host.
    4. Customise your module by adding your corporate identity (logo, custom text, etc.)
    5. Untick all the boxes as shown below and click Save.

     

     and the YOUR_ASSIGNMENT_ID - https://community.teamviewer.com/English/kb/articles/109371-create-an-assignment-configuration-7-9

     

    As I mentrioned i f you want to use a GPO this is not part of our support you could save the script as a .bat file and add it as a startup script in the GPO.

    That is what most customer do when deploying via GPO:

    Within the group policy console you can go to computer configuration > Policies > Windows Settings > Scripts > startup > click add to select the bat file you want to setup for running whenever the computer starts next time.

  • TVAC9
    TVAC9 Posts: 2 ✭✭

    Hi thanks for the reply.

    Installations are being done in our environment via SCCM with the .bat file no gpos - since posting the issue a couple of admin console updates have been released that have helped with some of the issues.

    I think there are two areas for improvement however.

    1) Imaging devices - a typical IT process, we have teamviewer installed via Task Sequence during Operating System Deployment. The second command in the bat file during installation doesn't lend itself very well to this type of OSD enironment - indeed, I've found it unreliable.

    2) You're obviously going through a lot of development work moving over to v15 and modern device management, I suggest a rethink on how the client is deployed - ideally we'd be wanting to avoid running secondary commands to assign the client to a particular assignment ID, many businesses run hybrid setups and you have a point of failure if the endpoint is remote - in my option relying on GPOs in this way is pretty old hat.

    May I suggest a rethink in terms of when a custom module is created, all the key elements like the assignment id being made part of the installation or supported via msiexec be considered instead? I'm fully supportive of having everything in the modern console and the goal should be "make a module, deploy it" that drops it into the given Device Management group where it picks up it's polices without additional post installation steps needed.

  • I totally Agree! i have said this for years, all the assignment ID and Grouping + naming with --alias should be done all in one with the custom installer MSI, other companies have done this, im confused as to why TV are still clinging on to the old way.

    With regards to SCCM we are running the same enviro as yours, we deploy TV with PowerShell instead of BAT.

    As a company we have lost faith in TV to create Custom modules that do what you want without having to do scripting/bat files/GPO's maybe its time to look elsewhere.

  • I have the same problem with the new interface.

    I can download a custom exe module with the new teamviewer host console. I can also install that exe sillently iwht the /S argument. but then with starting up it naggs about the account assignment. I would like to enroll this new version with intune but if this is not solved i cannot continue.


    Any advice?

  • Good_SC
    Good_SC Posts: 1

    Exact same problem here.


    I have tried with a batch file as below. Silent mode fails to install the teamviewer client ( no errors shown just returns to command prompt, im forced to use passive mode.

    Batch file contains:

    start /wait MSIEXEC.EXE /i "TeamViewer_Host.msi" /passive CUSTOMCONFIGID=YOURIDGOESHERE ENABLEOUTLOOKPLUGIN="false" DESKTOPSHORTCUTS=0 ASSIGNMENTOPTIONS="--alias %COMPUTERNAME% --reassign"

    timeout /t 20 /nobreak

    "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assignment --id yourassignmentIDgoeshere


    The device has internet connection ( it'll never apply the config if it doesnt at time of running)

    Sometimes it works and assigns it, sometimes it doesnt. I've tried repeating the last 2 lines of the batch file 3x to try assigning again incase its not ready. No errors produced, it just doesnt work.


    Support have been non-responsive. I fail to understand why the customconfig has a tick box for assignment, yet you have to run a 2nd command to do the actual assignment!?

  • flospi
    flospi Posts: 45 ✭✭
    edited September 2023

    Following steps work for us without any problem:

    1) In the Custom Module that you define in the WebConsole: Deactivate "Use Managed Group assignment"!!! Activate "Allow Account assignment". The rest doesn't really matter... yes I know it makes no real sense for some...

    2) Create your Assignment...

    3) The installation with the MSI is very plain and simple and not using to much options (I think I use most of the ones that kind of make sense:

    msiexec.exe /i "%~dp0TeamViewer_Host.msi" /qn ADDLOCAL=ALL REMOVE=f.DesktopShortcut ENABLEOUTLOOKPLUGIN="false" CUSTOMCONFIGID=*

    4) Pause for 20-30 seconds

    5) Assignment is also very basic (once again I use more or less all of the options that make sense):

    "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assignment --id *** --device-alias %COMPUTERNAME% --retries=10 --timeout=60

    So, in the MSI there is no more "reassign" or "hostname". Thats basically all moved to the second part.


    PS: Support is under water right now due to too many little bugs and flaws. They had a lot of good ideas with the new group management and I think that most of it was implemented on the technical layer pretty well. But they haven't implemented to well in the user interface... as you can see by the differences between the webconsole and the new client.

  • Eirinn
    Eirinn Posts: 3 ✭✭

    I'm trying to move the automatic installation to managed groups. So far I was able to deploy the app, but I still have that issue with the assignment, which has to be done by clicking the popup via a user with admin privileges.

    What I understand from your post is that you are able to deploy the app and do the assignment via that script (so assignment at point 5)? for info, I'm using Intune for deployment.

  • flospi
    flospi Posts: 45 ✭✭

    Check Step 1) from my list... You have to deactivate "Use Managed Group assignment"...

  • Eirinn
    Eirinn Posts: 3 ✭✭

    just to reply to myself, yes, the last bit is what makes the assignment for the managed group. A simple bat file deployed along with the msi in the intunewin file is all you need for intune win32 deployment.

  • IT_Engineer88
    IT_Engineer88 Posts: 2 ✭✭

    Can you explain this part, creating the bat along with the intunewin? I'm able to get the client installed, but I need to get that last part intergraded so I don't have to migrate devices through the management console every single time.

  • ScrubLord
    ScrubLord Posts: 1

    Except these steps are for the old console and not the new one like OP stated. When making the custom module in the modern console you see this:

    There is no option to deactivate managed group assignment like you're suggesting. Why assignment IDs aren't an option for the .msi is beyond my understanding.

  • wsucppsits
    wsucppsits Posts: 4 ✭✭

    I am having the same issue and the only work around I have found is to use the classic custom module with everything else modern.

  • flospi
    flospi Posts: 45 ✭✭

    Yes, you do create a module that looks as if it will be used in TeamViewer Classic... But did you get a look at my Step 5)? Here you use the Assignment ID from the new "Assignment", not the old one... so the setup is a nonsensical mix of old and new...

    It works for us in general! At least 150 installations have been done already.

  • Sweeny
    Sweeny Posts: 3 ✭✭

    I'd like to thank you so much! I've been losing my mind over this insanely difficult deployment based on all of the outdated information in TeamViewers articles.

    For those of you stumbling upon this like I did, if you're using Powershell, you'll need to adjust a little. Here's my example.

    $pkg = (path to your .msi file, I had to use GPO to move mine from a network folder to the users local Public Documents as a hidden item to get it to work)

    Start-Process msiexec "/i $pkg /qn CUSTOMCONFIGID=xxxxxxx" -wait

    Start-Sleep -Seconds 20

    Start-Process -FilePath "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" -ArgumentList "assignment", "--device-alias=%computername%", "--id (your Assignment ID here (from the Assignment Tab in the Design & Deploy tab in the web client))", "--retries=10", "--timeout=60"

    I am going to try using an immediate task in GPO, we'll see though, I may use a startup script instead. Hope this helps!

  • DCho
    DCho Posts: 3 ✭✭

    Guys it's a bit vague what you are saying here.

    you mention the MSI but I believe you are repackaging in a Win32 with a PS/Bat script right?

  • WCSD_DOT1
    WCSD_DOT1 Posts: 5 ✭✭

    there should not be so many convoluted methods and locations on

  • WCSD_DOT1
    WCSD_DOT1 Posts: 5 ✭✭

    this is in the old console though not the new...TV any fix for the new console??

  • Sweeny
    Sweeny Posts: 3 ✭✭

    No, I'm not repackaging it, just using the $pkg variable to show where the file path to my .msi installer is located at. Let me know if you have any questions.

  • eillinois43
    eillinois43 Posts: 1 Newbie

    I am glad I found this post, that 'allow account assignment' is the way to not have the 'company assignment' dialog box come up asking to allow and finish. This should be added to the custom modules in the new interface TeamViewer

    Mass deployment on Windows - Overview - TeamViewer Support

    start /wait MSIEXEC.EXE /i "TeamViewer_Host.msi" /qn CUSTOMCONFIGID=#########

    cd "C:\Program Files\TeamViewer\" 

    TeamViewer.exe assignment --id ##################################################