Inquiry Regarding Connectivity Issues with the Latest Version of TeamViewer

Good morning,

I would like to describe my current situation: I use TeamViewer to access another computer from my personal one. After updating to the latest version of TeamViewer (15.48.5), I have encountered a problem when trying to connect to the other computer, which has an AMD graphics card. When attempting the connection, the following message appears: "No physical monitor connected - virtual fallback monitor of TeamViewer", despite having monitors connected. Furthermore, I have noticed a delayed response when interacting with the screen (lack of fluidity and responsiveness).

To solve this issue, I had to revert to an earlier version of TeamViewer, after which the problem disappeared. Has anyone else experienced this issue with the latest version of TeamViewer? Do you know if there is work being done to resolve this problem?

Thank you very much.

Answers

  • gkrol
    gkrol Posts: 2 ✭✭

    i am having the same issue connecting to many machines, especially laptops using 15.48.5

    Thanks

  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍

    Hi @AbelLaaouaj, hi @gkrol,

    Thanks a lot for sharing the issue you are experiencing.

    I asked our dedicated team and will revert as soon as I have news to share.

    Have a great day,

    /JeanK

    Community Manager

  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍

    @AbelLaaouaj @gkrockman1959

    As a first step, could you please update the impacted devices to the current latest version 15.49.2, and see if the update fixes the issue?

    /JeanK

    Community Manager

  • AbelLaaouaj
    AbelLaaouaj Posts: 4 ✭✭

    @JeanK

    Hello, I just updated to version 15.49.2 and the same issue is still occurring.

    Thank you.

  • gkrol
    gkrol Posts: 2 ✭✭

    @JeanK I also still have the same issue.

    Thanks

  • Raymond1020
    Raymond1020 Posts: 2 ✭✭

    hello

    I have same issue

    this message is continuing to appear in the upper right corner of the screen


  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍

    Hi all,

    Thanks a lot for reporting the issue.

    Our team is currently investigating; I'll keep you posted!

    Merry Christmas, everyone! 🎄

    /JeanK

    Community Manager

  • Raymond1020
    Raymond1020 Posts: 2 ✭✭

    hello

    some information update

    is this about the OS win 11 or win 10?

    coz when i connected to other computer which is win 10, its working well, no issue

    but it happened in OS win 11

    and I’ve noticed that I did setup the quality to customize as lowest before the connection, and it’s will automatically adjust to highest quality with no changed (win 11)

    again, win10 is working well, it’s exactly the quality what I setup before the connection!


    by the way, sorry for my poor English, please let me know if you don’t understand what I’m trying to describe


    merry Xmas and happy new coming year to everyone!

  • davidbcdd
    davidbcdd Posts: 5 ✭✭

    I just have a white screen when trying to connect to a computer that does not have the monitor powered on. It's stuck on the connecting screen and won't go any further. It used to work correctly.

  • ate24
    ate24 Posts: 1
    edited December 2023

    Could you let us opt out of this function? Since I have a customized resolution for a monitor-less PC (1600x900) which I don't have to zoom in or out, this function disrupts everything by forcing a different resolution to me, say 1920x1080, which zooms way too large for my laptop so that I have to use it in full-screen environment.

  • KRT
    KRT Posts: 4 ✭✭

    I am having the same issue, have submitted a ticket to support but still do not have a solution.

    It may be connected with the "Virtual Monitor Adapter" that TeamViewer has installed.

    I am still waiting for an answer on how to safely uninstall this from a remote connection.

    My physical display adaptor is a NVIDIA GeForce GTX 1660.

  • JDSx
    JDSx Posts: 6 ✭✭

    I am seeing a lot of messages, about 20 of them, as shown below when I connect to one of my devices. This is happening since a few weeks, allthough the message was shown in a different way first.


    Why is this and what can I do to stop this?

    I am on TeamViewer version 15.48.5 (32 bit), dated december 4, 2023. This is on a laptop that I switch on, wait for the login to appear and then I close the lid to connect to it from another PC.

  • winnerace
    winnerace Posts: 1

    I have encoutered similar issues using the latest version. periodically it prompts the attached two messages.

    The monitor (actually a TV) that connects to my remote PC is off when I use TeamViewer to connect, and the graphic card is a GeForce RTX 4070 Ti.

    Hope this can be fixed in the new version.

  • Scott_Baron
    Scott_Baron Posts: 1
    edited January 4

    We are experiencing the same thing at our company and find its when we connect 15.49.2 of teamviewer to the same version on another pc.

    when we connect to that same pc with version 15.21.6 the popups don't come up.

    what is odd is that this doesn't happen when connecting to all pc's with the 15.49.2 but any computer i connect to this 1 pc gets the popup.

    also when my co-worker installed the 15.49.2 on his pc, it installed alongside 15.21.6 instead of removing it, and the start menu icon continued to point to the old version.

    we are running on dell latitude laptops with Intel UHD Graphics adapters. connecting to a dell latitude laptop with no external displays.

  • skilset
    skilset Posts: 3 ✭✭

    I'm experiencing the same issue when I try to connect. I'm on version 15.49.2 as is the host PC. Every time I connect to it, I get the same error. I can still access the system and do what I need to. But, it is now a slower connection... and there is definitely a working monitor physically connected to it.

    Please help...:)

  • skilset
    skilset Posts: 3 ✭✭

    Sorry... I forget to mention that both systems are on Windows 10. I'm on the Home version and the host system is on Pro.

  • KRT
    KRT Posts: 4 ✭✭
    edited January 5

    TeamViewer support asked me to install registry keys

    HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\DisableVirtualMonitor REG_DWORD, value 1

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\TeamViewer\DisableVirtualMonitor REG_DWORD, value 1

    remove the TeamViewer virtual monitor/display adaptor drivers (again) and restart the TeamViewer service.

    This did not work, even after a reboot. TeamViewer simply re-installed the virtual drivers.

    On a hunch I set the registry key HKEY_CURRENT_USER\Software\TeamViewer\DisableVirtualMonitor REG_DWORD, value 1

    This did work after a reboot and I am back to the correct number of monitors.

  • AndreLeBlanc
    AndreLeBlanc Posts: 2 ✭✭

    @KRT

    Did you make those registry changes on the control PC or the remote PC?

  • mpountouris
    mpountouris Posts: 1 Newbie

    When in appears


    I take remote image without remote control features.

    To fix it i restart the Server from Teamviewer Menu - Remote Restart.

  • gonespeed
    gonespeed Posts: 12 ✭✭

    it seems Teamviewer does not care whoever cannot connect while monitor is off. I have been searching about this connection issues, none solution pops up from Teamviewer. I tried many many ways, still no luck, I have enough about this, just waste of time. I have only 2 months business membership left, must move to other program.

  • JenW
    JenW Posts: 968 Moderator

    Hi all,

    We are happy to announce that we have fixed the bug regarding connectivity issues and the monitor messages popping up.

    We invite you to update TeamViewer to the latest version.

    Also, feel free to have a look at our changelogs: 👉 [Windows] v15.50.5

    We thank you all for your patience and wishing you a great day,

    Jen

    Modératrice Communauté Francophone 💌 French Community Moderator

  • Seemon
    Seemon Posts: 1

    Installed v15.50.5 on client (Windows 11) and server (Windows 10). Problem still exists. No change!!

  • JenW
    JenW Posts: 968 Moderator

    Hi @Seemon,

    Thank you for your comment.

    We're sorry to hear that the issue persists on your side.

    Before going further into the investigation, we invite you to uninstall TeamViewer completely from the client Windows 11, and the server Windows 10.

    Here is the article that guides you step by step: 📄 Uninstall TeamViewer Remote on Windows

    After the fresh installation of the newest version, please establish a connection and come back to us with the results.

    Best,

    Jen

    Modératrice Communauté Francophone 💌 French Community Moderator

  • derekc
    derekc Posts: 10 ✭✭

    No kidding. I now have to uninstall and reinstall all my clients. Sigh.

  • Roockie
    Roockie Posts: 2 ✭✭
    edited February 5

    Hello all,

    @JenW @JeanK

    I have exactly the same problems as the others, I have several servers running without external monitors connected.

    When I connect, I can't take control, I have to restart the server... I have to inform the users, when I have to make a few changes, it's very blocking.

    It's very problematic, I didn't have any problems before 15.45, I think.

    This is VERY URGENT !!!!! The last Teamviewer update (15.50) didn't help.

    Thank you for your understanding !

  • Quiche_NY
    Quiche_NY Posts: 2 ✭✭

    I have the same issue with 15.51.6. Uninstall/reinstall did not help.

    "No physical monitor detected on remote device. Virtual monitor could not be activated."

  • Quiche_NY
    Quiche_NY Posts: 2 ✭✭

    Might I add that this is a laptop that is not connected to an external monitor, simply using the laptop screen. This issue does not prevent using TeamViewer (I only use TeamViewer to help my aging parents when they have computer questions), but it's annoying to have to click on this message, often 5-10 of them, before I can proceed.