teamviewer.com link icon
or
Ask The Community

Teamviewer asks for password (RDS/Citrix)

Hi guys

I have observed a strange phenomenon with Teamviewer. When are logged into your Teamviewer Account on a Terminal Server and you try to connect to another client, where easy access is configured and no password is set, i get the following Message :

The password you have entered is invalid, please try again

There is no clear pattern when the connections work and when not. I have even included new remote machines to our account with different configurations and a brand-new Teamviewer installation. Before we had Version 7 installed on our local and remote side, it worked fine.

It doesn't play a role if you have the following Versions installed on the remote or local clients:

  • 12.0.78313
  • 12.0.83369
  • 12.0.85060 (Insider)

On the remote machines log files i get the following messages:

 

CLoginServer::CheckIfConnectionIsAllowed()

LoginServer::runServer: using condition set: {}

CLoginServer::AuthenticateServer()

AuthenticationPublicKey_Passive::Verify: Permission Denied

 

There is no problem when you establish your connection from a physical machine, logged into your Teamviewer account, trying to connect to a remote client.

I have tested serveral different RDS Server environments to exclude a problem related to our infrastructure.

This is very urgent, because many big companies have a Virtual Desktop Infrastructure and user Teamviewer as their daily remote connection tool.

Sincerely

A Teamviewer User

 

 

Sign In or Register to comment.