Debian 8 headless setup problem (Teamviewer-host)

Options
junglejet
junglejet Posts: 2 ✭✭
 

I have successfully installed teamviewer-host on a Rpi. However on a Beaglebone Black with Debian 8 I encounter the following messages when running setup (the user is root):

 :~# teamviewer setup
TeamViewer daemon is not running, setup cannot continue. Please activate the
TeamViewer daemon before invoking setup.

When I run daemon status or systemctl status teamviewerd everything seems to be fine:

:~# teamviewer daemon status

systemctl status teamviewerd.service
● teamviewerd.service - TeamViewer remote control daemon
Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled)
Active: active (running) since Sun 2017-10-08 10:12:58 UTC; 10min ago
Process: 7090 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
Main PID: 7092 (teamviewerd)
CGroup: /system.slice/teamviewerd.service
└─7092 /opt/teamviewer/tv_bin/teamviewerd -d

When I start teamviewer (to launch teamviewer-host) the progamm fails to return, it does not even show the "Aborted" message. In the task list, but there is a double entry for teamviewer, which does not seem normal to me.

:~# teamviewer

Init...
CheckCPU: armv7l
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

=== does not return ===

ps -e

...

8892 pts/0 00:00:00 TeamViewer
8942 pts/0 00:00:00 TeamViewer
8998 pts/1 00:00:00 ps

Please help.

Andy

Comments

  • junglejet
    junglejet Posts: 2 ✭✭
    Options

    More details:

    the Teamviewer ID is missing

    :~# teamviewer info

    TeamViewer 12.1.83885 (DEB)

    TeamViewer ID:
    Try restarting the TeamViewer daemon (e.g. teamviewer --daemon restart)

    teamviewerd status ● teamviewerd.service - TeamViewer remote control daemon
    Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled)
    Active: active (running) since Sun 2017-10-08 18:29:21 UTC; 3s ago
    Process: 3514 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
    Main PID: 3516 (teamviewerd)
    CGroup: /system.slice/teamviewerd.service
    └─3516 /opt/teamviewer/tv_bin/teamviewerd -d

    "teamviewer license" dies when called

    I then found the logfile and compare it to the Rpi log. Things go wrong here:

    2017/10/08 18:38:35.295 4716 3070066688 S Using IPC-Port 5939
    2017/10/08 18:38:35.298 4716 3070066688 S UpdateOnlineState newOnlineValue 0
    2017/10/08 18:38:35.305 4716 2954881632 S Using systemd-logind for suspend/resume monitoring
    2017/10/08 18:38:36.227 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:38.229 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:40.230 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:42.231 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:44.232 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:46.233 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:48.234 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:50.235 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:52.236 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:54.237 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:56.238 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:38:58.239 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:00.240 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:02.241 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:04.242 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:06.244 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:08.245 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:10.246 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:12.247 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:14.248 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:16.249 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:18.250 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:20.251 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:22.252 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:24.253 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:26.254 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25
    2017/10/08 18:39:25.601 4886 3025375232 C Logger started.
    2017/10/08 18:39:25.610 4886 3025375232 C Found 0 Minidump files ...
    2017/10/08 18:39:25.627 4886 3025375232 C systemd: logind service available
    2017/10/08 18:39:25.643 4886 3025375232 C systemd: New seat seat0 [path=/org/freedesktop/login1/seat/seat0, activeSession='', canGraphical=0, canTTY=1, canMultiSession=1]
    2017/10/08 18:39:25.656 4886 3025375232 C SysSessionInfoManager: observing sessions from logind is marked as reliable
    2017/10/08 18:39:25.656 4886 3025375232 C SysSessionInfoManager: Session Information provided by VT [priority: 2]
    2017/10/08 18:39:25.657 4886 3025375232 C! FrameBuffer: Cannot access /dev/fb0, frame buffer support unavailable
    2017/10/08 18:39:25.664 4886 3025375232 C!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=2
    2017/10/08 18:39:27.747 4886 3025375232 C InterProcessBase::SecureNetwork created
    2017/10/08 18:39:27.782 4886 2954884112 C InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    2017/10/08 18:39:27.783 4886 2954884112 C Opening local TCP connection to 127.0.0.1:5939
    2017/10/08 18:39:27.786 4716 3038767712 S CAcceptServer::HandleAccept: new connection from 127.0.0.1:47743
    2017/10/08 18:39:27.787 4886 2996827152 C Local TCP connection established
    2017/10/08 18:39:27.833 4716 3047156320 S!! DBus::Connection::HandleAsyncReply: Message Type is of error., Errorcode=11
    2017/10/08 18:39:27.835 4716 3038767712 S!! Process IPC connection failed, session not found: type = 1048576 pid = 4886
    2017/10/08 18:39:28.255 4716 3030379104 S!! LinuxVT::GetActiveVT: error=25 consoleFD=-2, Errorcode=25

    The reason may be that there is no autologin present on Debian 8, but this goes beyond my skills.