Not ready. Please check your connection after upgrade to v12



  • TcoUpLoad
    TcoUpLoad Posts: 2

    i know this is a reply to an old question but next time search in and for your search has this link teamviewer v11 and others

  • ahasbini
    ahasbini Posts: 1

    Exit Teamviewer, open task manager and go to Services tab, find Teamviewer serivce, right click and stop. Wait until it's Status changes to stop. Then open Teamviewer again and now it connects.

  • smart2017
    smart2017 Posts: 1

    I have the same problem and i have reebooth and upgrade but its still not working

  • LadyTramp
    LadyTramp Posts: 1

    @MSunThis worked for me... Thank you

  • Ales
    Ales Posts: 4

    oiram wrote: 
    sudo apt install libnss-resolve:i386

    That finally helped! I wonder how did you figure it out but thanks a lot.

  • oiram
    oiram Posts: 3

    I suspected it was a problem with Wine and the network, and because all worked fine until I have installed Ubuntu 17.04 I have take a look to the release notes discovering Canonical changed the support for DNS, so I googled looking for people having a similar problem with Wine and network comunication after the update to Ubuntu 17.04 and I found the solution :)

  • subho
    subho Posts: 1

    I was facing the same problem with v12 on Windows 10.....and it is solved after the Microsoft .NET Framework 4.7 for Windows 10 Version 1607 and Windows Server 2016 for x64 (KB3186568) update. So I believe the problem was in Windows 10 and not in Teamviwer.

    I hope this will help.

  • sudo service teamviewerd restart

    This works for me. Thank u very much

  • SashaS
    SashaS Posts: 1

    @oiram wrote:

    I have resolved on Ubuntu 17.04 executing in a terminal the following command:

    sudo apt install libnss-resolve:i386

    Excellent! The only real thing which worked for me (ubuntu 16.10).

  • Omg! Thank you! You save me!

  • Elder-Geek
    Elder-Geek Posts: 1

    This did the trick for me.  I tried stopping the Teamviewer service and it didn't stop.  I then used Task Manager to stop the service.   The service was still marked at stopping.  I then tried to stop it again and it was finally marked as stopped.  I then started the service and all is now working perfectly.

  • Thanks! This worked for me also.

  • After reading  lots of comments and try many recommendations, I was successed when disable "Internet protocol Version 6(IPv6)", disable IPv6 at Lan/Wifi properties(not at router), just uncheck this option, I work like a boss. Please view the link below to detail

    Fix teamviewer v12 connection on window 10

    Nice day!

  • HI!

    On Windows 10 I had same problem.

    I stopped teamviewer services. On Teamview option I disable start with system.
    After reboot teamviewer worked fine.

  • No, Its not working did that.

  • Thanks!!

  • Fixed after starting VPN :|

  • I've had to kill the background process for teamviewer and start it up again. Generally I get this when I lose internet and get it back again.

    As a workaround, I wrote a .bat file that essentially kills Teamviewer and all of it's background processes, then start it up again and it works.

    taskkill /f /im teamviewer.exe
    taskkill /f /im tv_x64.exe
    taskkill /f /im tv_w32.exe

  • GlenB
    GlenB Posts: 6

    Same error message. Have been running TV12 on Win10 for weeks with no troubles. Then this started. I have not knowingly changed any of my network configuration.But I checked.

    1 - Windows Firewall is on and there are rules to let TV and TV-service run over TCP and UDP.

    2 - My adapter has IPv6 off and has ALWAYS had it off.

    3 - I used Task Mgr to get rid of any and all instances of TV andthen restarted the program.

    4 - "Check for updates" says that I am already up to date.

    None of those made the slightest difference. So I downloaded the install package and ran it again and now it all seems fine.

    Not helpful to have NO IDEA what got messed up or how it happened. The error message is particularly uninformative, making a suggestion about Proxies which I don't use but have always had set as self-discover.

  • aquintanar
    aquintanar Posts: 1


    I get the same message.  I was working pretty nice for several months.  I upgraded some times and increase the version without any problem. But since some days ago, I get the message "Not ready. Please check your connection".

    I upgraded to the version 13 Beta and until now everything works great for me.

    Kind regards.

  • mcochi
    mcochi Posts: 3 ✭✭

    The issue was IPv6. I disabled it and it worked fine.

    Running Win 10 Home OS

  • GlenB
    GlenB Posts: 6

    My router does not support IPv6 so I never enabled it. Unless TV messes with my net config (which it should not without letting me know) then there is some other reason for the problem.  

    Seems that it eventually goes away all on its own ... further evidence that the problem is not my configuration. Of course if it can go away, then it can come back.  

    We really need a better explanation and not something that is assumed because they seemed to happen at the same time.

  • Rps
    Rps Posts: 1

    Thanks it worked.

  • This workaround works for me, for other people with the same issue before try to restart your teamviewerd service before modify the  /etc/systemd/system/teamviewerd.service. If after the service restar teamviewer is online go a head to modify the config file. @Bloodhound Thanks for the solution.

  • edstrait
    edstrait Posts: 1

    This is the one that worked for me. Stopped teamview, renamed the /etc/teamviewer/globla.conf to .old restarted Teamviewer and all was golden.

  • getinto-pc
    getinto-pc Posts: 1

    thanks for ur info.

    download here the required software at getinto-pc

  • Ray666
    Ray666 Posts: 1
    Same problem, caused by Avast web shield