teamviewer.com link icon
or
Ask The Community

Team Viewer 13 installs but will not open

I have a Windows 7 X64 laptop that worked just fine with Team Viewer 12.  Upgraded to Team Viewer 13 and was having issues whenever I tried to connect to another PC from this Windows 7 laptop (it would log out my Team Viewer account and never connect).  I uninstalled 13 and re-installed 12 and verified everything worked again.  I upgraded to 13 again and now it shows it is installed, but the program will not run (check task manager under Processes and Team Viewer is not listed and the Service is not running).  Need some assistance with this as Team Viewer 13 works on all of the other computers that I have tested it on.

Comments

  • Serge2
    Serge2 Posts: 1

    Hi,

    Do you have any updates on this issue?

    I have the same problem. During the update it says
    http://prntscr.com/j4f0rl

    The TV13Install.log has a lot of errors. They start with

    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\.tvs\=TeamViewerSession
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerSession\shell=
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerSession\shell\open=
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerSession\shell\open\command=
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerSession\shell\open\command\="C:\Program Files (x86)\TeamViewer\TeamViewer.exe" --play "%1"
    CreateRegValWithRollback(): Error!!! Registry value could not be written. (EC5)
    WriteRegValueWithRollback(): Error!!! Registry value HKEY_CLASSES_ROOT\TeamViewerSession\shell\open\command\ could not be written. (EC5)
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Warning! Can't write registry value HKEY_CLASSES_ROOT\TeamViewerSession\shell\open\command\="C:\Program Files (x86)\TeamViewer\TeamViewer.exe" --play "%1".
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerSession\DefaultIcon=
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerSession\DefaultIcon\="C:\Program Files (x86)\TeamViewer\TeamViewer.exe",0
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\.tvc\=TeamViewerConfiguration
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerConfiguration\shell=
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerConfiguration\shell\open=
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerConfiguration\shell\open\command=
    2018-04-12-11-11-46 WriteRegChanges(WRITE_STRING): Write registry value HKEY_CLASSES_ROOT\TeamViewerConfiguration\shell\open\command\="C:\Program Files (x86)\TeamViewer\TeamViewer.exe" --control "%1"

    And in the end it says
    2018-04-12-11-11-54 InstallTeamViewer(): Run TeamViewer service...
    2018-04-12-11-11-54 InstallTeamViewer(): Error!!! The TeamViewer service could not be started. The installation will be continued.
    2018-04-12-11-11-54 InstallTeamViewer(): Start TeamViewer.exe...
    2018-04-12-11-11-55 InstallTeamViewer(): Error!!! TeamViewer.exe could not be started.
    2018-04-12-11-11-55 Set update progress (handle:980, msg:PROGRESS:100 last error:0)
    2018-04-12-11-11-56 InstallTeamViewer(): Installation finished.

    The TV service is not on the list and when I try to run it manually from the TV folder it says
    http://prntscr.com/j4f522

    The same message if I try to run TV from there.

    The shortcut is weird too
    http://prntscr.com/j4fa36

    Thanks.

  • I have the same issue

     

Sign In or Register to comment.