team Viewer 13 is a MESS!


I tried team viewer 13 on a couple of remote sessions from my Ubuntu 14.04 based system .

Connection to a windows system was fine, no issues.

I connected to a Linux Mint 17 system successfully and had multiple disconnects each one requiring a reboot to close the failed connection.

Installed on a Linux Mint 18.x system for remote access to that system, and it would never show the icon in lower right corner . When you ask to launch a program you should not then have to look for a small icon to actually open it! Tried reverting back to team viewer 11 and now it says the daemeon is not running.


I have spent (wasted) the better part of a day on team viewer today and mty time is worth something. 


your forced upgrades cause more headaches than its worth.


I may be kissing team viewer goodbye keeping machines on same version across platforms is too challenging 




  • Ketterer
    Ketterer Posts: 7 ✭✭
    If you would like to help you can submit bug reports and extra details to help the team. You can also fill out the Linux survey and keep an eye out for the next update that we stood hopefully see on the next 2 weeks.

    Best with them, program maybe native for Linux with no more wine needed. This is great news as it'll be a lot more Snappy as well as a lot more integrated in the future. They have already showing but they are dedicated to creating a client that is on par with every other operating system. They also seem to be acting up to be able to have Weiland support soon. So if you just hold on to a little bit of patience for the next while I'm sure you'll be happy with what TeamViewer is delivers in the next few months. They've given us basic functionality as well as one or two little extras and it won't be long I would say till we have most of the general features that are on every other.
  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @markosjal, if you don't have a tray icon, then (most likely) either your desktop environment does not support them or TeamViewer could not start successfully.

    If TeamViewer is started automatically on login, it is started in the background (like all well-behaving applications do). If you start it manually from the menu, it should always start in the foreground, or come to the foreground if it was already running.

    After installing [Update: 13.0.9865] File Transfer & Chat, if you still experience these problems, I need more data to get them fixed for the March release. Name your desktop environment and the exact steps how you start TeamViewer and what happens then.

    Best regards,


    Linux Developer