Black screen on remote Mac

Szienz Posts: 26 ✭✭

There is one remote mac (running latest version of TVhost 11 on OS10.10.5) that repeatedly turns into a black screen which prevents any further access which I can only circumvent by having someone on site to reboot. 

I always disable the option to Lock on Session End as this is sometimes also a problem, but I cannot find a pattern that causes the black screen. I can connect, there is the correct info on the server when I press the Home button, but remote desktop remains entirely black.

As I see this behaviour on only one mac (and i control a dozen over different locations), could there be some security on the LAN kicking in? .


  • I've nothing to add other than to second this – we are an all-Mac support house and now are unable to remotely manage multiple clients' machines, forced restarts do not help for any machine who has a user set to log in automatically, FWIW.

  • W_deFazio
    W_deFazio Posts: 22 Staff member 🤠

    Hello Szienz,

    Thank you for your post.

    Could you please submit a ticket to our Support Department on with a brief description of the issue so a Support Engenieer can work on resolving the issue with you. 

    Please submit log files with the ticket, and you will find instructions on how to get logs for Mac OS X here :

    Hope that was helpfull!!!


  • Icymacl
    Icymacl Posts: 1

    I have a version of this problem with a totally black screen prior to login from a Mac accessing a PC running Windows Vista Business, both machines running TeamViewer 12 beta.  Once logged in on the PC I can connect and see the screen.  Prior to login on the PC, I used to see the sign on screen but now I'm just seeing a black screen.  Any ideas what I need to do to resolve this?  Thanks!  

  • bfr
    bfr Posts: 1

    We've got the same issue and it persisted from v10 thru v11, and we're not upgrading to 12 yet, in part because that shouldn't be the resolution for a remote connection app. It's connected to a display, so that's not the issue. TV11 Host has been removed and reinstalled multiple times, but the issue persists. It's problematic - telling your client to reboot their server because it's not accessible is...well, it's not ideal, right? I can actually see the mouse cursor, but the display itself never actually mounts until a restart and it's a server so that's really a double-whammy. 

    Hardware: MacMini 2012, 16GB RAM, SSD, set to never sleep, and for drives to never spin down; is visible via TV and shows as online, but simply doesn't ever display the display once connected. 

  • Someone may find this helpful.

    I experienced the same issue and a workaround is to use teamviewr actions to "Lock Computer" once that action is sent the screen comes up to the Mac login screen....

  • puddle
    puddle Posts: 1

    The problem I had was that I had "put display to sleep". I had no wake on LAN problems because the computer was always on. Before this was never an issue for some reason, but with latest version it would connect (because the computer was always on) but I would see a black screen (sleeping display) that I could not wake. But the "lock computer" (lightning bolt) would wake the display. 


  • Thanks, that's a better workaround than I had been using (TV to the problem Mac, then TV to another Mac on the same network and connect to the problem one with screensharing, that woke up the problem one).  It still needs fixing though.

  • FrankNicklin
    FrankNicklin Posts: 6 ✭✭

    Got this today on a MAC. Really annoying. Unfortunately I cannot lock the screen to get rid of the black screen. Come on Teamviewer guys this has been going on for a few years now and is still not resolved. We pay a lot of money to use your services, but when needed most it fails us.

  • Szienz
    Szienz Posts: 26 ✭✭

    I agree that it is very annoying that this issue can not be solved. This is a highly reproducible issue once you are on certain networks speeds as I do not see this with all my mac servers.

    What I do nowadays to bypas this: I fire a second request for  remote access, you get a warning that there is already a connection (yeah... the black screen), ignore that warning and open 2nd connection. This will open directly to the desktop since you had just entered credentials a few minutes earlier.

    So here is also the clue for TV developers how to "backdoor" your way in on the blackscreen. as somehow the 2nd request gets through. Hope it rings a bell somewhere at TV, or at least helps you Frank.

  • FrankNicklin
    FrankNicklin Posts: 6 ✭✭

    Thanks for that. In this instance I had to get someone local to the MAC to restart restart it to get access back.

    I have a paid account with only one remote access license, so not sure this will work for me as it complains that the license is already in use. Will give it ago when this happens again.

  • I just saw when I connect on local LAN the situation is good.(windows to mac or android to mac)

    So when I want to connect with another connection or outside of my home, the black is back.

    It's a trouble from internet port?


    thank for your help.



  • Szienz
    Szienz Posts: 26 ✭✭

    no, it is a matter of network speed and screenrefresh rate. You are caught somewhere in the middle, ending up with a black screen

  • Thanks Szienz,

    My connection is good (upper of 25Mbps).

    It's work again if I do a locking action by toolbar.


    Have a good day.



  • Have this issue as well, also figured out the lock workaround, but FYI: mine is also because is also because of display sleep.  But I get the black screen whether in my home LAN  (where the computer i'm remoting into is - my laptop, which lives in the closet) or remoting into it from my office.  If i'm home, i just switch my mouse over and back because, unlike teamviewers cursor, the actual local cursor will wake it (duh, obviously).  But yea if i'm out of home i have to do the lock screen trick and its supppper annoying.