Teamviewer 13 on Ubuntu - completely white windows

Options
MR90
MR90 Posts: 3 ✭✭

Hi!

I've been using Teamviewer for quite a few years now. Recently (after upgrading to TV13) I've experienced a problem where TV starts with completely white windows. The functionality is (somewhat) there since I was able to open up the Computers & Contacts window by knowing where the button was as seen from the image below.

TeamViewer 13 White Windows

 

I've had this problem before - a few days ago. It disappeared after some time (I can't recall if it was a reboot that fixed it) but now it's back.

 

Things I've tried:

  • Simply closing TV13 and restarting
    • No effect
  • Stoping and starting the daemon
    • The result is different, but not really usableTV13 Windows after daemon restart
  • Using TV (on my phone) to login to the laptop in question here
    • Everything worked as expected, except that the thing that's usually all colorful in the corner was all white (on both host and guest)
  • Killing the process on the process manager
    • No improvement 
    • If I did this after closing the daemon, I get the bugged out license agreement TV started after stopped daemon
    • After that, I'm treated to a slightly different, but still set of windows After Agreeing to license
  • Starting TV from the console
    • teamviewer

      Init...
      CheckCPU: SSE2 support: yes
      Checking setup...
      Launching TeamViewer ...
      Starting network process (no daemon)
      Network process already started (or error)
      Launching TeamViewer GUI ...

  • Rebooting Ubuntu
    • No change (only tried once, though)
  • Launching into a computer 
    • In some instance, I can see some of the names of the computers I've got in the list
    • I used that to navigate to the "Log in to this computer" menu and successfully managed to do that
    • This results in an unusable situation, however: Session itselfSession itself
  • Look at teamviewer info
    • teamviewer info

      TeamViewer 13.0.6634 (DEB)

      TeamViewer ID: 724795826

      teamviewerd status n/a (error)

  • Looking for the solution on Google 
    • Couldn't find anything of interest - saw different kinds of problems, but none that looked similar to mine.
  • Ziplog

 

Now a little bit about my system.

  • I'm running 
    • teamviewer --version

      TeamViewer 13.0.6634 (DEB)

  • My OS 
    • lsb_release -a
      No LSB modules are available.
      Distributor ID: Ubuntu
      Description: Ubuntu 17.10
      Release: 17.10
      Codename: artful
  • My Hardware:
    • Hardware
  • I'm on a laptop with an extra monitor
    • Result doesnt' changed on either monitor
  • My Display driver:
    • echo $DESKTOP_SESSION
      ubuntu-xorg
    • (I sometimes need to log into here as well so Wayland doesn't really work yet)

 

If any further information is required, I'd be happy to provide it.

Best Answer

Answers

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠
    Options

    Hi @MR90,

    wow, I've never seen anything like that... we'll actually, I have. Some people reported white windows or menus, but that was a permanent (desktop theme related) problem that hopefully we fixed with today's update: [Update: 13.0.9865] File Transfer & Chat

    However, I'm not sure it's the same thing that you have. Please give the update a try. If you have to restart teamviewer, avoid killing the daemon directly. Just

    teamviewer daemon restart

    will do, and re-start the UI also (if start with system is enabled). But in your case, just closing and starting the UI again should be sufficient.

    Linux Developer
  • MR90
    MR90 Posts: 3 ✭✭
    Options

    Thank you for your reply!
    After a week had passed, I wasn't really hoping for a response on something that seems to only affect 1 person so far.

     

    As for the anwer itself, I installed the update that was rolled out today. Unfortunately, as far as I can tell, nothing has changed. Teamviewer version seems to have updated, but the problem is exactly the same as it was before.

    Here's a picture of some of the menus (if I know where to click).

    All the same after updateAll the same after update

     

    I tried restarting the daemon again after the update, nothing changed.

    Since I'm a lazy hog (and I have a ton of stuff open at once), I've yet to experiment with a reboot, but I will get back to you once I have (system needs one anyway).

    And since my last post, I've never had this fix itself again. I guess I haven't been looking too often either, though.

     

    Right now I'm simply using TV through a virtual machine when I need it. Not ideal, but works.

     

    Thank you again for taking the time to review my issues with your product.
    If there's any additional information I can provide, I'd be happy to do so.

    All the best,

    MR90

  • Keha
    Keha Posts: 3 ✭✭
    Options

    same problem

  • MR90
    MR90 Posts: 3 ✭✭
    Options

    While restarting my system did not help, this did.

     

    Thank you! :)

     

    EDIT:
    One annoying issue is, I need to redo this (and restart the daemon) after I've closed Teamviewer.

  • Keha
    Keha Posts: 3 ✭✭
    Options

    this bug in qml (qt5), all programs having qml-based interface may be getting white window :smileymad:

    new teamviewer 13 for linux with qml interface :smileyhappy: