teamviewer.com link icon
or
Ask The Community

Shift key stuck in TeamViewer 13 Linux

Hi,

For some reason, when connecting to Windows-based teamviewer from my Linux, if I press Shift, it gets stuck (always pressed). Getting it unstuck is quite difficult (the host user has to press it and usually it doesn't work until I disconnect).

This is a new problem with version 13, version 12 didn't have this issue. Could be related to the fact that I use both shifts to switch languages?

System: OpenSUSE 42.2, TeamViewer 13.0.9865.

Anyone else noticed this problem?

Cheers

Comments

  • mwildam
    mwildam Posts: 16

    CTRL key not working either. Not talking about clipboard transfer between machines - I even cannot use CTRL+C just in the remote machine!

  • vvirag
    vvirag Posts: 1

    Yes, same problem for me. Ubuntu 17.10 trying to log in to Ubuntu 16.04 (both: TeamViewer 13.0.9865).  Quite unusable :'(

    Edit: figured this workaround.
    Start terminal and type:

    onboard

    On the virtual keyboard you will see both Shift keys stuck. Click on them until they are not active anymore. 

    Sadly this won't fix the entire session. You will see that the Shift keys randomly get turned back on. Super inconvenient, but at least you can always switch them off with the virtual keyboard on. :/

  • mwildam
    mwildam Posts: 16
    Thanks for the hint, but this is not the case for me. OnScreen Keyboard does not show any stuck Shift or Ctrl key. And clicking those does not help either.
  • mads_n
    mads_n Posts: 1

    Any progress or workarounds on this issue?

    I have similar issue with teamviewer 13 (<ALT> very often hanging according to onboard on-screen keyboard) .
    Server=Ubuntu 18.04
    Client=Ubuntu 16.04

    Both has this TeamViewer version:
    teamviewer_13.1.8286_amd64.deb // note marked as PREVIEW version

  • Yip, same for me connecting from Xubuntu 18.04 to Windows 10. I was trying to tell my client it was their keyboard but no, it is another problem with the Linux Teamviewer client. This "sticky" shift key bug is random and when it happens it is almost unusable! On top of the trickle feeding of features after a forced upgrade to Teamviewer 13 this is almost enough for me to say Adios!

  • Julia
    Julia Posts: 290 Staff member 🤠
    Julia
    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • jflambert
    jflambert Posts: 5 ✭✭

    I'm here because of a stuck Shift key and this linked topic has absolutely nothing in terms of solutions.

    My setup is Windows 10 local and Ubuntu 18.04 desktop remote. Latest releases on both machines: 14.4.2669 on Windows and 13.2.26559 on Linux.

    I've used TV for more than a year, we have a commercial account, and this Shift key bug just hit me today.

    I've tried rebooting the Windows computer and restarting the daemon on the Linux side, no help. I guess the next big thing is rebooting the Linux computer.

  • LordHelmchen
    LordHelmchen Posts: 8 ✭✭

    2020 and they still did not care about Teamviewer being unusable on Linux.

    CTRL is stuck all the time.

  • basillicus
    basillicus Posts: 0

    TL; DR: Read text in bold

    I already answered to this question in the thread posted by Julia, but for the sake of completeness I will post here the answer too as it is more related to this topic.

    I had exactly this problem, using Team Viewer on Linux, Kubuntu 20.04. I found my source of the conflict, and a simple workaround to fix it.

    In my system I configured it to switch keyboard layouts by pressing the two shifts simultaneously and that conflicts with Team Viewer, generating this problem . I changed it to a key combination that does not involve any of the Ctrl, Shift or Alt keys, and it looks like solves the problem so far.

    In KDE environment: System Settings -> Keyboard -> Advanced: Switching to another Layout And change it to anything that does not involve Ctrl, Shift or Alt Keys. I used the (not-any-more) useless key Caps Lock to switch keyboard layouts, and it solved my problem so far.

Sign In or Register to comment.