TV quits even before start (never did this for years)

Hi, after many years of excellent services, TV can't open anymore and quits from start. I verified my connections, particularly in Little Snitch  and VPN (both are off now), but result is same. The problems reports says (extract only):

"System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Codes: 0x0000000000000001, 0x0000000000000000

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [0]

Application Specific Information:

So it seems that this "SIGILL" command would be responsible, but I wonder how to remove it (from the system or from the app?).

BTW, a surprising thing is that the message telling me that TV quitted unexpectedly appears in the next 3-4 seconds, and clicking on either "ignore", "notify" or "relaunch" lets it disappear but reapearing in the next few seconds (ad infinitum!). The only way to get rid of it is to send TV in the basket. I also removed TV from both folders: LaunchAgents and LaunchDeamons (looking in both HD library and ~library).

TeamViewer 13.1.1548, on Mac OS X High Sierra 10.13.3

I reinstalled it a few times (after uninstalling it completely with all its files)

Thanks for new ideas.

Best Answer


  • Esther
    Esther Posts: 4,057 Former Community Manager

    Hi @Dsoslglece 

    There is a new Mac version available: v13.1.2559

    Can you please download this version and check if this resolves your issue?



    Former Community Manager

  • Hi and thanks Esther… this version don't seem to be visible anywhere and the one I've got has always been said to be the last. So, I got some hope that with your link it'll work. I keep you informed anyway…

  • andrewmp
    andrewmp Posts: 1

    Same problem with me.  Also re-installing latest version had no effect.

    Screenshot 2018-03-15 14.20.19.png

  • mscheurer
    mscheurer Posts: 14

    same here. Maybe deleting teamviewer settings may help.

    macOS 10.13.3

    Edit: temporary solution - see my post below

  • Esther
    Esther Posts: 4,057 Former Community Manager

    Hi again,

    please try to go to Preferences --> Advanced --> scroll down and uninstall TeamViewer completely.

    Looking forward to receive your feedback on this.

    Former Community Manager

  • Well sorry, but it does exactly the same as before with the new version.

  • Hi, I did it and didn't work.

    Anyway, you could try by using CleanApp (free version is enough).

    BTW the files are all in the library (or maybe, depending of the accounts in OS X, in your ~library)

  • Esther
    Esther Posts: 4,057 Former Community Manager

    Hi and thanks for the update.

    I will forward the information internally.

    Best, Esther

    Former Community Manager

  • mscheurer
    mscheurer Posts: 14

    latest 13. The version before upgrading was 13 too but lower patch level (13.0.6447).

    Uninstall via app not possible because the app crashes on startup immediately!

  • Well, Hi again. I did completely uninstall TV (and again following an advice lower on this discussion), but using CleaApp, since it is impossible to go to the prefs when TV is not on :-)

    I try it again and will verify once more all the files in the libraries

  • mscheurer
    mscheurer Posts: 14

    My temporary solution:

    Open finder > Goto > /users/<username>/Library/Application Support/

    and delete the "Teamviewer" directory.

    Restore older version from Timemachine Backup.

  • Hi Esther, Following a suggestion from someone (can't find the message on the page yet), I went into Time machine, and since I don't use it very often, I only got a teamviewer version from last December : version 13.0.5640.

    It works as a charm, and I managed to go to a friend in Florida to give a little kick to her Macbook…

    So, (talking about TV versions) sometime better is the ennemy of good.

    I had yesterday also tried to start a Teamviewer app from one of the systems installed in parrallel on my machine: Mavericks, but the latest TeamViewer compatible with it, even if working OK, couldn't connect to the distant TeamViewer app (v 13).

  • mscheurer
    mscheurer Posts: 14

    Teamviewer V13.06.447 from Dec 14, 2017 12:01:14 is working too.


  • MihaiGo
    MihaiGo Posts: 7
    Please check also "TV13 Quit Unexpectedly on OSX" on this forum. Same topic. You will find a link to a reliable source for a working version of TV13, posted by Julia - TeamViewer staff. The working version is 13.0.6447 and not 13.06.447 mentioned by mscheurer.
  • Hi Esther, I thought I sent a reply about this, but no problem to answer again: yes I tried this new version, and no, it didn't solve the problem that stayed exactly similar to itself.

    But I gave another answer about this whole problem (after trying another TV from an older system installed in parallel to mine —Mavericks— it worked fine, except that it could only connect to older versions of TV installed on the friend's machine.

    Finally, the solution (but temporaly), was to find an older version of TeamViewer, but not that old though (13.0.5640) and reinstall it.

    Thanks for your attention.

    Works fine now.

  • Me To:

    Tried to fresh install TV13 latest on Mac High Sierra:

    Process:               TeamViewer [1314]
    Path:                  /Applications/
    Identifier:            com.teamviewer.TeamViewer
    Version:               13.1.2559 (1)
    Code Type:             X86-64 (Native)
    Parent Process:        ??? [1]
    Responsible:           TeamViewer [1314]
    User ID:               501

    Date/Time:             2018-03-17 14:52:23.425 +0000
    OS Version:            Mac OS X 10.13.3 (17D102)
    Report Version:        12
    Anonymous UUID:        8177E9F6-B7C9-053C-0294-4512A91899C4

    Time Awake Since Boot: 6200 seconds

    System Integrity Protection: enabled

    Crashed Thread:        0  Dispatch queue:

    Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
    Exception Codes:       0x0000000000000001, 0x0000000000000000
    Exception Note:        EXC_CORPSE_NOTIFY

    Termination Signal:    Illegal instruction: 4
    Termination Reason:    Namespace SIGNAL, Code 0x4
    Terminating Process:   exc handler [0]

    Application Specific Information:

    Thread 0 Crashed:: Dispatch queue:
    0   com.teamviewer.TeamViewer         0x000000010e4ef192 0x10c971000 + 28828050
    1   com.teamviewer.TeamViewer         0x000000010e4f007c 0x10c971000 + 28831868
    2   com.teamviewer.TeamViewer         0x000000010e006881 0x10c971000 + 23681153

  • Didn't find a link to that version, would've been mighty kind of you to post it. Instead I googled and installed this version: 

    It works for me. I'd suggest turning off automatic upgrades.

    @User51973 did you even test bro?

    My troubleshooting (for the devs): full clean uninstall deleting all the tiemviewer files in the prefs folder and the applications folder as mentioned in this thread. none of it worked. I reported a few crashed to apple. You can ask them for the reports.

    Model Name: MacBook

      Model Identifier: MacBook5,1

      Processor Name: Intel Core 2 Duo

      Processor Speed: 2 GHz

      Number of Processors: 1

      Total Number of Cores: 2

      L2 Cache: 3 MB

      Memory: 2 GB

      Bus Speed: 1.07 GHz

      Boot ROM Version: MB51.007D.B03

      SMC Version (system): 1.40f2


      Sudden Motion Sensor:

      State: Enabled

  • Found version 12.0.90924 to install on the Mac and version 12.0.90922 to install on the Windows 10 laptop. Both work fine for me now. Happy bunny.

  • astrouser
    astrouser Posts: 2
    edited March 2022

    Same problem on an old iMac.

    Been very happy with TeamViewer for some time. Installing old teamviewer works ok (12) but won't connect to my Teamviewer 13 host. Upgrading from 12 breaks same way.

    Love this product, but this super **bleep**. Can we get an official link to an older Teamviewer 13 build and instructions?  I deleted ~/Library/Preferences/*team*, but didn't change anything. Not sure if there is anything else I need to clean to uninstall (can't do from app since it doesn't start).

  • Well, I used an old version but as old as 12 (13.0.5640) and it works fine now on my iMac 10.13.3.

    Indeed I had the same problem as you had with an older version installed on Mavericks (parallels), that couldn't connect to a Mabook High Sierra and TV 13.

    If TeamViewer site can't send you this version, I could make it available through Mega, just say so please

  • jridley
    jridley Posts: 3

    If someone could share an earlier copy of v13 that still functions that would be great; It would be wonderful if Teamviewer themselves allowed users to download an earlier build of the current version instead of just the old version 12... 

    My other computers all wanted to update the latest & greatest so they are all on 13 now, just not my Mac.

    I have tried downloading the latest (v13.1.2559), and installing after deleting the Teamviewer folder in the Preferences, as well as all com.teamviewer... files in the user preferance Library - still results in the same error / not opening.


  • Hi,

    first thing: you should really read all the answers in a discussion, since I mentionned at least twice that I was prepared to share with anybody in need, an older version of TV 13 (working on High Sierra 10.13.3),  provided someone asked for it.

    here is the link (plus the key to the file) to my account on Mega:

    [Link to 3rd part website removed - we recommend to download TeamViewer only from our website - Thanks for your understanding]

    Please, to be able to DL or UL files on Mega, you have to use Google Chrome (Don't like Google, but this is the most simple), or Firefox+Mega extension. After entering the link and sending it, you have to chose:


    • The other solution proposed is to Import to (your Mega account if you have one… free account up to 50 MB, very strongly encrypted and secured), but I guess you need it on your Mac.

    I'll leave this link for quite long in case someone else would need it, or until a new working update pops up.

    Good luck

    P.S.: If you didn't read carefully all posts, may I remind you not to forget to change the prefs and chose not to install automatically the updates if you don't want to find yourself once again with the newest but not working version…

  • jridley
    jridley Posts: 3

     Thank-you very much! I had read your offers to post, but didn't want to assume you would still be available to be able to do so. I really appreciate your download, and was able to install and run that version without issue.

    Obviously there is something wrong in Teamviewer's latest installation and hopefully they are aware of this thread and will be able to solve the issue for all others as well.

  • jridley
    jridley Posts: 3

    RE: [Link to 3rd part website removed - we recommend to download TeamViewer only from our website - Thanks for your understanding]

    Teamviewer: I appreciate your suggestion, and would typically download direct from the original website. However: the version on your website does not work, and does not work for (at least) a few people as posted here. You don't allow downloads of older releases of the current version, which is the only fix for this issue until your developers release a working version. 

    So my only options are to downgrade my windows machine which, is currently in a different location therefore impossible; or try a version as offered by a kind forum user, Dsoslglece - thanks again!

  • Esther
    Esther Posts: 4,057 Former Community Manager
    Hi all, we published a download link in another thread:

    Check out for the post from our staff member Julia (currently marked as solution).
    Best, Esther

    Former Community Manager

  • Well, it is quite understandable, especially concerning such an app that could be arranged behind your back for no good by little busy bodies. Sorry not to have thought of this.

  • Esther
    Esther Posts: 4,057 Former Community Manager

    Hi all,

    the version which is available on our website (v13.1.2559) does now include a fix for the crash you might have experienced earlier when installing TeamViewer on Mac OS.

    This version will have to be downloaded from the webite and cannot retrieved via the update function in the TeamViewer application.

    We will keep you updated as soos as the update will be available via the software itself again.

    Thanks, Esther

    Former Community Manager

  • Esther
    Esther Posts: 4,057 Former Community Manager

    Hi all - I apologize for the confusion. I just got the information that it is still in the uploading process and that it will take a bit until it is available.

    I will keep you updated as soon as the fixed version is available.

    Once again - I am sorry! Please excuse me being too fast in sending you the GO.

    Best, Esther

    Former Community Manager