link icon
Ask The Community

Requesting assistance - Teamviewer on Windows 10, iPhone 7, and Samsung S7 (Verizon)

Hello my fellow forum members!

I installed Teamviewer to connect to my Samsung Galaxy S7 (Verizon edition) smartphone via a Windows 10 PC and an iPhone 7 (international edition). The S7 is running Android Nougat 7.0 and the iPhone 7's iOS is fully updated. Unfortunately, I was unable to connect to the S7! I did not find a solution after much troubleshooting and thoroughly searching this forum, so I decided to create this post. Here is an elaborate outline of my troubleshooting. I hope it is not taken with harshness; I am only trying to explain as clearly as possible for you guys and gals!

I have tried using Teamviewer 13 on both the iPhone and the PC to connect in the following ways:
1) iPhone to S7's Host(app),
2) PC's Teamviewer 13 program to S7's Teamviewer Remote Control(app),
3) PC to S7's Host(app) via web portal using Microsoft Edge.
I have tried these three steps before installing "Add-on: Samsung" on my S7.
I have tried these three steps after installing "Add-on: Samsung" on my S7.
My S7 responded the same way whether or not I was using "Add-on: Samsung".
Teamviewer Host(app) and Teamviewer Remote Desktop(app) requested, and were approved, to enable Samsung Knox.
The common error message I am receiving states that I did not approve the connection to my S7. From my S7, I see the stages change from ready, to connection requested, and then back to ready. There is nothing else-- not even a pop-up message on my S7.

I will be very happy if we can get Teamviewer to work on these devices. Whoever has any questions relating this matter, please do not hesitate to ask, and I will get back to you as soon as I can!

Best Regards,


EDIT: I would like you all to know that I tried all of this with eco-mode on as well as with Eco-mode off.

EDIT2: I solved my problem!! After looking closely at the logs on my app, something caught my eye. Teamviewer was attempting to set the screen resolution to 1440x2560 (WQHD). My laptop has a maximum screen resolution of 1920x1080p (Full HD) and the iPhone 7 (not iPhone 7 Plus) has a maximum screen resolution of 1334x750p (??As clear as the human eye is capable of noticing-p).

Solution: I changed my S7 screen resolution to 1280x720p (HD). It works!



  • Esther
    Esther Posts: 4,089 Former Community Manager

    Hi Zach,

    I am glad to hear that you found a solution :-)

    Best, Esther

    Former Community Manager