Screen refresh lags behind

JWM1769 Posts: 1
edited May 2023 in General questions

For a while now, my TeamViewer 13 remote sessions are lagging behind on refreshing the screen as a result of user input.  Well, there is an exception that I've found where drawing in MS Paint will typically result in immediate screen updates.  But in general, mouse movements, clicks, keyboard inputs: all of these will fail to result in immediate screen updates, and this becomes pretty infuriating after a while.

For example, clicking to open a pulldown menu at the top of a Windows app will fail to refresh the screen, and I then have to wiggle the mouse around until it draws what already happened on the remote screen.

Even more annoying is that when typing, the most recent keyboard input is never shown as an immediate screen update, so when going back and editing out typos, you often end up overshooting the number of necessary backspaces because the screen isn't updating fast enough, and sometimes you aren't sure if your key input registered or not, so you hit it again, only to find that it really did register and you just couldn't tell because of this TeamViewer bug.

I am confouded as to why there are still no posts about this subject online that I could find.  Some details: all of the remote sessions in which I'm observing this problem are from a TV13 client running on Windows 10, to a remote Windows 10 machine: either version 10.0.16299.192, or version 10.0.17134.48.  The issue could be far more widespread, but this is my limited experience, and these are my machines that I need to use daily, so this has been pretty frustrating.  I've had to change to a policy of going back to the LAZILY (under)developed **Third Party Product** for the remote machine in which I'm doing the most heavy work at the moment.  My initial reaction to TeamViewer 12 (towards the very end of its development cycle) was that it was/is the pinnacle of all remote desktop software in existence in all aspects, but TeamViewer 13 has been nothing but trouble so far from my perspective.  I love TeamViewer, so I hope that version 13 finally gets the kinks worked out, and stops receiving updates that introduce serious bugs which remain un-fixed for long stretches of time.



  • stevie999
    stevie999 Posts: 1
    Im getting exactly the same issue with the latest update. working 100% fine before the update
  • dochoffman
    dochoffman Posts: 1
    I also have the same issue. I use Teamviewer multiple times a day from my laptop to connect to two desktops. Version 14 on all machines. It is massively frustrating and if it continues, I will have to change.
  • PhilipAlbert
    PhilipAlbert Posts: 2 ✭✭

    I too am having the exact same issue after the latest and greatest upgrade/updates. 

    I use this to remote control my observatory. Direct fiber link. Can't use RDP because of very heavy graphics. TeamViewer always has worked great. Not now! Can't even keep a remote session for couple minutes once I start using anything that requires real-time refresh.... and on a fiber link, no less. 

    If this is a ploy to push users to purchase, like they did in the past with timeout periods, that would be a mistake, I think! But, I don't think that is it...... Probably just bad programming/development?!?! Which I hope they fix soon!?!? Even they, using it, would have to see this issue right away!?!?

  • PhilipAlbert
    PhilipAlbert Posts: 2 ✭✭

    Update - 

    Ver. 14 and end of 13. 

    Host machine - Win7 Enterprise, Dual Monitors. 100/10 cable connection. 3 Security camera feeds on one monitor. 

    It seems that ANY streaming video developed/programmed to NOT work well or highly choked off, throttled, etc...... when remoting into a host computer.

    Prior versions I could literally remote into my host and watch tv and movies, and my security camera's with no issues at all! 

    It seems that ANYTHING that streams on the host machine has been severely throttled -

    My right monitor has 3 security camera's recording and viewing live video feed through fiber optic. I've slowed them down as much as I can without loosing much clarity. 

    My left monitor is blank and I use it for web browsing, email, etc...... Never EVER a refresh issue (or any issue) while remoting in using that monitor. But, when I go to the right monitor.... nothing but severe refresh issues. I have to toggle back and forth, between screens to force it to refresh the right monitor. After 5 min. or so then it starts becoming a little bit better. Not much though. 

    Cellular connections can be at 40/10 to 20/5 mbps, that I'm remoting in with and TeamViewer acts that same.

    So, I'm left with the fact that anything that 'streams' on your remote session...... they've killed on purpose?!?! 

    I haven't even started on how this adversely effects remote controlling my observatory - high speed camera's etc...... Ugh! 

    TeamViewer was the **bleep**! I can understand not wanting to be taken advantage of etc.... But, your prices are pretty steep for just a home user. Offering it free to single user's should mean that the software works exactly as if I WAS paying for it. Otherwise, what's the point?!?! 


    Phil Albert

  • ufernest
    ufernest Posts: 1

    Have same issue connecting latest Teamviewer from Mac to Linux. Enter symbol and nothing happens on the Teamviewer screen. Then enter second symbol and two entered symbols appears.

  • cooljeffro
    cooljeffro Posts: 1

    I had the same problem when connecting to a headless Linux setup. The display was always one key behind.

    After toggling through all the different options, I finally found disabling hardware acceleration solved the problem for me. In the TeamViewer main window: Extras -> Options -> Advanced -> More -> Disable hardware acceleration

  • MATaylor
    MATaylor Posts: 1
    edited September 2021

    I am experiencing the same issue - the TV screen display refreshes with every other keystroke when using TV to connect from windows 10 to a remote linux box. I have TV 15.21.8 on windows 10 connecting to TV 15.21.4 on Ubuntu 20.04. The 15.21.4 version was retrieved/installed this morning from h_t_t_p_s:// Unfortunately disabling hardware acceleration in TV on windows 10 did not resolve the issue. I do not see a similar option in TV on linux. I have rebooted the Ubuntu box and bounced the TV service on windows 10. Any other ideas?

  • TM_Camtek
    TM_Camtek Posts: 1

    having similar issues as well - any fix? with latest update became really worst!

  • Ulaş
    Ulaş Posts: 2 ✭✭

    After more than 4 years as a Premium customer, I started to switch to alternative products because of the renewal speed issues. 

    When I connect to my computers with remote desktop, the refresh rates bother me a lot. 

    I hope they can find a solution quickly.

  • tvale2
    tvale2 Posts: 7 ✭✭

    Same issue after update