Wayland Support


Will Teamviewer support Wayland? And if so, when will this version of Teamviewer be released?



Best Answer


  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]

    Dear WalterTamboer,

    Thank you for your post.

    At the moment, our developers are working on a Linux Native version for Linux but there's no release date or information about features included.

    I will forward your suggestion to support Wayland our product management team.

    Such ideas are always welcome, although we can not promise when or if this Feature will be implemented.

    Decisions for new features are mainly based on customer's suggestions.

    Nevertheless, your feedback is crucial to us, as we want to continue to develop TeamViewer-based on our user's need.

    Any other questions don't hesitate to ask.

    Best regards,


    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • Same here. Just installed Ubuntu 17.10 and teamviewer doesn't work anymore on wayland, but it works on x.org. It doesn't work at all with the *.deb file on wayland and with the *.tar.gz file it ends up in a black screen. Any wayland support would be highly appreciated.

  • ringe
    ringe Posts: 2 ✭✭


    I had TeamViewer 12 install when I upgraded to Ubuntu 17.10 with Wayland.

    No issues with TeamViewer whatsoever. It has continued being an essential tool.
    I support all kinds of people and systems with it.

    Then I upgraded to TeamViewer 13 BETA and it simply says it cannot open in Wayland.

    What is the point? If TeamViewer 12 works under Wayland, why can't 13?

    Ubuntu 17.10 runs X applications under Wayland with no problems at all.

    Please fix the BETA so I can continue using TeamViewer.

    Best Regards

  • rompe
    rompe Posts: 1
    Any progress here? Would have been nice if TeamViewer had been ready for Wayland when Ditributions started defaulting to Wayland. Since this opportunity has clearly been missed, is there any chance TeamViewer will at least someday work again on modern Linux Desktops? Xorg will not always be there, and even now I doubt all people will fall back to Xorg just for TeamViewer.
  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @WalterTamboer@fansari, @Spurlos, @DigitalSpinner, @maggiv8, @rompe
    Please read about the current state of Wayland in the TV13 announcement.
    In short: GUI starts, outgoing connections possible.
    Also note that we will release an update next week adding important features.

    @ringe, you installed teamviewer-host, not teamviewer. Please read the announcement above, then try with the teamviewer package.

    Linux Developer
  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    Along with our new release, I also posted a dedicated explanation on the state of Wayland:
    [Update: 13.0.6634] Christmas Update
    State of Wayland & TeamViewer

    All the best,

    Linux Developer
  • Hi Thank you! Just installed the current preview and somehow is getting usable again (I'm on Ubuntu 17.10 with Wayland disabled) - I can both view/control and act as a server for my home linux desktop again (despite no integration with TV account, which obviously is work in progress I suppose..).

    Once again thank you, keep up good work, TV is excellent.

  • Is there any new about wayland support.... 

  • Moham
    Moham Posts: 1

    Teamviewer 13  ....  the new must have tool , it rocks on windows platform, there is no match

    but when it comes to wayland support well the things get bad.....  wayland  is  the default main display server and it will be the default for all the major  linux distros....     simple no way to work tv ...      switching to xorg for now...  well no so good workaround...... can you please speed up the development for this major issue and support wayland...



  • Tim42
    Tim42 Posts: 1

    We pray for that.....  wayland situation and the teamviewer support for that is really something that makes our situation dificult,  but we all have to acknowledge  that tv  stuff works hard to keep up and fix this issue, i know its hard to pay big bugs  for the subscription  and to expect to work flawlessly  as it must be,  but we all have to wait litle more i guess and lets hope the issues will be resolved soon.



  • ringe
    ringe Posts: 2 ✭✭

    The problem is upstream in Wayland, as far as I have understood.

    I wish TeamViewer would show how great they are and just put money on the table to get the upstream fixed. Just hire Red Hat to take on the task, or Canonical.

  • Still waiting for that support

  • it's actually supported within the last version
  • Ubuntu 0.18.10 : Teamviewer does the same error: Teamviewer not running on target computer.

    Yes it doesm and xrdp is working and port 5938, 80 and 443 are open, so what your team is doing?

    Just install Ubuntu + mate and see by yourself.

  • targettor
    targettor Posts: 2 ✭✭

    Running Teamviewer 15.4.4445 on Fedora 31.

    Teamviewer hanging, crashing sometimes a connection possible, but most of the time not.

    Until one figures out that Teamviewer does not run with Wayland.

    It turns out that nowadays, the only reason for disabling Wayland is Teamviewer.

    On Fedora 32 (beta) it's even worse. The Teamviewer application doesn't even work properly, the application is hanging. If it receives a remote connection, it just crashes straight away.

    Teamviewer Support: Please add Wayland support. Otherwise most modern Linux users won't be able to use the software.

  • ZekeMX
    ZekeMX Posts: 4 ✭✭


    Now that Kooha and OBS Studio work well on Wayland I hope to see Teamviewer also working with Wayland. We are very fortunate that both applications are Opensource so that Teamviewer Linux Developers can see their code and find a way tor Teamviewer to work with Wayland.


  • JeanK
    JeanK Posts: 6,984 Community Manager 🌍
    Answer ✓

    Hello dear Community friends,

    I have quite some news for you...

    We started working on supporting Wayland! 🚀

    Please find more information in our Blogpost here:

    I hope you will be able to try it out.

    We would appreciate any feedback! 🙏

    All the best,


    Community Manager

  • dennis_tgc
    dennis_tgc Posts: 1
    edited November 2022


    Thank you for supporting Linux and an active development branch.

    I just had an issue with connectiing _to_ kubuntu with wayland activated. With X11 there was no issue. Issues experienced:

    • no keyboard
    • clicking start worked, but further to the right the actual mouse cursor was not my actual mouse cursor. when clicking pinned items, I was actually clicking on the next pinned item. In the system tray nothing was clickable and resulted in minimizing all windows (the button which is on the far right on a default kubuntu panel).
    • no remote cursor after activating remote cursor
    • lots of black screens, had to connect multiple times before getting a connection
    • a popup screen of 1-5seconds which said remote control was disabled (which is want).

    I tested _from_ kubuntu 22.10 with wayland and X11 as client AND from Windows 10 with the same results. On kubuntu with the latest stable and preview version (15.35.7), on Windows with the last available version from the website (on 10 nov 2022)

    Only after switching the target system to X11, the issue was resolved.

  • kode54
    kode54 Posts: 17 ✭✭

    I only have one problem with TeamViewer on Wayland Gnome now. Now, whenever the remote end disconnects from my session, the TeamViewer app locks up with the disconnect notice on screen, and the TeamViewer process hangs trying to ptrace what appears to be a defunct TeamViewer process.

  • gwdteamviewernom
    gwdteamviewernom Posts: 9 ✭✭

    My Client to connect Fedora (KDE Wayland) could not success for Teamviewer 15.37.3

    In TeamViewer15_Logfile.log show:


    2023/01/05 18:50:17.469 3925 140320228787648 D  Logger started.

    2023/01/05 18:50:17.469 3925 140320228787648 D  Found 0 stack dump files ...

    2023/01/05 18:50:17.469 3925 140320228787648 D  Found 0 core dump files ...

    2023/01/05 18:50:17.470 3925 140320228787648 D  systemd: logind service available

    2023/01/05 18:50:17.471 3925 140320228787648 D  systemd: New seat seat0 [path=/org/freedesktop/login1/seat/seat0, activeSession='2', canGraphical=1, canTTY=1, canMultiSession=0]

    2023/01/05 18:50:17.471 3925 140320228787648 D  LogindSessionInfo: New session LogindSessionInfo [id=2 user=gwd state=user active=1 reliable=1 infoId=450215437] [path=/org/freedesktop/login1/session/_32 TTY=tty1 seat=seat0 display= vtnr=1 owner=[SysUser: gwd [uid=1000, gid=1000 home=/home/gwd gecos=gwd shell=/bin/bash]] idle=0(0) active=1 type=wayland class=user state=active timestamp=1672915633818854 service=sddm defaultCG= leader=1446 audit=2 remote=0 rHost= rUser= killProc=0]

    2023/01/05 18:50:17.475 3925 140320228787648 D  SysSessionInfoManager: observing sessions from logind is marked as reliable

    2023/01/05 18:50:17.476 3925 140320228787648 D  SysSessionInfoManager: Session Information provided by VT [priority: 2]

    2023/01/05 18:50:17.476 3925 140320228787648 D! FrameBuffer: Cannot access /dev/fb0, frame buffer support unavailable

    2023/01/05 18:50:17.476 3925 140320228787648 D  SysSessionInfoManager::SessionAdded: adding session WaylandSession: [SysSession 450215437 [type=87 vt=1 tty= pseudotty=0 info=1 id=2 user=gwd state=user active=1 reliable=1]]

    2023/01/05 18:50:17.476 3925 140320228787648 D!! SysSessionInfoManager::GetOwnProcessSession: No session found!, Errorcode=11

    2023/01/05 18:50:19.482 3925 140320228787648 D  Cannot acquire lock for "/run/user/1000/tv_desktop.lock", reason: locked by other process (3070)

    2023/01/05 18:50:24.487 3925 140320228787648 D  Shutting down DBus IOHandler


    startup.log show:



    TeamViewer:       15.37.3 - RPM

    Profile:          /home/gwd (gwd)

    Desktop:          DS: 'plasma'   XDG: 'KDE'

    XServer TTY:      none

    ok (info)

    CheckCPU: SSE2 support: yes

    ok (profile)


    It would 100% occur in Fedora Labs (Scientific).