link icon
Ask The Community

Deploy Teamviewer Host MSI Package (Not added to my group) need password for every pc clients

We're an organization looking to find a better way to help our users.
As of now, we ask our users to open a shortcut on their desktop, they have to say yes to to start TV, from there we ask them for their ID and password.
Every single time. 
I have already started gathering about 30 users that I have had a session with, but this is a never ending story with 500+ users in our domain.
I have tried following the guide (up top) and I find that the MSI package, which I renamed the _Host-idcXXXXXXX .
When installing this package (on a test PC) I dont see my personal settings being implemented, when opening TV after the install.
Do I stand alone with this issue??
Then I've tried installing TV13 host with the link it provides 
Now I get all my personal settings. We will never get all our users to do this!
So when I want to remote control the test pc with my own licensed user account.I need to enter a password, which has not been set.
The guide just ends like that, after I have saved my reg file.
Now what??
All I want Teamviewer to do now (so I can continue testing) is to install TV13 on PC so that PC would be automatically added to my group in Teamviewer Management Console. Is this possible..
PS: I've read that the assignment tool doesn't work any longer with TV13
Looking forward to your replies, Regards MTS


  • Scotty
    Scotty Posts: 494 Staff

    Hi @mts-arkil

    Thanks for posting.

    The IDC does not apply a password, it only ever applies the logo and policy etc.

    Thank you for pointing out the article, this is not applicable to V13.2 or later.
    I have updated the article with a note reflecting this and pointing to the new method.

    The new MSI is rolled out using Parameters. So you would need to add a parameter to have the MSI pick up the TeamViewer_Settings.reg. The full article is here

    If you would prefer to use the older method, you can download the MSI for V13.1 here

    I hope this resolves this for you.


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Hi Scotty.

    Thank you for replying, I will take a look at this when I get the time.


  • Hi Scotty.

    I got the first part working, I've added a install package in our Deployment Console. So I've now got the way to rollout the installment of Teamviewer Host 13 (13.1) the way it should including the preferences I've added.

    V13.1 uses the previous deployment method with a .reg file in the same directory and the Assignment tool if required.

    I have the reg file and assignment tool in the same share folder as the msi package. But once It is installed it wont use the settings I added in the reg file nor the group it should be added to.

    I just named the reg file teamviewer, so it cant be because the reg file needs to have the name, right? = "TeamViewer_Setting.reg"

    Regards MTS  



Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!