link icon
Ask The Community

Consistent failure to launch on Mac

This is related to another post, but each time I tried to post a reply there, my response was auto-flagged as spam. 

For a number of weeks, TV was consistently starting up when I first start my Mac, but if I quit, it would never start again, until I restart.

I tried the full manual TV reinstall a couple times, including deleting the Plist items. No difference. Also reinstalled MacOS, no difference.

It does bounce a couple of times, then disappears. Looking in Console, I see errors like this:

default 21:35:01.829210 -0700 launchservicesd CHECKIN:0x0-0x53053 964 com.teamviewer.TeamViewer
default 21:35:01.931374 -0700 TeamViewer -[TVProcessLock initWithScope:name:lockImmediately:]: You don’t have permission to save the file “Cleanup At Startup” in the folder “Caches”.
default 21:35:01.934082 -0700 TeamViewer A TeamViewer instance is already running.
error 21:35:02.013702 -0700 TeamViewer AEGetDescData of non-desc type 'reco' not a good idea
default 21:35:02.020049 -0700 TeamViewer OSErr AERemoveEventHandler(AEEventClass, AEEventID, AEEventHandlerUPP, Boolean)(aevt,quit handler=0x7fff52baf52c isSys=NO) err=0/noErr
default 21:35:02.020289 -0700 TeamViewer OSErr AERemoveEventHandler(AEEventClass, AEEventID, AEEventHandlerUPP, Boolean)(GURL,GURL handler=0x7fff52baf52c isSys=NO) err=0/noErr

I then restarted, started TV and tried the Uninstall via preferences, then reinstalled. Now it won't start even after I restart the machine, same sort of console errors.

Lookng at "A TeamViewer instance is already running" in Console messages above, I checked Activity Monitor and found a TeamViewer_Service, whose parent is launchd. So a daemon, but I can't see how to disable that, if it is even the problem.

I even tried downgrading to TV 12 and got the same results.

Not sure what else to try here. Suggestions welcome!

Oh and this is Mac High Sierra (10.13.6) trying to run latest version of TV 13 for Mac downloaded today.

Sign In or Register to comment.