link icon
Ask The Community

Can view but Can't control Motorola phone with QucikSupport

I can view the screen on my motorala mobile but I can't control it from my PC. It is showing that "this device only supports screen sharing mode". How can I remote control my moto phone



  • ReyhanReyhan Posts: 276

    Hi @bha1

    Thank you for your post.

    Please have a look at this post 


    Did my reply answer your question? Please accept it as a solution to help others, Thanks.
  • ReinholdReinhold Posts: 6

    Hi @bha1

    With today´s TeamViewer release we now provide remote control for Motorola devices.

    This feature is available for all new Motorola devices (e.g. Moto Z2 Play, Moto E (Plus) 4th Gen) and all devices that get an update to Android 7.1.1.

    Users will be asked to grant a special access after installing our Android Host/QuickSupport app.



    Enjoy the new feature! 


  • It doesn't ok for me...

    Motorola Moto E4 Plus, Android 7.1.1, QuickSupport or Host : this question about Special Access never appear...

  • aasororaasoror Posts: 22

    Same here (moto E4, 7.1.1).

    Here is a question that I posted on another thread and didn't get an answer for, is it true that you need a premium/coorporate license as well as 7.1.1 running on your moto to get remote control to work from TV QS/Host ?


  • aasororaasoror Posts: 22

    @Reyhan any thoughts about my question above, your feedback is appreciated. 


  • ReyhanReyhan Posts: 276

    Hi @aasoror

    I am pleased to help you. You need a license for commercial usage.

    If you establish a connection to QS-Moduls or Host-Moduls at work you also need a license.

    I hope this information helps you.

    Did my reply answer your question? Please accept it as a solution to help others, Thanks.
  • aasororaasoror Posts: 22

    @Reyhan, thanks for your reply, I am not using TV for work/business so my question is regarding personal (non commercial) users.

    Let me rephrase, should personal users be able to remotely control moto E4 running Android 7.1.1 or is that functionality reserved only for business users holding premium/corporate licenses ?

    Thanks again.

  • ReyhanReyhan Posts: 276

    Hi @aasoror

    Thanks for your reply. Fortunately, this functionality is free for private user as well as TeamViewer. :smileyhappy:

    Did my reply answer your question? Please accept it as a solution to help others, Thanks.
  • aasororaasoror Posts: 22


    Thanks for the reply, with that cleared up we can concentrate on why its not working as its supposed to, between this and the other "ideas" thread there is few people reporting getting stuck in "screen sharing" mode with no "remote control" abilities on both G4 and E4 running Android 7.1.1 so in theory it should work, but practically we don't get the "allow special access" dialogue box during QS/Host installation, I have also checked "special access" section (under Settings -> apps -> options) and "Host" isn't listed under "Device Administrators" or any other "privileged" access app group.

    Is TV aware of the issue ? are you actively looking into it ? is there anything that we can do on our end to help ? do you need logs ?


  • @Reyhan

    Any thoughts ?


  • @Reyhan,

    Any updates ?


  • Can you please send us a screenshot of your 'About Phone' menu so that we can evaluate this further with the manufacturer?


    Constantin Falcoianu
    Director, Business Development

    TeamViewer GmbH * Jahnstr. 30 * 73037 Göppingen * Germany
    Registration AG: Ulm HRB 534075
    CEO: Andreas König, CFO: Dr. Thomas Nowak
  • @Constantin

    Thanks so much for the reply.

    Find the screen shot attached below

    Moto E4 VZWMoto E4 VZW

  • @Constantin any updates ?


  • Yes we talked to Motorola. As those are devices from the US they do not have this functionality yet unfortunately. So there is no possibility for us to get remote support on them for the moment but we are working to cover those devices in the future as well.


    Constantin Falcoianu
    Director, Business Development

    TeamViewer GmbH * Jahnstr. 30 * 73037 Göppingen * Germany
    Registration AG: Ulm HRB 534075
    CEO: Andreas König, CFO: Dr. Thomas Nowak
  • That's unfortunate.

    But thanks for the reply @Constantin, its appreciated.


  • @Constantin wrote:

    Yes we talked to Motorola. As those are devices from the US they do not have this functionality yet unfortunately. So there is no possibility for us to get remote support on them for the moment but we are working to cover those devices in the future as well.


    Hello @Constantin

    Do you have a timeline on this or anymore info as to when this functionality will be added to the Moto E4 phones?  Or, should we expect it not to happen anytime soon or ever? 

    Also, why aren't specific models listed on this page (or models and Android OS combinations with issues)?

    I bought a Moto E4 specifically because Motorola and Lenovo are on that list and thought you supported all of their phones (from the past few years at least) and now I am concerned that the next phone I might buy might have the same issue.  This is very bad because this is an incredibly popular phone in the US and many other customers might make the same error I did.


  • aasororaasoror Posts: 22

    @rnbaker The issue seems to be specific to the E4 (VZW?) E4 Plus (VZW) works fine.

    @Constantin Do you mind elaborating further ? is it a problem with all E4's or just the ones from VZW ? are you missing VZW system signage keys for the E4 firmware ? why does the E4 Plus from VZW works with TV just fine (Same US wireless provider).

    Any insights would be appriciated.

  • Hi @aasoror

    Thanks for the info...Are you sure the E4 Plus works with TV?  Do you have a link or something that confirms this?  Also, I tried an unlocked, non-Verizon E4 and it didn't work either.  Thanks again.

  • aasororaasoror Posts: 22

    @rnbaker, this is good information, now we know its not something related to a specific carrier but rather an issue with the Motorola generic firmware itself.

    The E4 plus confirmation was from a community member.

    @Constantin after further investigation, seems the app requests a premission that is undefined on the Moto E firmware.

     declared permissions: prot=signature, INSTALLED
    requested permissions:
    install permissions: granted=true granted=true
    android.permission.RECEIVE_BOOT_COMPLETED: granted=true
    android.permission.BLUETOOTH: granted=true
    android.permission.INTERNET: granted=true
    android.permission.GET_PACKAGE_SIZE: granted=true
    android.permission.CHANGE_WIFI_STATE: granted=true
    android.permission.ACCESS_NETWORK_STATE: granted=true
    android.permission.KILL_BACKGROUND_PROCESSES: granted=true
    android.permission.ACCESS_WIFI_STATE: granted=true
    android.permission.WAKE_LOCK: granted=true

    So the following requested permissions was not granted:


    Of these I was able to manually grant the external storage permissions manually.

    I wasn't able to add the video output and inject event permissions due to security limitations (stock firmware not rooted).

    Now more notably is the result I get when trying to grant the remote control permission.

    Bad argument: java.lang.IllegalArgumentException: Unknown permission:

    So I think it all boils down to the REMOTE_CONTROL permission, if this permission is not defined at the firmware level I am not sure how will TV get around it.


  • @aasoror  Thanks for all the great info...Yep, I bought the prepaid Verizon version first because it was so cheap and can be unlocked and noticed you had a Verizon version also so got a non-Verizon version the next day just hoping it was Verizon model specific. 

    Unfortunately, it wasn't.  I just bought an LG Stylo 3 for the moment (and tried the Samsung J3 Emerge and worked very well with TV but it just didn't have enough RAM for my purposes) and should be here in a few days and think I should be set for the moment with that model. 

    However, I am going to need quite a few more phones over the next few months so really hope that Motorola/Lenovo will upgrade the Moto E4 firmware so I can purchase them like I originally intended.  That said, maybe Motorola wants customers to buy their higher end models for this type of functionality so I am not going to hold my breath.

  • aasororaasoror Posts: 22

    @Constantin Any feedback ? is the debug info I posted of any use to you ?


  • ConAirConAir Posts: 4

    Hi @Constantin

    Is there an update. Esther pointed me to this thread as I have a European Moto E4 running 7.1.1.

    Teamviewer does not allow control and reverts to screen sharing only.

    I had asked Esther for a list of confirmed compatible devices as the press release and information on compatibility on your site is wrong.

    Is there an update?

  • aasororaasoror Posts: 22

    Hello @ConAir

    Thanks for contributing, this is very usefull information, so what you have just confirmed is that the issue isn't with the US version of E4, same issue exists with the EU version as well, so I guess if teamviewer wanted to invistigate this further they can without much trouble as it seems there is no E4 that supports remote control at all.

    Thanks again, hopefully this new information can get TV to see whats going on, E4 is a new phone and is gaining customer base daily, its very disappointing that its missing critical TV support (despite the TV press release saying otherwise).


  • ConAirConAir Posts: 4

    Hi, I thought I would give some information that may be useful to you all.

    Whilst testing the E4 I rooted and then attempted to unroot. My unroot attempt failed which caused me to reflash stock firmware using the sp flash tool with firmware (Android 7.1.1) version MOTOROLA_E_NMA26.42-75_ROW.

    This version is Russian (language can be changed at initial boot), but works with my device XT1762. This version has the special access menu and TeamViewer worked. It's not ideal and may not work for everyone, but hopefully, this helps. I would put links but I fear they may be blocked, so search for E4 unrooting and that ROM version above.

    Things you will need

    Windows machine

    SP Flash tool V5.1628_Win

    Vcom Drivers.

    ROM file - MOTOROLA_E_NMA26.42-75_ROW


    Install Vcom drivers

    Start SP flash tool and browse for the scatter loading file.

    Select MT6737M_Android_scatter.txt

    Put phone into fastboot (Download) Mode and connect.

    Click download in sp flashtool

    Good luck.

  • aasororaasoror Posts: 22

    This is good info, unfortunately not many of us can make use of the Russian firmware due to Carrier locked bootloader.

    Seems TV has no interest in pursuing this further, devs are not even replying with any info that we can use to push Motorolla to release a fix :smileyfrustrated:. 

  • GTWGTW Posts: 1


    Any update on this issue?   We just switched my 86 year old Mother from an iPhone to an Android 7.1.1 Moto e4 because the iPhone 6S would not allow full remote control.... and now we run into this problem AGAIN!! :D  yikes...   WE LOVE TEAMVIEWER!!!   

    I have had no problem with my older LG Android phone (android 4.1.2), nor my cheap Insignia Android Tablet (Android 6.01), both running the same versions of HOST (13.0.7847) , which is also the same version of HOST on my Mom's new Sprint MOTO e4 phone.   

    There is a QuickSupport Add-on for my LG phone, QS Add-on LG version 12.1.7042, and there is also a QuickSupport Add-on for my Insignia Tablet , QS Add-on AOSP 14 version 11.0.5583.

    But I do not see a specific QS Add-on for the Moto e4, so it is using the "standard" QS version 13.0.7847.

    So, are there any updates?   Is this a Motorola Firmware issue (still) ?   OR is Teamviewer not interested in supporting Moto e4 phones?  Or is Teamviewer in process of fixing this?  

    I just want to know the status, and where the issue lies, before I contact Motorola & give them some **bleep**, I might still know some executives there, I was in Telecom / Cellular for about 30 years working all over the world :D.... so maybe I can apply some pressure , maybe... but I would like to know if Teamviewer is interested in fixing this, and where they are in the process.

    Thanks so much.... !!!!


  • Its not a TV issue, there should be no specific control module for the moto E, with Android 7.x there should be just proper permissions implemented in the firmware so once you grant it to the QS app you don't need an additional app (addon) for remote control functionality.

    Its evident from this thread that issue is not US firmware specific, its an issue of all moto E firmwares (except for the Russian variant), and its also evident that TV has no interest in getting this sorted out with Lenovo.

  • Dino2Dino2 Posts: 2
    I have ordered phone jelly pro from ebay , and I tought it can open quicksupport with pc and let me to do whatever I want to do with device, while Im reading those posts, I can see that it will probably doesn't work. What should I do?? Can you resolve this problem for me as soon as posiblle?
  • Can they resolve this problem for you as soon as possible ?

    Not sure you have noticed that this thread started in March 2017 and remains unsolved as of right now :)

    But if your jelly pro is not a moto phone you might want to create a different thread and see if you will have a better luck.

Sign In or Register to comment.