link icon
Ask The Community

no teamviewer GUI on Centos 7 (tar package without root access)


I'm trying to use the tar package without root privilege on Centos 7 (x86_64) - teamviewer_14.0.14470_amd64.tar.xz

Here was my problem after I ran teamviewer:

CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process started (35632)
Launching TeamViewer GUI ..."

The program had no response and nothing happened (it didn't terminate either)

Here were some preparations I did:

I had to install related QtQuickControls packages manually since I don't have root privilege. This means I had to export LD_LIBRARY_PATH in ~/.bashrc to include the QtQuickControls libraries (such as qt5-qtdeclarative qt5-qtwebkit qt5-qtx11extras qt5-qtgraphicaleffects qt5-qtquickcontrols). Then I could run ./tv-setup checklibs witout any problems:

"Analyzing dependencies ...            
All library dependencies (*.so) seem to be satisfied!
QtQuickControls seems to be installed"

(   although I had to comment out the line "LD_LIBRARY_PATH="$ld_path" in the script ./tv_bin/script/teamviewer_setup to let the program recognize the env variable. I also needed to give the correct directories in the function CheckQtQuickControls()    )

 So it seems that the script is using ./tv_bin/script/tvw_main to launch the program ./tv_bin/TeamViewer  --  I did try to run this directly and also nothing happens (no response)

PS: a related topic has been discussed but it was a different issue which has been solved with the later update (mostly about checklibs and QtQuickControls).

I very much appreciate your comments and help.

Best regards,


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!