teamviewer.com link icon
or
Ask The Community

SHIFT and CTRL not working for Teamviewer + Remote Desktop

BertK
BertK Posts: 3 ✭✭

SHIFT and CTRL are working for my teamviwer session to the remote computer with Windows 10. Also when directly logged in to the remote computer a Remote Desktop to another system with Window 7 works fine. For the combination of Teamviewer + Remote desktop however, the SHIFT and CTRL key are not working. Does anybody know why?

Comments

  • darwall
    darwall Posts: 1

    Hi though i was going mad, same issue hear, Teamviewer into Windows 10 comptuer, Shift Keys and CAPS and CTRL all work fine.

    Once connecting into RDP Windows 7 PC, with in Teamviewer session, the trouble begins, can't type with Shift key, Ctrl + combinations don't work and sam with CAPS . ??

    Surely someone has found a fix to parse the keyboard info through to RDP with teamviewer?

  • Same problem here, but all three computers are Windows 10

  • I solved this by not using full-screen for the RDP session.

  • JeanK
    JeanK Posts: 3,619 Moderator

    Hello @DeHaan58

    Thanks a lot for sharing this workaround. ??

    @BertK and @darwall, can you confirm that this workaround fixes the issue on your side as well?

    Best regards

    Jean

    French Community Moderator
  • BertK
    BertK Posts: 3 ✭✭

    Unfortunately the workaround doesn't work for me. Using Notepad on the 2nd computer in a non-fullscreen window, selecting text and typing ctrl-C just replaces the selected text with a C. Instead of copying it to the clipboard.

  • I'm sorry to hear that. You say '2nd computer' (first is the TeamViewer client, second is the TeamViewer host, third is the computer controlled by RDP) When at the second computer I start mstsc.exe and I choose Full-screen I have the problem. When I start mstsc.exe and I choose for example 1440 x 900 I don't have the problem.

    I also created a TeamViewer support ticket because I use Full-screen most of the time. No response yet.

  • BertK
    BertK Posts: 3 ✭✭

    Excuse me, in your terminology I should say "3rd computer". But anyhow, I can't reproduce your workaround. For me the problem occurs in a full-screen RDP as well as in a windowed RDP session.

  • Jo0Lz
    Jo0Lz Posts: 1 Newbie

    This has been bugging me for a long time now. I've actually switched to another solution because of this.

    I figured I'd see if this has been resolved yet, but it isn't. Any updates from Teamviewer? Acknowledgement that it is in fact a known issue? Is there any bug report?

  • ShaunRDC
    ShaunRDC Posts: 1

    I have had this issue for years. Full Screen mode sometimes works but most times it does nothing. Makes things like typing in a password with capitols very difficult.

  • Gerbstar
    Gerbstar Posts: 1 Newbie

    Same problem here. More than a year after initial bug report.

    Any update from Teamviewer team when this will be solved?

  • rian0880
    rian0880 Posts: 1

    I also have the same problem, very annoying!

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!