SHIFT and CTRL not working for Teamviewer + Remote Desktop

Options
BertK
BertK Posts: 3 ✭✭

SHIFT and CTRL are working for my teamviwer session to the remote computer with Windows 10. Also when directly logged in to the remote computer a Remote Desktop to another system with Window 7 works fine. For the combination of Teamviewer + Remote desktop however, the SHIFT and CTRL key are not working. Does anybody know why?

Comments

  • darwall
    darwall Posts: 1
    Options

    Hi though i was going mad, same issue hear, Teamviewer into Windows 10 comptuer, Shift Keys and CAPS and CTRL all work fine.

    Once connecting into RDP Windows 7 PC, with in Teamviewer session, the trouble begins, can't type with Shift key, Ctrl + combinations don't work and sam with CAPS . ??

    Surely someone has found a fix to parse the keyboard info through to RDP with teamviewer?

  • DeHaan58
    DeHaan58 Posts: 4 ✭✭
    Options

    Same problem here, but all three computers are Windows 10

  • DeHaan58
    DeHaan58 Posts: 4 ✭✭
    Options

    I solved this by not using full-screen for the RDP session.

  • JeanK
    JeanK Posts: 7,015 Community Manager 🌍
    Options

    Hello @DeHaan58

    Thanks a lot for sharing this workaround. ??

    @BertK and @darwall, can you confirm that this workaround fixes the issue on your side as well?

    Best regards

    Jean

    Community Manager

  • BertK
    BertK Posts: 3 ✭✭
    Options

    Unfortunately the workaround doesn't work for me. Using Notepad on the 2nd computer in a non-fullscreen window, selecting text and typing ctrl-C just replaces the selected text with a C. Instead of copying it to the clipboard.

  • DeHaan58
    DeHaan58 Posts: 4 ✭✭
    Options

    I'm sorry to hear that. You say '2nd computer' (first is the TeamViewer client, second is the TeamViewer host, third is the computer controlled by RDP) When at the second computer I start mstsc.exe and I choose Full-screen I have the problem. When I start mstsc.exe and I choose for example 1440 x 900 I don't have the problem.

    I also created a TeamViewer support ticket because I use Full-screen most of the time. No response yet.

  • BertK
    BertK Posts: 3 ✭✭
    Options

    Excuse me, in your terminology I should say "3rd computer". But anyhow, I can't reproduce your workaround. For me the problem occurs in a full-screen RDP as well as in a windowed RDP session.

  • Jo0Lz
    Jo0Lz Posts: 1
    Options

    This has been bugging me for a long time now. I've actually switched to another solution because of this.

    I figured I'd see if this has been resolved yet, but it isn't. Any updates from Teamviewer? Acknowledgement that it is in fact a known issue? Is there any bug report?

  • ShaunRDC
    ShaunRDC Posts: 1
    Options

    I have had this issue for years. Full Screen mode sometimes works but most times it does nothing. Makes things like typing in a password with capitols very difficult.

  • Gerbstar
    Gerbstar Posts: 1
    Options

    Same problem here. More than a year after initial bug report.

    Any update from Teamviewer team when this will be solved?

  • rian0880
    rian0880 Posts: 1
    Options

    I also have the same problem, very annoying!

  • Luub
    Luub Posts: 0
    Options

    I had the same problem, but only when I use the option "Show empty screen". When I turned this off, I didn't had the problem, but of course this is less secure.

    Reading some information about this item at the community-site of Microsoft, I found out that you can change the keyboard-settings at the options of the RDP-client. Setting "Apply Windows key combinations" to "On this computer" solfed the problem for me.


  • nathann
    nathann Posts: 3 ✭✭
    Options

    This is the last time I'm renewing Teamviewer in any of the organizations we support if this issue isn't addressed. This is so fundamental to have keystrokes passed to the remote client that TV should stop developing any other bells and whistles to solve this.

    It's not just RDP it can be other applications that are affected too. vSphere remote console is also affected.

    N.

  • SDP190
    SDP190 Posts: 2 ✭✭
    Options

    Same to me

  • micabaud
    micabaud Posts: 2 ✭✭
    Options

    For me, it is only when "Disable remote input" is enabled in the initial Teamviewer connection, regardless of full-screen or not in RDP.

    Where can I find the suport ticket?

  • micabaud
    micabaud Posts: 2 ✭✭
    Options

    I'd like to "support" it if possible! :)

  • Scottics
    Scottics Posts: 1
    Options

    Following worked for me... Before connecting to remote computer, right click the teamviewer icon connection for the computer in question, select properites, Advanced, and check Action Settings/remote input, set to (inherited) or Enable Remote Input. Mine was Disable remote input and show black screen. I had changed this and forgotten i did.

  • Peter_Sukenik
    Peter_Sukenik Posts: 3 ✭✭
    edited April 2023
    Options

    I am free user as I am using TeamViewer for personal use and at home I am connecting using RDP. The reason for this issue is RDP app on Mac OS. That is why I am using free version of [Removed as Community Guidelines] on my Mac to connect to my other Windows PC, using RDP protocol. Shift and all other buttons work this way.