Can no longer view or control my android phone w/quicksupport



  • michel4
    michel4 Posts: 3

    happy birthday post :-) you're one year old now. have some cake!

    your friends

  • mondipr
    mondipr Posts: 1

    Were is the solution to the Special Access. My Moto g7 plus not work.

  • BenniBDF
    BenniBDF Posts: 2

    Hey Folks, I just found a alternative solution/workaround for my Moto G6:

    I used "ApowerMirror" with USB-debug-mode to control my phone remotely (just search for these keywords online).

    Still the limitation here is: it only works in your local WiFi Network or while connected via USB cable...

  • ctunderw
    ctunderw Posts: 4

    Update 5/7/2020 -

    I just tried TeamViewer with my mom and I am now able to access her phone remotely!  I am running TeamViewer Version 15.5.73 CL on my Google Pixel and she is running Quick Support version 15.5.76 on her Motorola Z4 running Andrioid 10.

  • HonestLai
    HonestLai Posts: 1

    Unfortunately this is still broken for devices with Android 9 that's can't upgrade or downgrade to a version that works

  • ade_1
    ade_1 Posts: 2

    Which component is missing ?

  • ctunderw
    ctunderw Posts: 4

    @ade_1 - I am not sure which component is missing.  It may be the version of Andriod, the version of Quick Support or both.  I just happen to try it with my mom last week and it worked.  Here is what my mom's Moto Z was running:

    • Andriod 10:  build QDF30.130-42-1
    • Quick Support:  version 15.5.76

    I was connecting to her phone using my Google Pixel.  When I first tried to connect she got the screen to grant access and after she approved it I was able to connect successfully.  In the past it would have dropped me at that point in the connection process.


  • OlimNZ
    OlimNZ Posts: 6

    So, posibly phone to phone works but PC to Phone does not.

  • OlimNZ
    OlimNZ Posts: 6

    Yeah the Community Moderator is off having a baby I gather. You'd think they would appoint someone else in the meatime to curate the thread.

  • Xiaomi Redmi Note 8 Pro with the latest Firmware also not working... great stuff for an an issue, that is over a year old.

  • michel4
    michel4 Posts: 3

    are you actually running android 10? sorry for asking, thought that would resolve the issue.


  • Yep... Android 10. Basically the latest stable europe firmware.

  • michel4
    michel4 Posts: 3

    ok strange i'm running 9 and cannot upgrade (officially) but i thought it was resolved with 10 :-(

  • To anybody still following this thread, you might try out "**Third Party Product**. I have a Moto X4 and my in-laws have the Moto G7 Play. TeamViewer still can't control either device. Since TeamViewer isn't in any hurry I went ahead and tried out **Third Party Product** and it works on both. All of my devices, desktops included, are now switched over to **Third Party Product**

    TeamViewer censors the competition? That's lame.

  • OlimNZ
    OlimNZ Posts: 6

    Yep, that's rude. I tried**Third Party Product** and found it a lot more complex to install as it requires Developer mode. **Information removed as per CG**

  • BjornGrylls
    BjornGrylls Posts: 1

    I think I found the one you're referring to. I have same problem with TeamViewer on my Moto G6. For anyone else, the app starts with the second word in "MacBook Air" and ends with the last syllable of "Android".

  • lilmarsli
    lilmarsli Posts: 1 Newbie

    Hi all,

    I faced this problem when I try to connect to my mom's phone. The problem was fixed at the end.

    The reason at the beginning for using QuickSupport was to help her to do stuff on her phone (changing some settings, how to use some specific features, etc), but I ended up helping her how to enable screen capturing on QuickSupport :D

    Her phone is Realme RMX2030. When we realize the problem, I looked it up then found this thread. I also thought that the problem was because of the permissions. And also, I thought it might be an issue caused by its Android version. But after I made her look at the version, it was 10. So I thought it wouldn't be the case because I was able to connect to my phone from my computer. My phone is also Android 10. I made my mom change some settings and made her enable everything for the QuickSupport app in App settings and App Permission settings which took an hour :) I don't know exactly what she did, because I could only guide her over the phone. But after she enabled things I was finally able to manage to see her screen.

    Go to App Settings, find QuickSupport, and enable whatever you can find related to this issue. Because apparently, it is a screen-sharing problem rather than a connection problem. Somebody else here had suggested elevated access settings. That also may be the source of the problem. When you attempt to connect, a message on the screen should read "Allow remote support? Would you like to allow ... to remote support your Android device?". You need to press "allow". Then a second message should appear which says "QuickSupport will start capturing everything that's displayed on your screen". Click "Start Now". Then it's ready to go.

  • astefan
    astefan Posts: 1
    edited January 2021

    Hi There,

    Please I need support!

    I cannot control remote my phone Samsung A20e ( Android 10) , Everytime in apps I have a black screen. Add- on Sasmsung can not be install.

    Is there any solution to control may phone Samsung A20e?

    Thank you for your support

  • ebeighe
    ebeighe Posts: 11 ✭✭

    I just tried this today in the slender hope that somehow it would work.

    Moto X4 w/ Android 9 ("Pi").

    One encourageing sign was after installing Quicksupport, it request to install the "universal add-on" -- which i did. The bad sign is it still asks for something about elevated privelege and to tap here but then there's no way to grant it :-(

    when trying to connect, it asks "allow remote support" (i answer yes, of course)

    and immediately after that it requests to enable "universal add-on activation" to which i answer enable, of course...

    Then nothing happens; on the pc-side, it just hangs on "authenticating".

  • Tarsha
    Tarsha Posts: 1

    I have an elderly mother in another state that needs desperate help with her Samsung Galaxy 9+ Android.

    I don't know if this is still an issue. I was having this exact problem. I just spent the last 12 hours and found the simplest of solutions that has worked every time.

    I originally had installed QuickSupport, Host, Pilot, and also TeamViewer full version .. ALL on my android.

    On my PC I had TeamViewer full free version (Version #15.19.5 32-bit. Dated July 1, 2021 at 3:12 pm *receiving insider builds*) and Google Chrome TeamViewer extension. The Google Chrome extension gave an error of being the wrong version type and would not allow me to connect. I went back through 16 years of memories of using TeamViewer and experiencing several version conflicts between dozens of devices. 

    Since I retired, I've not really needed to use TeamViewer for anything more than the laziness of not wanting to walk across the room to my other laptop. I've also not needed to log into my PC's from my cell phone much.

    Anyhow, I uninstalled the PC TeamViewer full free version (Version #15.19.5 32-bit. Dated July 1, 2021 at 3:29 pm *receiving insider builds*) and did a complete sanitation using my favorite uninstaller program. I then reinstalled Teamviewer full free version (Version# 15.15.5 64-bit. Dated July 1, 3:29pm) ---no insider builds.

    After the reinstall, I was able to access the Remote Control Settings screen to allow the required permission. I was able to connect to my Samsung Galaxy 9+ Android using TeamViewer Host and TeamViewer QuickSupport. I'm leaning towards using TeamViewer Host because it does not require authorization and can be accessed unattended (the fewer clicks mom has to perform the better for the sanity of us both).

    I wanted to ensure this was a solid solution for my particular problem so I uninstalled every form of TeamViewer from my cell then only installed TeamViewer Host on it. It still worked spectacularly, allowing me real-time screen sharing, apps list, unlock the phone..etc

    I hope this will help someone.

    Tarsha 😉