teamviewer.com link icon
or
Ask The Community

auto assignment not working (msi)

I've had a working deployment for weeks, but it suddenly stopped working.

In the teamviewer logs I get the following error:

2019/02/05 11:58:31.677 6096 5352 C0+ ApiRequestExecutor: request https://webapi.teamviewer.com/api/v1/groups?shared=False&name=Unassigned successful
2019/02/05 11:58:31.677 6096 5352 C0+ AssignDeviceSequence::Step3_GetGroup: no group found, need to create it

It's telling me that the group Unassigned does not exist. It does exist.

I'm using the following commandline for auto assignment and this has always worked untill know: TeamViewer_Host.msi CUSTOMCONFIGID=xxxx APITOKEN=xxxxxxx-xxxxxxxxxxxxx IMPORTREGFILE=1 ASSIGNMENTOPTIONS="--grant-easy-access" /qn /norestart

I check in teamviewer, the tokens and customconfigid are still correct.

Are there known issues on the side of 

Best Answer

Answers

  • Yes, it seems to be resolved with adding the group-id.

    Thank you.

  • This it the command line I am using to bypass this.  Support helped me with this last week as well.   They say they have a new .MSI created to fix the issue but as Friday they hadn't released it yet. 

    msiexec.exe /i "TeamViewer_Host.msi" ALLUSERS=1 /qn /norestart /log output.log CUSTOMCONFIGID=XXXXXXX APITOKEN=XXXXXXXXXXXXXXXXXXX IMPORTREGFILE=1 assignmentoptions="--alias %Computername% --grant-easy-access true --reassign --group-id gXXXXXXXX"

  • Is there a possibility to see which computers havent' had a succesful autoassignment?

    I'm deploying this to around 800 computers via GPO. It seems that since a week this deployment no longer worked. It's a bit crazy to figure this out manually.

    Can i check via a scripted way, if the autoassignment was succesful? If i check the installation of the MSI, that is offcourse installed. 

  • By the  --group-id gXXXXXX do you mean the number from the web interface of the group in the URL where it is  /home/buddies/g/######## ? So it would be   --group-id g######  leaving the g in front of the numbers?