teamviewer.com link icon
or
Ask The Community

unknown architecture 'aarch64'

When starting teamviewer on a rock pi 4, I got the error message:

Init...

Error: CheckCPU: unknown architecture 'aarch64'

 

Comments

  • acdifran
    acdifran Posts: 1

    I was able to solve this by adding aarch64 to the checks performed by the start script. Navigate to where teamviewer is installed (for me this was /opt/teamviewer). Navigate further to tv_bin/script. Open tvw_main and find the section where it checks the architecture (CheckCPU function). Where you see ( armv71 ), add aarch64, so the line now reads ( armv71 | aarch64 ). Then try running it again (run "teamviewer" from the terminal).

  • Teo64
    Teo64 Posts: 1

    I tried to do as instructed but fails

    teamviewer

    Init...
    CheckCPU: armv7l
    Checking setup...
    Launching TeamViewer ...
    Launching TeamViewer GUI ...
    Aborted

     

  • agui
    agui Posts: 1
    exactly the same problem,have you solved it?
  • xhuvom
    xhuvom Posts: 3

    I am also facing the same problem. My platform in Jetson Xavier

  • ShamannRunner
    ShamannRunner Posts: 2 Newbie

    Any update on this?

Sign In or Register to comment.