Only LAN connections are possible shows up although I am connected to the internet

Options

I have just installed TeamViewer12.0.75813 on Windows 7 64 Bit but when I run it, the following message shows up in the lower left corner:

Only LAN connections are possible.

I read that the reason is most-likely that I am not connected to the internet, but I am definitely (I am writing this post, so...).

Best Answer

Answers

  • mLipok
    mLipok Posts: 781 ⭐Star⭐
    Options

    Try to check here:
    TV_ContactList_LanConnectionOnly.png

    Regards,
    mLipok , AutoIt MVP
  • OSLINAUTSIND
    OSLINAUTSIND Posts: 1
    Options

    english please

  • MattC
    MattC Posts: 4 ✭✭
    Options

    General->Incoming LAN connections is set to "accept" (not "accept exclusively"!)

    I see this answer all the time, but it is not the solution; TV still shows "Only LAN connections are possible"

    For me this is an Ubuntu/Linux issue - other computers with TV installed on the same network do not have this problem

    Version 12.0.76279 wine-1.6 (latest, Mar 24 2017 00:45:31)

  • Chiron
    Chiron Posts: 229 ✭✭
    Options

    Link sort of related issue.

    Link also related.

    This may be a DNS issue on the computer that is having the problem. You have internet connection, but you may not be resolving the address of the TeamViewer servers.

    You should be able to ping master11.teamviewer.com - or similar - master3, master4,..

    Compare the results against one of the computers on the LAN that is working.

    I don't work for TeamViewer. I'm just a user.
  • MattC
    MattC Posts: 4 ✭✭
    Options

    Unfortunately not, all resolve correctly.

    I have now also tried the Chrome TV extension on the same computer,  which works, so it is likely not a networking issue. Also, there are no errors in the TV log relating to networking

  • gabriele-vecchi
    gabriele-vecchi Posts: 2 ✭✭
    Options

    The same problem with Windows 10, no proposed solution is working.

  • cosmin
    cosmin Posts: 1
    Options

    Have the same problem on 2 machines running Ubuntu 17.04

    Both accept only LAN connections even both are able to use the internet connection.

    Another issue is that both cannot Sign In at all. 

    Still cannot understand why is not working

  • ITDogNumber1
    ITDogNumber1 Posts: 1
    Options

    Haven't seen much thanks, but had same issue as others mentioned on Gentoo (soucecoded linux distro). I'm using TS13 and they messed around with the layout, but problem was the same. I think I had a  TS11 running nicely, and 12 no problems. I am sure solution will work, so in advance thanks. ITGuyNumber47

  • glycoaddict
    glycoaddict Posts: 1
    Options

    solved! your suggestion of DNS was helpful. Our network must've done something with the DNS

    in command prompt > ipconfig /flushdns

    After a minute, if nothing happens either restart TV12 or go into advanced options, set the server to some value, hit ok and ok, then repeat and set to blank.

  • duleNS
    duleNS Posts: 3 ✭✭
    Options

    We have installed TeamViewer 14.2.2558 Corporate licence on Windows 10 64 Bit.
    Five days ago suddenly, all TeamViewer machines became inaccessible even though they have a connection to the Internet - Only LAN connection are possible?!
    At the same time TeamViewer download and update work  - Help / Check for new version - update work!
    Machines have a connection to the Internet, but only LAN is enabled.
    What's the problem with this TeamViewer version?
    We have a corporate license and we suffer great damage every day for this failure!

  • MattC
    MattC Posts: 4 ✭✭
    Options
    In the end I tracked my issue down to a VPN client installation on the same machine. Irrespective of whether the VPN client was active, the fact it was installed was incompatible with TeamViewer due to the underlying network changes it made.
    Uninstalling the VPN client resolved the issue
  • duleNS
    duleNS Posts: 3 ✭✭
    Options

    We do not have installed VPN clients on machines with this problem!

  • wclusa
    wclusa Posts: 1
    Options

    In my case, the Teamviewer 12 service (TeamViewer_service.exe) was hung and I couldn't restart it.  I had to manually kill the service, then afterwards I could start it afresh, at which point I was able to access remote teamviewer PCs & laptops outside the local LAN.

    I have no doubt that an alternate solution for me would have been to simply reboot the affected laptop but reboots take longer than killing, then restarting a service.

    My problem started when I moved my laptop from a hard wire connection to wifi then back to hard wire - we do it all the time at work when taking our laptops to and from meetings.

    This is the first and only time I've encountered this particular issue.