link icon
Ask The Community

Base64 Password Connection

How does the Base64 password connection work? I try to use 

 start-process -filepath 'C:\Program Files (x86)\TeamViewer\TeamViewer.exe' -argumentlist "-i <TeamviewerID> --PasswordB64 <PasswordInBase64Encoding>"

and I get an incorrect password notification.

If I try to use "--Password <Password>" it does connect successfully.

I just used an online converter to get the Base64 encoding. (For example, 'Password' becomes 'UGFzc3dvcmQ=')


  • ajones
    ajones Posts: 14


  • ajones
    ajones Posts: 14


  • ajones
    ajones Posts: 14

    No support for this?

  • ajones
    ajones Posts: 14


  • ajones
    ajones Posts: 14

    What a useless forum, a year and a half since posting and no replies. Figured this was a fairly simple question considering you guys have it in your documentation..

  • TotalPC
    TotalPC Posts: 87 ⭐Star⭐

    Hello @ajones ,

    I just tested the below using my own data and both worked as expected. Try copying my PowerShell code below and try it with your ID and Password...

    If this works for you...

    start-process -filepath "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" -argumentlist "-i [TeamViewerID] -P [PlainTextPassword]"

    ...but this does not work for you...

    start-process -filepath "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" -argumentlist "-i [TeamViewerID] --PasswordB64 [Base64EncodedPassword]"

    ...all I can think of is either the Base64 encoded password is wrong or maybe extra characters are slipping into your command.

    Here's a test for your Base64 encoder; a random password I created for this test: HWBV1738
    should Base64 encode to: SFdCVjE3Mzg=

    Since that worked for me you can try testing with it too by temporarily adding it to additional passwords on the remote system. This way the only thing you need to switch out in the below code is your TeamViewer ID. Don't forget to delete it after testing.

    Additional Passwords.png

    start-process -filepath "C:\Program Files (x86)\TeamViewer\TeamViewer.exe" -argumentlist "-i 1O1O1O1O1 --PasswordB64 SFdCVjE3Mzg="


    The parameter requirements can be picky, for example two dashes are required before the --PasswordB64, if it has just one dash it doesn't work (you'll get an incorrect password), and it's the other way around for the Short variant, -B works but if two dashes are before it, it won't work.

    Hope this helps you.


    TeamViewer user since version 6 (2010). We used other remote software programs (TVNC UVNC PCAny) for many years before.
  • ajones
    ajones Posts: 14

    Thanks for that info TotalPC, I appreciate the response!

    I am a bit busy this week but I will defintiely give that a shot when I have a few minutes free.



Sign In or Register to comment.