teamviewer.com link icon
or
Ask The Community
Update now to the most recent TeamViewer version 15.30. See the Change Logs here.

TeamViewer Change Logs - What´s New!

[Windows] v14.2.2558 (Full) - Change Log

Esther
Esther Posts: 4,112 Former Community Manager


 




We released a new version of the Windows full version.

Operating system: Windows

Version: v14.2.2558 (Full)

Release date: 2019-03-19

Change Log:
  • TeamViewer-UDP now also works in IPv6-Only-Networks or where specific NAT-Technology prevent UDP via IPv4 from working.
  • With a new access control for script execution for incoming and outgoing sessions that can be rolled out via policies in the Management Console the permissions can be set more granular.
  • Script execution is now also possible when connecting to a Linux remote machine. The necessary scripts can be uploaded in the Management Console.
  • Major performance improvements for TeamViewer Pilot connections
  • Free-hand drawing of Pilot connection partner
  • Improved the remote control performance by improving how TeamViewer leverages the network for optimal throughput
  • Now the script menu within the session is updated while having a session if scripts are added, deleted or updated.
  • Improved the way how TeamViewer handles CTRL keys in combination with other programs
  • Fixed a bug that created new folders during a file transfer when copying from/to a network drive (that is not mapped).
  • Fixed a bug that caused TeamViewer to freeze when large files were copied especially from a network drive.

  • Fixed a bug that caused a decreased remote control performance when connecting to macOS devices where TeamViewer is configured as start with system
  • Fixed a bug that results in a freeze of the remote Excel application for copy & paste from a local Excel file to a remote Excel file (only occurred for big local Excel files).
  • Fixed a bug that caused videos running on the remote machine to freeze during a connection when resizing the video window
  • Fixed a bug that caused screen artifacts when resizing a video during the remote control session
  • Fixed a bug that caused TeamViewer to consume more memory than expected during remote control sessions
  • Fixed a bug that caused TeamViewer to consume more memory than expected while transferring large files
  • Fixed a bug that caused TeamViewer to consume more memory than expected when using an account with many partners in the computers & contacts list
  • Solved some other issues which caused crashes
  • Minor improvements and fixes

Former Community Manager

Tagged:

Comments

  • Mr_Wolf
    Mr_Wolf Posts: 13 ✭✭

    Hi, I have an issue with the latest update. I have a PC with Windows 7 64 bit and TeamViewer is set to start on boot. Since I've installed the latest update, when I boot my PC, my PC frezees for one-two minutes, and in special way the wireless system tray icon is freezed while connecting to my router, till TeamViewer system tray icon shows up.

    I've made several tests and it seems it's TeamViewer the culprit. I remember I had a similar problem some times ago, which was solved with an update.

    By the way, I don't have the same problem on another PC with Windows 10 64 bit.

  • JeanK
    JeanK Posts: 5,643 Community Manager 🌍

    Hello @Mr_Wolf,

    Thank you for your message.

    This is indeed an unexpected behaviour.

    In this case, I recommend you to fully uninstall TeamViewer (with all the .reg files in your registry editor) and reinstall TeamViewer. You will find all the information you need in the following article: How to uninstall TeamViewer on your PC

    Please note, that this is going to remove all the TeamViewer settings that you have set up locally on your device. You will need, for example, to tick the "Start with Windows" option again.

    I hope this could help. If not, do not hesitate to contact us again.

    Cheers

    Jean

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • ITDSupport
    ITDSupport Posts: 3 ✭✭

    Executing scripts does not work at all, the "Scripts" button is inactive (grey) and after highlighting it I see: "Remote side does not allow script".

    We experienced this on WIndows and MacOS. Of course in incoming connections we have all settings on "Allowed".

    https://photos.app.goo.gl/bk5uJMT9hN7Q9DSU9

    https://photos.app.goo.gl/SPBnAtJUFGeWA93p9

    https://photos.app.goo.gl/ZxAXWnxYpV5i6S1E8

    Only rollback to previous build resolve problem.

  • Esther
    Esther Posts: 4,112 Former Community Manager

    Hi @ITDSupport 

    Thanks for your feedback.

    Can you check whether version 14.2.2558 is installed on both devices (your device and the remote one)?

    Thanks in advance and best,

    Esther

    Former Community Manager

  • Mr_Wolf
    Mr_Wolf Posts: 13 ✭✭

    Hi @JeanK, Ive tried to uninstall & reinstall, but the issue was not solved.

    As I said, I had the same or a similar problem some times ago, and only a new update solved it.

  • ITDSupport
    ITDSupport Posts: 3 ✭✭

    Hi!

    We use TV Host on client site. I've tried to reinstall Host too, but no changes.

  • gbsmatt
    gbsmatt Posts: 1

    Some of our users have updated to this build and it has caused a problem with copy and paste in our custom program.  We can still copy and paste text but our custom objects no longer copy.  Those users still running the previous build can copy and paste everything with no problem and there hasn't ever been a problem up until now.

    This is a major problem for us and in the short term I would just like to reinstall the previous build.  Can anyone tell me where i can download version 14.1.18533?

  • Esther
    Esther Posts: 4,112 Former Community Manager

    HI @gbsmatt 

    Thanks for your post.

    To analyze this, may I ask you to send us the Support Collector both from a device with 14.1 (without the issue) and from a device with 14.2 (with the issue)? Please send the files by submitting a ticket via this page (you need to scroll down a bit): https://www.teamviewer.com/en/support/ 

    Thanks and best,

    Esther

    Former Community Manager

  • I'm missing essential information on the v14 updates:

    * [REMOVED] We have removed the automatic assignment of the machine to your account when you logon to your account with the client after a fresh installation.

    [/sarcasme on] For your convenience you now have to manually add the machine to your account ...

    We removed this option to make TeamViewer more user friendly. [/sarcasme off]