teamviewer.com link icon
or
Ask The Community

Remote update 2019

Cannot update remote system because of "old version" message. Nobody can operate manually on remote computer (no display can be connected). I need initiate update process remotely. Older manuals says it is possible, but this last update is killing my system - in manual there are only information about manual update on  remote.

Is it possible somehow update remotely? Remote system is visible...

Tagged:

Comments

  • AlenaC
    AlenaC Posts: 821 Moderator

    Hi @DmytrQ ,

    thank you for your post.

    If you can connect remotely to your device you should be able to update it. Please click this link to get more information: How do I update TeamViewer?

    Please let me know if you need further information.

    Have a nice Thursday,

    Alena

    Spanish Community Moderator :)

  • DmytrQ
    DmytrQ Posts: 5

    Remote computer is visible in the my computers list:

    Снимок.JPG

    I can open, for example, chat window with it.

    But when I try to connect, I see 

    Снимок.JPG

    I could connected some monthes before. But now I don't see the way, how I can connect.
    Will it help, if i'll try older version on my computer? Or bloking is because servers blocks older version on remote, so older on my will not help?
    Is it possible to fix this issue somehow?
    - Well, I also checked version on my computer, it is 12 version. I didn't update for be compartibly with remote. I am not sure, which version is on remote. But message is about "there" is an old version, not "here", so i still asking for help.

  • AlenaC
    AlenaC Posts: 821 Moderator

    Hi @DmytrQ ,

    thank you for the post and the screenshots too.

    It seems that you have to update both of your devices.

    We are recommending our users to update to the newest version  (currently TV14), so that you can use our best and safest features. 

    Here (Updating to the latest and greatest version of TeamViewer. )  you will find all the information regarding the update.

    Please let me know if you need more information.

    Have a nice Friday,

    Alen

    Spanish Community Moderator :)

  • DmytrQ
    DmytrQ Posts: 5

    Your message doesn`t help. Sure it is good to update both devices, but the question is how to update remote computer, if it has no monitor, and can be accessed only with Teamviewer. And Teamviewer recently blocked the access because of old version. 
    The remote is visible, probably it is possible to install 3 services, but doesn't allow to control and upgrade.

    I figure out myself one possible solution: from the web login of Teamviewer I found an option to connect from web. Have fixed some problems with flesh, and voila - i see my remote. 

    I checked, there was 11 version there.

    I found there and option to upgrade version from 11 to 14... And this was my mistake, because after I initiated upgrade, I have lost my remote. It is not even visible any more :(

    Probably I had to downgrade version on my local, or upgrade 11-12-13-14, not 11-14, or not to touch anything and to do my task through web, while it was working.

    Now I can say good buy for my remote. Thank you, Teamviewer and Teamviewer support.
    TV- very good service, thanks. But these upgrade issues - I am not happy :))

  • MacTen
    MacTen Posts: 6

    I have exactly the same problem,

    The machines I try to connect with are all running teamviewer v12.0.76279  . Last Day I was able to connect was 8th of April, but not it is not possible anymore. Devices are online and listed in my devices list, but connection is not possible due to remote temviewer version is out of date. I tried to establish connection with different teamviewer versions( v12 , v13, v14 ) but none of them was capable of connecting to my devices anymore. I'm using a free license and my location is EU. Please teamviewer support give us any option to regain connection to older software versions!

  • It really is a big problem !!

    for LINUX servers that handle client TV in versions 8,9,10

    Could you keep connecting? it is not possible to update these libraries in LINUX

  • Pamparam
    Pamparam Posts: 1

    Same problem here. I cannot update remote - it shows, I can connect but update message pops out and no way I can update. 

  • DmytrQ
    DmytrQ Posts: 5

    As I mentioned earlier, I do managed to upgrade the remote with the help of web - service. But the connection to remote was totally lost after this.
    Yesterday I have set a monitor to rhis remote, so I can check what happened.
    Teamviewer was really upgraded to v.14. But it cannot run because of some C++ libraries error. Previous versions worked well. It is winXP system.

    So You can try.

    I have one more remote with Win 7 with same situation. I will try to upgrade it from web. If succeed, I will report here.

  • SMSlutex
    SMSlutex Posts: 1

    @DmytrQ  how did you connected via web?

    Ive tried chrome app and web connection (with flash) and TW app - and nothing let me connect.

    All with the same error old vesion problem

  • DmytrQ
    DmytrQ Posts: 5

    @SMSlutex I didn't managed to connect via web. I've started upgrade on remote via web. And when I reached the remote in live, i saw, TW app was upgraded. But there where c++ runtime error, so i didn't reach remote after upgrade.
    On my second  case I cannot even start upgrade via web, because i don't remember password :) it is closed under dots in TW app.

  • Unessential
    Unessential Posts: 3 ✭✭

    Man, yesterday I turned on teamviewer on a computer I knew i wouldn't have physical access to for a week.

    No message to upgrade or notice that their policy has changed.

    Now I can't access the content of my computer... the least they could do is allow a connection for the sole purpose of updating...

    It wouldn't be such a problem if they had the foresight implement this in a way where people would be informed and/or not lose access to anything...

    Will definitely be looking for an alternative since I obviously can't trust Teamviewer to implement things in a way that doesn't majorly disrupt my activities.

  • Yeah this was a pretty dumb move. I have a NUC in the UK (am in US), it has no monitor or keyboard. I am the only admin and I wont be there till February (4 months time). Totally buggered up my productivity. Its over there burning power, I can see it is alive in the TV dashboard, but I cant get to it..... sigh...

  • Szoulias
    Szoulias Posts: 1

    Can someone from Teamviewer give a responsible answer ? I have 1100 devices total and at 480 of them i don't have access😡

  • P_Versluis
    P_Versluis Posts: 3 ✭✭

    Same problem here, cannot acces 200+ linux devices remotely.

    Anyone from teamviewer got a solution for us?