teamviewer.com link icon
or
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳


Please find more information here.

TeamViewer on iPhone not connecting over mobile data on the T-Mobile network

I used it last night at my house on my wifi network and it worked fine. I just tried it right now over mobile data on the T-Mobile network and it is not working. When I try to sign in, I get the message "sign in failed. Please check your internet connection". Obviously my internet is working just fine....

Tagged:

Best Answers

«1

Answers

  • sbertram
    sbertram Posts: 2

    I am having a similar issue on iPhone 6 (t-mobile) Using wifi, i can connect. Over cellular, it just says connecting without actually connecting

  • My Teamviewer has stopped working from my Android device over T-Mobile within the past several days/weeks. Works alright if I disable data and rely solely on Wi-FI.

  • kash
    kash Posts: 1

    I'm using Tmobile and it was working fine before on Tmobile but now I've to use wi-fi everytime I need to connect to my laptop at home. I tried both from Andriod and iOS devices. 

    I live in Chicago, IL and using the same laptop and T-Mobile from the same location. 

    This is the msge I get everytime I try to connect directly "A connection could not be established please check your internet connection". My data on my phone working greate. 

    Please help!

     

  • Hello,

    Thanks for the update; it looks like it's finally working for me with the T-Mobile network in the Los Angeles county area :) I still have to try using teamviewer on a device that's connected via hotspot, but I'm sure it'll be fine now. Thanks again.
  • acot
    acot Posts: 5

    I have the same issue as this customer.

    Im on t-mobile. i am from chicagoland area. I have an iphone 7 plus. I have version 12.1.76106 CL of the IOS App for Teamviewer. I am on IOS version 10.2.1. I am using LTE wireless data (this seems to be important) My hotspot is not on.

    Here is what I have troubleshot so far.

    This all started after that last server downtime/update teamviewer announced. (not saying thats cause, just that it started after that) Teamviewer has always worked for me on my current phone, current, IOS, and current carrier before. I cannot confirm if I have the same Teamviewer Build that it worked on as my phone auto updated IOS apps.

    When I try to log into my account over wireless LTE I see "Operation Failed. Please check your internet connection and try again"

    If I try over Wifi it works.

    If i turn off LTE in settings > Cellular > Cellular Data Options > Enable LTE > Off and force 4G everything works.

    If I gain an active connection to a remote PC through the app over wifi or 4G and then switch my phone back to LTE the connection stays active and I am able to manipulate the remote PC without any time out.

    If I close the connection (that i activated over wifi/4g and swapped over to LTE) then it brings me back to a blank blue computers screen in the teamviewer app.

    I can turn off my phone or go on airplane and back or close the app or double tap home and slide the app up close. none of that matters when i go back onto the teamviewer app over LTE I will get a blue window with nothing on it on the computers tab of the teamviewer app.

    If i go to settings and sign out. I will then see the normal login page on the Computers tab but when i enter my credentials i get, as stated above, "Operation Failed. Please check your internet connection and try again"

    I am a Tech Advisor for a software company that troubleshoots high level excalated calls all day. I would be happy to help in any way with figureing this out.

    In the mean time, i can still switch my phone over to 4G and everything works when I need to connect in a pinch but obviously this is not ideal.

  • I'm on Android and on Tmobile.  Teamviewer hasn't worked properly since about 2 weeks ago or so.  

     

    Please work with Tmobile to get your software working on their network again.  Thank you.

  • compdepo
    compdepo Posts: 1

    Using Samsung Galaxy note 5, note 3, and s7 edge.  Non of them work as well on tmobile data.  I tried logmein and logmein works fine.

  • wsloan
    wsloan Posts: 8

    I am in Chicago. Teamviewer is not working on T Mobil network. I spoke with T Mobil and they said it should work over thier network. They instructed me to ask the app developer if they are restricting cellular data and making the app only work over WiFi?

  • acot
    acot Posts: 5

    If any of you have iphones (not sure if you can do this on android) can you try switching to 4g and trying it like I did.

    Over LTE Teamviewer does not work, but over 4G it does. SO obviously the T-Mobile cellular network works.

    Its something about Teamviewer trying to connect over LTE

    Here are my instrctions from above:

    If i turn off LTE in settings > Cellular > Cellular Data Options > Enable LTE > Off and force 4G everything works.

  • acot
    acot Posts: 5

    Update--- what I wrote above does not seem to be consistant.

    On saturday night 4/22 at 11pm central timeteamviewer worked over LTE to get to the computers select screen and allow me to connect but its back to never working again.

    Yesterday at lunch 4/26 at around 11:30 central time LTE and 4G did not work. (4g has been consistantly working for me) I had to go back into a wifi signal range to get to the computer select screen and connect to my PC, once connected I was able to go out of range and keep the connection open over LTE no problem as long as I didnt disconnect.

    4g appears to be consistantly working again.

  • wsloan
    wsloan Posts: 8
    Does anyone know if this is a TeamViewer issue or a TMobil issue?
  • It is an issue with TeamViewer on T-Mobile and the TeamViewer support team doesn't seem to care to get it fixed...they are expecting us to reach out to T-Mobile to get their (TeamViewer) program working...
  • wsloan
    wsloan Posts: 8
    TeamViwer support:

    Can you respond to this to confirm if the issue is on your end or Tmobil's?????

    Thank you
  • acot
    acot Posts: 5
    I got a private message from staff member Julia on this thread saying that some people have gotten it fixed by calling T-Mobile. Except she didn't tell me how or what to say. Maybe tell me a port range that needs to be open?
    I called T-Mobile and they don't know what I'm talking about.
  • wsloan
    wsloan Posts: 8
    I called TMobil as well and they didn't have any ideas on how to fix it or why there was a problem. My personal thought is TMobil is blocking it as a way to reduce the amount of data usage on thier network.
  • At the end of the day, it is not our responsibility to fix this. TeamViewer and their support staff are the one's that should be working with T-Mobile to resolve this problem.

    I am currently paying for a license to use this software and TeamViewer does not seem to care to fix it. If the problem isn't resolved shortly, I will be contacting TeamViewer for a full refund of my payment.

    This delay is seriously getting out of hand.
  • LBean
    LBean Posts: 2

    Yes I am having this issue as well. Teamviewer should be working actively with T-Mobile, clearly the affected carrier here, to resolve the issue.

  • wsloan
    wsloan Posts: 8
    Do you know if they are? I have called TMobil and they do not seem very interested in resolving this. Been looking at switching to Verizon, they have some new plans that make them more competitive with TMobil than in the past.
  • LBean
    LBean Posts: 2

    Sorry I meant to imply that it's Teamviewer's responsibility to work with T-Mobile to resolve this issue. I don't know if they actually are though :(

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi to all,

    After changing the infrastructure, with the change of the IP addresses for TeamViewer, there have been some missed alignments and various issues by some internet service providers (ISPs)
    They have come to Italy, Israel, the United States, China and others: all have been solved by the reference ISP; for these TeamViewer I believe has directed the various service technicians to circumscribe and solve the abnormal cases.

    Among the various tests requested, to which the community contributed, were:
    - verify reachability master1.teamviewer.com ... up to master12.teamviewer.com (via ping);
    - Routing at least on first server master1.teamviewer.com (cmd -> tracert master1.teamviewer.com);
    - cleaning the device cache;
    - reading TeamViewer log files on some devices.

    In some cases, after resolving the problem by ISP, some customers had to disconnect and reconnect their home routers to get a new IP assigned to them.

    I personally do not think TeamViewer is happy with the lack of use of its product; Just as I do not really believe that T-Mobile wants to limit the use of its own band (more you consume ... more you spend).

    I'm really convinced that this is a mere technical problem and that TeamViewer and T-Mobile are at work to understand and solve it.

    Do you agree? Can you run some of the tests listed above?

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • Maldeus
    Maldeus Posts: 1

    Same issue like others, the app worked fine until suddenly after last update stopped.

    The app works fine over wi-fi, tried to test the web addresses suggested in other posts, with result web page is up and running. switching to lower network speed does not fix the issue.The app developer needs to fix the issue. The app is working fine on a different network(AT&T). maybe it has to do something with IP6 address on my phone.

    maybe it has to do something with IPv6 address on my phone.

    Please fix it. 

    the whole purpose of the app is to have access to my computer when I'm not using Wi-Fi

     

     

  • Julia
    Julia Posts: 290 Staff member 🤠

    Hi all,

    Thank you for your contribution in this thread :)

    I double checked the issue with our development.

    The provider has a problem to connect to our servers when LTE is activated (as you can see in some previous posts, a workaround at the moment is to disable LTE).

    So the provider has an ISP issue and they have to make sure that they can connect to our servers and they have to set *.teamviewer.com on their whitelist.

    We already reached out the provider and we kindly invite you to get in touch with them and ask them to grant you this access.

    Julia
    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • As I feel it is not my responsibility to fix your program's issue, I will not be contacting TMobile. I will wait for TeamViewer to press the issue further with TMobile to resolve this problem.
  • wsloan
    wsloan Posts: 8
    I just spoke to a TMobil tech guy and he filled out a ticket for thier engineers to try and figure out why thier network is blocking it because it should not be blocking it.

    I do wish Teamviewr would be a bit more proactive in trying to resolve this issue for thier customers.
  • wsloan
    wsloan Posts: 8
    I spoke with a TMobil engineer and they claim the issue is that TeamViewer needs to update thier app so that it can be accessed via IPV6.

    So if this is correct, when will this update take place? If this is not correct, how can we solve this problem? Can you confirm if Verizon customers are accessing teamviewr over thier LTE network?
  • jwxx
    jwxx Posts: 1

    It seems to fix the problem on my Tmobile s7 edege after apply "reset to default" under Access Point Names.

  • Anovil
    Anovil Posts: 2

    Same issue here:

    iPhone 7 with T-Mobile, in Chicago. 

    Doesn't work on LTE, but works on WiFi.

    Disabling LTE doesn't seem to work for me.

    Logs show multiple timeouts (first occurence is to master2.teamviewer.com:5938)

    This is quite upsetting. Please fix.

  • acot
    acot Posts: 5

    Hey everyone, everythings been working for me all weekend and today over LTE.

    How about the rest of you? we all fixed?