Teamviewer is running an old version which is out of date / no connection anymore !!


Teamviewer cutted support for me ( free license) to connect to machines with older teamviewer version installed. I try to connect to some machines running teamviewer v12.0.76279 on linux. Because these system are too far away, i have no option to update teamviewer manually at the moment. I have machines with same software configuration on my local network and I'm still able to connect to these clients per LAN( It is working with v14 /v13 /v12 I can confirm) , But no chance to establish a connection over Internet. Is there any teamviewer version for any OS that is still able to connect to old versions (v12.0.76279) . Please Help !



  • ashwathn
    ashwathn Posts: 1

    Getting a warning when connecting to a remote TeamViewer.

    The remote TeamViewer is running an old version which is out of date since 2019.02.04. Your connection partner can update TeamViewer by clicking on "Help" - "Check for new version"

    This refused me to connect to the remote machine. With Error : Unknown

  • Natascha
    Natascha Posts: 1,591 Moderator

    Hi @ashwathn 

    Thank you for your message. 

    Can you please update the TeamViewer to the latest version on both sides?

    Please let me know if you have any further questions. 

    All the best,

    German Community moderator 💙 Moderatorin der deutschsprachigen Community

  • samiam
    samiam Posts: 1


    Will this also be happening with Version 13 by Jun 2019 as per link? Or only Version 12 and older? I understand eventually it'll need to be updated but wanted to double check.

    Thank You.

    P.S. the linked site says June 18th, 2019 . Why were the users above cut off earlier? seems like if your going to publish a date then that would be the date it would happen vs randomly.
  • MacTen
    MacTen Posts: 6


    I'm having the same problem with some machines running a linux distribution. On this machines teamviewer v12.0.76279 is installed. Since a couple of days I'm unable to connect to this machines, same error message as described in first post. If on the same local network and using the IP adresses, I still can connect to linux machines running teamviewer version mentioned above. Tried this with teamviewer v12 / v13 / v14 for windows , all working well. But trying to establish connection to same machines over internet is dropping the error. Meaning this is blocked by server side of teamviewer. My problem is, that the publisher of my linux distribution told me, updating the teamviewer version will brick up my whole linux image. Because of this, updating to higher version seems to be no option for me. Any other solution out there? Or do I need to say goodbye teamviewer? Please Help!

  • akrippen
    akrippen Posts: 1


    I have the same problem but I can't update the Teamviewer on both side, because one of the systems has to run W2K. What's to do?

    Best regards,


  • wolf0104
    wolf0104 Posts: 2

    I have the same problem. I cannot update the Client!!! Because other partners cannot work with Version 14. What can we do??

  • Sandysus
    Sandysus Posts: 1

    I´m having the same problem. Have downloaded version 14 to my Macbook Air with Mojave, trying to connect to a friends older version of Macbook Air wit High Sierra who cannot download version 14 but has to go with version 12. I´ve tried 2 different Macbook Airs and also my boyfriends windows-computer but I get the same error message on all 3 computers. If I try do connect between my computers it works fine. And also if another friend try to connect with version 14 to my friends version 12 it works?! 

  • bhanu_user
    bhanu_user Posts: 2

    same issue since many months on samsung android. Have samsung host installed but it wont work.

  • It really is a concern for servers working with LINUX perfectly as a client, with TV9, because many of them do not have support for the latest update on tv14. Should I look for other software that does the same?

    I clarify, with Windows system there would be no problem in client and operator with TV14! as far as I know

  • I have the same problem for linux servers I can not touch customer tv9

    any solution

  • RoyR
    RoyR Posts: 1

    same issue. can;t connect with the machines with linux teamviewer 12.

    What is the solution for this? a paid version can connect to the machine with teamviewer

  • Natascha
    Natascha Posts: 1,591 Moderator

    Hi @RoyR @MacTen @bhanu_user 

    Thank you all for your posts. 

    In your cases I would recommend you to read the following article carefully: Enjoy using the best version of TeamViewer we made so far! - How to proceed?

    Please make sure, that you are using the latest TeamViewer version if you are not a license holder. You may update the remote TeamViewer with a policy. Therefore it is necessary that the remote device is assigned to your account. More information about the policies and how to apply them, you'll find in these articles: How do I assign a device to my TeamViewer account? and How to add a new settings policy 

    Please let us know if there are any further questions.

    Wish all of you a great Friday and a relaxing weekend :)
    All the best,

    German Community moderator 💙 Moderatorin der deutschsprachigen Community

  • StephenD
    StephenD Posts: 6

    I'm a free user connecting from TV 14.2.8352 on my PC to an Android phone (used as a Home Automation controller) that has TV Host for Samsung installed,  Although it's currently working I'm getting the update nag every time I connect and all the "learn how" to update information refers to updating TV on a PC, not Host for Samsung on an Android.  My Host for Samsung is the latest version.   (I have 2 Android phones with the same issue.)

    What do I do to stop the nag and, more importantly, ensure I can keep connecting?

  • I have the same problem and have updated both my computer and the remote computer however we both still get the same message. I am a private use client, never had any problems before with team viewer.

    Please help me get this sorted out.


  • Tinytosh
    Tinytosh Posts: 1

    I was asked by a relative if I could provide their first ever computer and because they had never previously used Windows I decided to give them a laptop with Linux Mint 17.3 because that cane pre-configured with Firefox browser, Thunderbird e-mail client and LibreOffice for document handling.  I installed on it the then latest Teamviewer which was Version 12, which started on boot so that if they had problems I could connect and see what was going on.  I also set up my own laptop to dual boot the native Windows 10 and also Linux Mint 17.3 so that if necessary I could replicate what they were failing to do using the same build spec.  It has worked perfectly when needed for over a year.

    Today when they asked for help, I connected OK but my connection timed out after 5 minutes because I was required to remotely update to Teamviewer14.  When I tried to do that, the update failed with error: "Dependency is not satisfiable:  libqt5gui5 | qt56-teamviewer"

    I am left with Teamviewer which currently times out after 5 minutes because I haven't updated to a newer version that won't install.  I either need this missing dependency resolved or a means to override the 5-minute time-out.  I have used Teamviewer only 5 times in the past year so I don't expect to have to buy a licence.

  • Thank you for you reply however I am not sure how this helps me as both my partner and myself on request, updated our computers from version 12 to 14 and yet we still both keep getting the message to update to a newer version.


  • MacTen
    MacTen Posts: 6

    Hi johnjwwilcox ,

    I only want to ask you about your comment 2 weeks ago and discuss this. You said, you are having 2 machines  , both running teamviewer version 14 (operating system can be any) AND YOU ARE STILL UNABLE TO ESTABLISH A CONNECTION?? This really sounds weird, I never experienced this behavior in the last time. Can you give us some pictures or screenshots from the teamviewer version number (from both systems) and maybe a screenshot from the error message you have?

    I'm pretty sure, there must be any other error within your configuration. With a succesfully installed teamviewer version 14 on both ends, all connections must work without any special paid license and around the world.


  • MacTen
    MacTen Posts: 6

    Hello, I just wanted to drop some information I got from some smart guys.

    It's an old story, that teamviewer version 14 is not running on a lot of older linux distributons. I'm not that tech guy to explain everything, but it's mostly upon qt 5 , that was introduced with teamviewer 14. Official statement : you can only upgrade to teamviewer 12/13 on older linux distributions or you need to upgrade to a newer linux version. My hint : search the web for teamviewer build number 14.0.14470 ! You need to find a install  package with that version suitable for your linux environment.Because of this is an early version of teamviewer 14 not using qt 5, it should run smoothly on your linux.

    I hope this will help you

  • Thank you very much for responding, on Linux servers, I can not update TeamViewer, I have no control. about them, everything was fine until the message of 5 minutes of connection and mandatory update began. It really is a problem for me, the TV client should continue to work as before, at least for Linux.
  • keyreel
    keyreel Posts: 5

    Teamviewer is trying to say: Throw out all the computers that cannot run TV14!!! It's obvious. Until you want to pay subscription! They just don't care about it anymore. I'm having the same problem.  I assume company changed their management. And it started, first of all they cut my connections saying I'm using it illegally. I sent 5 email requests. for over 10 connections which were interrupted. 

    Teamviewer was great program, until they started showing the face, everybody actually showing right now in software industry. All this inapp purchases, subscritption.... everywhere. My last laugh was about music metronome and the version with... Subscription! Metronome! :D  Do you remember time when you were buying soft? One time purchase? Not anymore! 

    Well I'm pretty **bleep**ed. My parents have Mac Mini 2007 and they live 7500 miles away, I physically cannot upgrade it right now. And I cannot fly there until end of July. All I can say, thank you Teamviewer! 

  • I still do not understand what the company intends to do, to cancel the incoming connections of TeamViewer 8,9,10,12? Without having control over them to update. which is the goal of complicating both the client that has Linux servers that do not allow updating. I can not ask the company to throw away their Linux server !!!
  • Test-rack
    Test-rack Posts: 1

    I updated my Debian 8 box running TV 10 to Debian 9. After that TV stopped working so I updated it to latest version on your site TV 14.2.8352. Funny part was I could access other machines running latest version of TV but no machine could access the Debian box.

    I signed up for the management console to make sure I could grant access to specific computer if I needed to, still no go. One funny thing I noticed in the console, the Debian box was still reporting itself as running TV10. When I tried accessing it via console, the application it looks for on my windows PC is TV10 which was removed long ago. I purged TV couple of times and reinstalled it using APT PURGE and APT-GET (I used autoremove and clean to remove stuff when purging the app). Evern after uninstalling and reinstalling TV14, the console still sees the box as TV10. Is there a fix for this? Are there any residual files that I need to go and remove or modify? I have found some mentions of TV10 on the Debian 9 OS, but they don't talk about the version of the software (unless I'm missing what to look for in the files or location).

    Help please. Thank you.





  • KZ
    KZ Posts: 1



    Due to the new policy, I just found I cannot login to my remote personal PC which has an older version of Teamviewer on it. (Error: Version out-of-date: Update the remote TeamViewer). Today is June 13, 2019, literally 5 days before the deadline June 18th deadline.

    The fact is, my remote PC is physically really far from me, that I or other people cannot reach it locally and login to update teamviewer, at least for months. 

    This is a poor design and bad policy. Guess I have to give up Teamviewer under this scenario. Not sure how many users are under the same condition. BTW, free account here. 




  • hhc
    hhc Posts: 4 ✭✭

    Hi, i am a paid customer, i have bought Version 11 Premium and since yesterday i have several customers that are calling me beacuse they connect to their computers in a casual way once per month, they use the free version and now the can't connect neither with version 11 or version 14, in the host pc is installed version 11 so i can connect with my paid license.

    How should i proceed to be able to continue using my license and they can connect with that frecuency (1 a month), beacuse if they update both ends i will not be able to connect.

    Thank you.

    @Natascha wrote:

    Hi @ashwathn 

    Thank you for your message. 

    Can you please update the TeamViewer to the latest version on both sides?

    Please let me know if you have any further questions. 

    All the best,