teamviewer.com link icon
or
Ask The Community

Connect to both old and new versions of teamviewer

Hi, I'm using the latest V14 Teamviewer. I want to connect to two locations - one which is also using the latest version, but another version which is using version 11.

When I try to connect to the version 11 site I get a message saying it's too old, and asking the remote site to upgrade to the latest version. The problem is this remote site is using Windows XP and CANNOT be upgraded to a newer operating system for all sorts of boring reasons.

So... how to connect to that site?

Tagged:

Comments

  • Esther
    Esther Posts: 3,811 Community Manager 🌍

    HI @Johnno 

    Thanks for your post.

    Chances are pretty good that you can use TeamViewer 14 on the XP as well.

    Which operating systems are supported? 

    Have a great weekend,

    Esther

    Community Manager
  • Johnno
    Johnno Posts: 2

    Actually, I did install TV14 on the XP system, but was no longer able to succesfully connect to it. So I uninstalled it (because teamviewer website tells me that TV14  is not compatible with XP) and installed an older version. However, then I always receive a message saying something like "the remote PC is using an old version which isn't compatible, please upgrade".

    So, I'm **bleep** if I do and **bleep** if I don't. Any way out of this?

    John

  • Esther
    Esther Posts: 3,811 Community Manager 🌍

    Hi @Johnno 

    Thanks for your reply. 

    We are no longer actively servicing Windows XP, but you can continue using version 14 of TeamViewer on this operating system if it works. Please keep in mind: we are no longer providing updates or fixes which are specific to them. See this announcement for more details.

    Regarding older version: Yes - Only customers with a license for an older version are still able to work with older TeamViewer versions and we’re asking our free users to update to the latest version to continue using TeamViewer.

    I hope this info helps you and that TeamViewer 14 works on your XP,

    Esther

    Community Manager
  • Hi,

    I am the licensed user of Teamviewer 11 Business. Teamviewer was promissed that I can use this license as a on premise for a lifetime when I purchassed. But I can't connect to my V11 clients from my V11 macbook anymore.Screen Shot 2019-07-22 at 06.40.49.png I get an this error (Both side are use V11)

     

  • Yuri_T
    Yuri_T Posts: 2,252 Moderator

    Hi @kevorkmalhas ,

    Thank you for your post.

    When you connect to version 11 that you purchased.

    Your TeamViewer on your local device, does not seem to be recognized as a license version.
    In order to use your license with the version 11, you need to make sure that your device is licensed.

    You can see more details about the activation from here.

    Also, please note that:

    • The business license can be installed on up to 3 devices.
    • Only one of those devices can be used to make a connection at the same time.
    • Only one side of a connection (Local side) needs to be licensed. That means, you do not need to setup on remote sides.

    When you connect to the newer version.

    With regards to your license, you need to use version 11 which you purchased on both of devices. 

    Here is the option to solve this issue.

    (1) updating to Subscription
    If you would like to use the latest version,  we will be able to find a suitable solution for you and send you an official quotation. Please feel free to contact our sales team.

    (2) getting version 11 back on both of devices
    If you are not interested in updating, please uninstall version 14 and reinstall version 11 from the below link.

    https://www.teamviewer.com/en/download/previous-versions/

    Please feel free to ask, if you have any further questions or require further information.

    Hope this will be helpful.

    All the best,
    Yuri

    Community Moderator/ コミュニティモデレーター
  • Avizo
    Avizo Posts: 1

    I have the same problem, but on Mac.

    I run a local little server for gaming purpose in my garage without keyboard/mouse/screen.

    Sometimes, I connect to it whith TeamViewer... But it doesn't connect anymore.

    I can't install version 14 on this old Mac OS and I can't upgrade Mac OS on this very old Mac.

    It's really a bad new that you REFUSE old users to continue using TeamViewer. I assume that the reason is NOT technical at all, but only commercial.

    Hoping you can change your decision... 

    Best regards

  • Man, yesterday I turned on teamviewer on a computer I knew i wouldn't have physical access to for a week.

    No message to upgrade or notice that their policy has changed.

    Now I can't access the content of my computer... the least they could do is allow a connection for the sole purpose of updating...

    It wouldn't be such a problem if they had the foresight implement this in a way where people would be informed and/or not lose access to anything...

    Will definitely be looking for an alternative since I obviously can't trust Teamviewer to implement things in a way that doesn't majorly disrupt my activities.

    I even downloaded the same version on my new computer and am still getting a message. so obviously they had the ability to tell me when I turned on teamviewer that I would no longer to be able to connect on a free license but chose not to until I had to connect.

    either a way to intentionally **bleep** people, or a huge oversight / bad decision making on how to inform people about this change...  I am definitely not happy.

  • MPPebworth
    MPPebworth Posts: 1

    Just ran into this same problem. It's incredibly annoying. 

  • Dukep6
    Dukep6 Posts: 2 ✭✭
    edited March 3

    Wanted to connect to my cousins pc to assist with a issue. I always used Team Viewer now I'm also getting this error and we are on the same version! if you update to the latest version it starts working but he can't as he is on Vista SP2! Why is older versions broken?

  • Dukep6
    Dukep6 Posts: 2 ✭✭

    Wanted to help my cousin out that is on Vista running Team viewer V14 and I'm also running v14 and getting this message The Remote TeamViewer is running an old version which is out of date!

    How those one solved this issue as he can't upgrade to a newer version then 14.2.56678

    If anyone can assist

    Kind regards

Sign In or Register to comment.