teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

TeamViewer_Desktop crashes on incoming connection: TeamViewer 14 on Ubuntu 18.04

Kaleb
Kaleb Posts: 3

Like the subject says: when there is an incoming connection, TeamViewer gets through the handshake, then TeamViewer_Desktop crashes. Relevant excerpt from the log:

Negotiating session encryption: client handshake received
Negotiating session encryption: client handshake received
Negotiating session encryption: server handshake sent, encryption established with AES key length 256
HandleSigChld: Child was dumped: 1744 signal 11
ProcessControlBase[4]: Process 1744 in session **Please do not post TeamViewer IDs** has terminated

(1744 is the PID of TeamViewer_Desktop)

Brief history if it's relevant:

  • was on Ubuntu 12.04 LTS. Everything worked fine until when trying to connect I got an error that TeamViewer on the remote server was too old.
  • Updated TeamViewer, but it wouldn't start due to something with the getRandom that some other people had problems with.
  • Upgraded to Ubuntu 14.04 LTS. Reinstalled TeamViewer and could connect, but after logging in, it would hang and reconnect just left me with something about trying to initialize the display. (some point in here I tried various versions of 14)
  • I dug into the logs and found some suspicious stuff (like a QT 5 X11Extras missing and the package not being found on the standard source lists)
  • Upgraded to Ubuntu 18.04. Reinstalled TeamViewer. It crashes on connect.

Let me know if it would help to post the logs, or core/stack dump. Please help me.

 

EDIT: It's also potentially noteworthy that this is somewhat of a headless server. I say somewhat, because  I've stuck a couple of resistors in certain pinholes of the VGA port, so the computer thinks it' connected to a monitor and starts up X normally (or at least it did in 12.04).

Comments

  • Kaleb
    Kaleb Posts: 3

    UPDATE: So, I have gotten things to work, mostly, with the following work-around:

    1. remove the remote server from my list of partners (the entry added by running "teamviewer setup" [same thing as assigning it to your account in the GUI, I think] on the remote server is invalid... well more specifically, it won't connect using the server ID)
    2. Install RDP on remote server and port forward appropriate ports (really just get some other way of accessing the server graphically)
    3. remote in using RDP and launch TeamViewer
    4. Open options and set your password to access that machine; hit OK
    5. note the listed User Id
    6. back on the client, add a new remote server
    7. use the User Id you noted and the password you created and name it what you want
    8. Now it connects successfully (As long as the Teamviewer GUI is open... See Edit2 below)

    So, I think this is still a bug, since connections using Server Id crash. I would like to get this back to where I can use double-click to connect, but at least this gives me access for now.

    EDIT: I just realized double-click still works. I just had to manually click "Connect using password" once, I guess... So, even though there's either a bug in TeamViewer or something wonky with my setup, I will mark this as the solution since it gets things working for me in the end.

    EDIT2: Some of you may have realized my folly here... This only works if you open the TeamViewer GUI on the remote machine. So, this doesn't actually solve my problem, as I'm unable to connect after reboot. I need to be able to use the Server Id instead of the User Id.

  • Kaleb
    Kaleb Posts: 3

    I just wanted to update this to say that my server is now on version 15.3.2682, and I still cannot connect to TeamViewer using the server id. If anyone has any solutions, it would be greatly appreciated.

    I am currently having to have RDP installed and the RDP port open which kind of defeats the purpose of TeamViewer, and opening the port, connecting via RDP, starting the TeamViewer GUI, disconnecting, and closing the port each time the server is restarted is a huge hassle. (I close the port afterwards, because there is otherewise a constant stream of attempted RDP connections from random people on the internet.)

  • ewaldc
    ewaldc Posts: 0
    edited December 2020

    Teamviewer version Linux: 15.12.4 (DEB)

    System is an Intel NUC with graphics card/hdmi connector but no physical console, nor graphic console connected.  No X server is running, nor display manager.

    Installation worked flawless.

    But when making a connection (file transfer or  remote connection), I get following error in TeamViewer15_Logfile.log:

    [logs removed per Community Guidelines]

    That does not sound right...

  • did this get resolved? how?

  • a-schild
    a-schild Posts: 2 ✭✭

    We see the same error with Ubuntu 18.04 and teamviewer 15.15.5 on 32 bit

    Any hints how to solve this?