TeamViewer is preparing for macOS Catalina



  • I have had issues connecting Mac to Mac ever since the Catalina update on each computer. I was able to get the connection working for a bit but then TeamViewer updated versions and the connection was botched again. I am running TeamViewer 15.0.8397 and macOS Catalina 10.15.1 on both computers. I have gone through and properly deleted and reinstalled TeamViewer on each computer and made sure all setting on both computers allow "full access".

    At this point I can connect and see the desktop of the partner computer but I cannot control anything.

  • I just uninstalled 15.0 and reinstalled v14.7.1965 I found at

    That did the trick.  I will try again with 15 when it hits 15.2 or so.

  • how do you install manually the latest version?

  • I did figure out,  I downloaded the latest version and installed it but for some reason it was still loading the old version, so I had to uninstall the old version and install the new, then it worked.  Thanks

  • JohnD
    JohnD Posts: 35

    TeamViewer Tech Support replied to my incident on this problem by acknowledging that it's a bug and saying that the workaround is to re-do the permissions on the Host Mac (below).  Hopefully a fix will be forthcoming soon.

    So the bottom line right now is don't update your Hosts remotely, because you will lose access to them via TeamViewer until you can fix the permissions either physically at the machine or via another remote-control system like Apple Remote Desktop.

    We have a current bug on our latest TeamViewer update. The issue is that after updating, the permissions need to be re configured on the MAC. 

    Please follow this guide to be able to control your macOS:**Please do not post TeamViewer IDs** 

  • MoreCoffee
    MoreCoffee Posts: 46 Staff member 🤠

    @tommynacc What you are seeing what happens if TeamViewer does not have permission to record the screen. Can you please check System Preferences > Security & Privacy > Privacy > Screen Recording? TeamViewer should be in that list and have a checkmark.

    If it is listed and has a checkmark, and the guest still cannot see anything other than the Catalina background, try un-checking and then checking the TeamViewer entry again.

  • Using TeamViewer (TV) v15.0.8397

    I had a working installation of TV. I upgraded to Catalina and now I cannot take control of the desktop. The settings in TV have not changed:


    And I went to the security options and gave TV the required permissions:


    I'm out of ideas.

  • How do you update manually?


  • Franco1947
    Franco1947 Posts: 3 ✭✭

    I had exactly the same problem. I solved so:

    Stop Your TeamViewer and install again from the TV web site.

    You will install the new version 15.0.8397 for Mac. There is no evidence, during installation, that you are actually installing the version 15 (no message) ... but it does it.

  • worldpeace
    worldpeace Posts: 2 ✭✭

    Similar issue just started less than a week ago.

    I have teamviewer remote access running on a Windows 10 and version is 15.0.8397 (Nov. 6 2019)

    and I have be accessing with two different MAC OS X 10.13.6 and Mac OSX 10.11.6 and now that

    something has changed (I do not remember doing any updates on Windows 10 Teamviewer) am getting the following message on Mac's - "Imcompatilble Versions" so I updated both mac's to its Maximum version: 14.7.1965 and now Macs can not match the Windows Teamviewer Version.

    Luckily I have an older Windows 7 laptop and was able to match the version with the remote windows 10 Teamviewer version. 

    I never had this issue before so is Mac teamviewer versions going to match the Windows version so both types of operating machines can work?

    If not is their a way to bring the windows version to match the 14.7.1965 mac teamviewer version? 

    As I said was working fine and I am assuming teamviewer updated on its own which I never new it would do it automatically (must be a new feature that was set on auto when I installed on windows several months before?).

    Please advise.

    Thank you, teamviewer team support.


  • Go to the teamviewer website and click the "download" button on the top of the page.  It will take you to the latest version for your operating system. 

  • averawc
    averawc Posts: 3 ✭✭

    Found my error. After downloading the latest version I reinstalled TeamViewer but received the same error message about partner's newer version. When searching downloads, I found that there were three (3) versions on TV. I had been installing the same teamviewer.exe version each time. After downloading teamviewer.exe (3), the latest version was installed and everything works perfectly. "Old too quick, smart too late"

  • Also hitting this error.  v14.7.x (latest) on Mac, v15.x (latest) on Windows.  Seems we're completely stuck until they release a v15.x for Mac?

  • I'm trying to connect to a partner computer. TeamViewer asked me to update in order to connect. I did and updated succesfully. However it is till asking me to update when I attempted again to connect. See screenshots.


    Screen Shot 2019-11-27 at 3.13.34 PM.pngScreen Shot 2019-11-27 at 3.13.52 PM.png

  • I have the same problem, the Mac version cannot work with the newest windows version. When will this be fixed? It's a huge problem because we manage our systems from a mac but all our clients are windows that automatically update! Now we cannot give any remote support! 

  • The funny thing is that iOS versions keep connecting to Windows, and the problem is just MacOS->Windows ?


  • The solution is posted above. You need to download the new MacOS version ( from the TV website directly. Hitting "update " doesn't work properly - that's the real problem!

  • Thanks!

  • relbas
    relbas Posts: 3 ✭✭

    i am running Catalina10.15,1 and the only what working is only screen sharing 

    but i dont have any control with the mouse or key board.

  • Same problem with MAC OS 10.15.1


    All settings checked!

  • Fully uninstall with config files, and reinstall problem solved.

  • MoreCoffee
    MoreCoffee Posts: 46 Staff member 🤠

    @RebellTEL @relbas  If you haven't done so already: Do not only check (= "look at") the settings, but turn the checkbox off and then on again in System Preferences > Security & Privacy > Privacy > Accessibility, for both the TeamViewer and TeamViewer_Desktop entries.

  • JohnD
    JohnD Posts: 35

    Looks like the issue I reported (the upgrade doesn't update the Privacy settings properly) is fixed in a new version v15.0.24 (that inexplicably has a lower version number).   That messed-up version number may also be why the Check For Update functionality doesn't offer it on any machines that already have v15.0.8397....looks like you have to download and install it manually for both Host and Full Client versions....

  • JohnD
    JohnD Posts: 35

    Looks like the issue I reported (the upgrade doesn't update the Privacy settings properly) is fixed in a new version v15.0.24 (that inexplicably has a lower version number).   That messed-up version number may also be why the Check For Update functionality doesn't offer it on any machines that already have v15.0.8397....looks like you have to download and install it manually for both Host and Full Client versions....

  • I cannot uncheck teamviewer_desktop or teamviewer. It just doesn't uncheck)

  • It helped, thanks! I quit teamviewer, deleted teamviewer and teamviewer_desktop from accessibility and started teamviewer again, checked teamviewer and teamviewer_desktop.

    Now it's working, thanks a lot!

  • I have been remoting in to my mother's iMAC (2019).  After yesterday, she updated to latest MacOS version, and I can establish a connection and move the mouse, etc, but can only see the toolbar at the top of her screen - rest is greyed out.  We've reinstalled / updates both sides of TV, but still get this.  I can even highlight the toolbar on her mac, but cannot see any other activity.

    Any suggestions woule be welcome.  I pretty much have to remote into her computer weekly to "unstick" something for her... Thanks

    screen shot of remote macscreen shot of remote mac

  • MoreCoffee
    MoreCoffee Posts: 46 Staff member 🤠

    @MikeTX  Did you / your mother give TeamViewer Screen Recording access on her iMac? This is a new requirement enforced by macOS Catalina 10.15.

    On your mother's iMac, there should be a yellow exclamation mark at the top of the TeamViewer main window:

    Screen Shot 2019-12-05 at 09.49.59.png

    If she clicks that exclamation mark, there should be a message and a button to request Screen Recording access. Clicking the button to request Screen Recording access should trigger a macOS prompt similar to this:


    Click "Open System Preferences" to go to System Preferences > Security & Privacy > Privacy > Screen Recording. There she needs to check the box next to TeamViewer to permit it to record the screen contents:


    When she checks the box, there will be a message to quit TeamViewer. After quitting and restarting TeamViewer, you should be able to see everything as expected.

  • MoreCoffee -

    That did it!.  Many thanks.  We had gotten to that screen (from her side) yesterday, but she couldn't explain to me what she was seeing.  Once I knew what to look for, we got it running right away.  Of course, I then spent another hour trying to configure her printer....

    Appreciate the response.