teamviewer.com link icon
or
Ask The Community

Disable Lock on Session End

Seems that Teamviewer is setting the "Lock on Session End" to enabled by default. How do I disable this permanently?

Best Answer

Answers

  • WWGJMRiggs
    WWGJMRiggs Posts: 2 ✭✭

    Thank you for your reply and explaining what each of the options mean.

  • OUR
    OUR Posts: 9

    Still not working on Mac :-( :-( :-(

    I have two identical installs by example

    One Works

    Screenshot 2019-11-06 at 08.26.26.png

    One does not Work

    Screenshot 2019-11-06 at 08.26.51.png

  • Doesnt work on win 10 when remoting in from Android 9. I have disabled the auto lock function.

  • PelicanMedia
    PelicanMedia Posts: 12 ✭✭

    @OUR This has been an issue for a LONG time now. TV seem to be just ignoring it...

    https://community.teamviewer.com/t5/General-Questions/Remote-session-always-logs-out-when-session-ends/m-p/16271

  • I do not have this option in my settings.

    Im using TeamViewer 15.4.4444 on a Mac High Sierra 

  • Hi,

    version 15.9.4 corporate lisc here...

    This solution does NOT work and has been an issue sometime now for those
    supporting remote systems running Win 10 Pro 64bit.

    this is something that should be addressed as a matter of priority please

  • Yuri_T
    Yuri_T Posts: 1,986 Moderator

    Hi @Ocean_Road

    Thank you for your post.

    I have checked with our technical support team and we have not been aware of any issues regarding this on our side. In order to understand your situation more, could you please provide an operating system on a local machine?

    Also, you can create a support ticket so our technical support team will be able to investigate this case individually.

    Kind regards,
    Yuri

    Community Moderator/ コミュニティモデレーター
  • For MacOS users:

    I know this used to be in the settings proper, but apparently, they've moved/hidden it for Mac users as of ver. 15.10.5. Once you log into the remote computer you should see a lock icon (indicating the computer will lock once you close the connection) next to the X to close the window on the top left-hand corner, click "Actions", highlight "Lock Computer", you should see a check next to "Lock on session end", click it and the check should disappear (along with the lock icon next to the X). After closing the connection and reconnecting, it should remember the setting. As far as if this change applies to all remote connections from here on out, I can't say for sure as I don't have a 3rd computer available to test that at the moment. 

  • adcxyz
    adcxyz Posts: 1 Newbie

    Hello,

    I am currently maintaining 3 recent macs (Minimac 2015, 2018, macbook 2015 macOS 10.13, 10.14, 10.15) remotely from a current macbook pro 2018, TeamViewer version 15.14.3. Overall, TeamViewer is great for that!

    Our setup is a sound installation that streams to radio, so it should never ever stop. BUT - everytime I log in, the menu at

    Actions -> Lock Computer -> Lock on session end is active again! So this is a bit like Groundhog Day, always turn it off when I login, always check before a logout ... It really should remember, please.

    thanks in advance, best regards,

    Alberto de Campo

  • johnroyer
    johnroyer Posts: 1 Newbie

    Version: Debian package 15.10.5

    Date: Sep 17 2020 10:18:27

    This version of TeamViewer is no option either.



Sign In or Register to comment.