teamviewer.com link icon
or
Ask The Community

Can't update to version 15

Hi everyone,

I have a problem! I have 3 computers. In one of them, I can't install the version 15, so, when I try to connect with another of my computers, I can't because are different versions.

I've tried to download it from the site, but the link download the version 14

I also tried to install it from the exe file from my others computers, but when I start the exe file, it is empty!

Help, help, help!

Thanks

Comments

  • Ying_Q
    Ying_Q Posts: 1,967 Moderator

    Hi @kingalex70,

    Thank you for posting in community.

    By default, when downloading TeamViewer, it should directly downloading the latest available version for installation. However, in special cases, TeamViewer would only provide the suitable version for download and installation. Can you kindly check the compatability of operating system and TeamViewer version please and choose the corresponding version to match your operating system.

    Hope it would be helpful.    

    Regards

    Ying_Q

    Community Moderator/中文社区管理员
  • Thanks a lot for the answer.

    My computer mith version 14 is a winXp.

    So, another question. In this case, one computer has version 14 and the other has version 15, how can I transfer my files from one to the other? If I work from the version 14 the sotware say me that the other computer has a newer version and can't able to connect. If I work from the computer with version 15, the software doesn't connect the computers without an explication.

    Maybe the solution is to install version 14 in all my computers till I change the old one?

    Thanks a lot.

  • nickvyk
    nickvyk Posts: 1

    I have the same issue. I'm trying to connect from my Mac (TeamViewer v15) to Windows server 2007 (TeamViewer v14.2). It failed to connect, it says the remote version is out of date...

    Have you resolved this issue? I tried to install an older version on my Mac but it didn't work neither. I was not able to connect to Windows server 2007 with the same reason.

    Is it possible to make it work?

     

    Thanks,

    Nick


  • @nickvyk wrote:

    I have the same issue. I'm trying to connect from my Mac (TeamViewer v15) to Windows server 2007 (TeamViewer v14.2). It failed to connect, it says the remote version is out of date...

    Have you resolved this issue? I tried to install an older version on my Mac but it didn't work neither. I was not able to connect to Windows server 2007 with the same reason.

    Is it possible to make it work?

     

    Thanks,

    Nick


    Unfortunately, I couldn't solve the problem. It solved itself because the computer broke down and I had to change it. Then I installed the latest version and everything works. But I got no answer from TeamViewer. 

    Bye

  • Owen72
    Owen72 Posts: 3 Newbie
    edited September 20

    Have the same problem with a old computer running Vista and not being able to update that win version. Ludichrist I cant update to TV v15 or connect to it.

    [removed per Community Guidelines]