teamviewer.com link icon
or
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉


Check out our brand-new Portuguese Community 👉 here 👈.

Can't connect to Android phones as of late - "server did not respond in the given time frame"

Werkaster
Werkaster Posts: 4

I can't connect to Android phones anymore. I get the message "The server did not respond in the given time frame" every time I try to connect to them. All clients, on all sides, are up-to-date, including both Quick Support and the Add-on for the Samsung and Huawei phones I've previously had no problem to connect to.

Also, one important fact before you consider blaming firewalls, virus or network settings. If I use Teamviewer I can still connect to computers all over the place. So far I've tried a bunch of different computers with different setups and it all works fine. Phones are the problems.

This didn't happen before, just a few weeks ago everything worked fine, so I'm guessing one of your updates did something, or something in the newer Android versions is blocking Quick Support without telling it. 

Please, help me out and let me know what's wrong and how to fix it.

With regards
Daniel Persson

Tagged:

Comments

  • Hi @Werkaster

    Other people have been having this problem so the servers may have temporarily gone down. Try again later

    From,

    James