teamviewer.com link icon
or
Ask The Community

Certain apps give a black screen in remote control

Hello,

I write to you perhaps with a rather strange question/remark.
This is because I have a handicap (muscular disease) which makes me almost completely paralyzed and thus unable to use a touchscreen. So I actually use the free version of Teamviewer in order to be able to use; my smartphone from my laptop pc.

Recently there must have been an update because since yesterday the remote control started behaving strangely. Today however, I had to consent on my smartphone to new terms and conditions, and the connection was normalized. But now several apps stopped working properly in remote control, they are actually opened on my smartphone but on my laptop I just see a black screen. It is only with banking or payment apps that I get this, so I suppose it's some sort of security update that prevents the remote usage of this kind of apps. Is this indeed the case?

Whatever the cause, for me this is a problem as I really want to use these apps and I am not able to use a touchscreen and operate my smartphone directly. I know there is allways a small security risk, but for me it is perhaps more important that I'm able to use these apps.
So my question is if it is possible to circumvent this new blockage in a way and keep using all sorts of apps in remote control?

Extra information: I use a Windows laptop and a recent Android smartphone from Samsung. My version of Teamviewer is 15.0.8397.

Can anyone help me with this?

Tagged:

Best Answer

Answers

  • Natascha
    Natascha Posts: 1,518 Senior Moderator

    Hi @JelleM94 

    Thank you for your post. 

    Can you please check your Samsung Knox settings? Maybe they don't allow you to remotely control apps like your banking apps and such. We did not implement such security feature.

    Please also download the latest version of the TeamViewer app from your Play Store and make sure to have the latest version 15.1.3937 installed on your PC. 

    Hope this could help. Wish you a great day. 

    All the best,
    Natascha

    German Community moderator 💙 Moderatorin der deutschsprachigen Community

  • JelleM94
    JelleM94 Posts: 6 ✭✭

    Thank you for your answer.

    It could indeed be some kind of security setting in the OS of Samsung/Android, but I can't seem to find a way to change those settings. Can anyone help me with that?

    Anyway, I will certainly also try re-installing Teamviewer with the latest version on both my devices. You never know that it helps.

  • JelleM94
    JelleM94 Posts: 6 ✭✭

    In the meantime, I have tried re-installing Teamviewer on both devices, but unfortunately it didn't solve the issue.

    But when I re-installed the host-app, I got a poç-up that I had to activate Samsung Knox if I wanted to use the remote control function. I tried once not pressing on 'activate', but then I just completely couldn't connect. When I first started using Teamviewer I certainly didn't get such a pop-up, so I suppose it has indeed to do with Samsung Knox. I'm quite sure, because I now also tried connecting with my sister's smartphone (not a Samsung) and I didn't have any issue there to access apps.

    So can anyone help me with how to change Samsung Knox settings or if necessary how to de-activate it?

  • Kthemmerling
    Kthemmerling Posts: 2 ✭✭

    @JelleM94I have ALS so I have the same problem! If I figure out how to adjust the settings, I will let you know!!

  • I have exactly the same problem. Meanwhile, is there a solution to disable this in Knox?

  • Futureweb
    Futureweb Posts: 2 ✭✭

    Its an old thread, but I still wanted to ask. We got Teamviewer Corporate, and wanted to replace another app on android.

    We use a 2FA App, that is black with Teamviewer, tried Know and Media, but the same issue. The other app works, but means, we would need it next to teamviewer, which is sad.

    Also trying to find to "allow" this specific app, otherwise I understand those messures for mobiles you do quick support on, but not for ones you explicitly want that behaviour not to happen.