teamviewer.com link icon
or
Ask The Community

Team Viewer on a Raspberry Pi 4 - Terminal Window Delays

I've just done a clean install of Raspbian Buster onto a new RPi4, installed Team Viewer host, and everything works and connects and I can remotely control the RPi4.

However, if I open a terminal window while remotely connected, and type some commands, it always shows one command behind what it should.

For example, if I type the command: pwd (without pressing return) the remote display shows:

[email protected]:~ $ pw

whereas the monitor connected to the HDMI port on the RPi4 shows:

[email protected]:~ $ pwd

The screen only updates if I leave it for around 20 seconds, or if I move my mouse over the terminal window, (or type another character but then it's still behind one character).

I've tried a complete reinstall of everything, but it's still the same. I've also tried running the Team Viewer client from another PC, but again, still the same.

Any ideas how I can get it to refresh the screen correctly as I type, at the moment its barely usable/incredibly annoying.

Comments

  • DomLanDomLan Posts: 490 Star

    Hi @BenGolden,

    a first attempt may be to temporarily disconnect the HDMI cable from the device. It is possible that the Pi4 internal video board buffers your keyboard input.

    Let me know if you notice any changes in the delay times.

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
Sign In or Register to comment.