Remote access without remote user approval each time

Hi,

Since upgrading TV to ver. 15.2.sxx, I am unable to access my very old father's computer without him having to confirm each time that I am allowed to access it. He's no longer able to do so quickly enough...

I need to access his computer without any intervention from him. (His computer and his TV are both on at all times.)

Would someone please direct me to the instructions for this, for ver. 15.2.xxx (the old instructions I find lead to tab items that no longer exist).

Thank you,

JF

 

Tagged:

Best Answer

  • Yuri_T
    Yuri_T Posts: 2,256 [Former Staff]
    Answer ✓

    Hi @JosephusFlavius ,

    Thank you for your reply.

    First, could you please check if you setup "Full access" on a local devices on top of the setting I mentioned ealier?

    TeamViewer software > Extras > Options > Advanced > Show advanced options > Advanced settings for connections to other computers > Full AccessFull access 1.png

    Secondly, with regards to your first question, if you do not setup anything, the answer is Yes as a default.

    This is the basic connection.

    How it Works

    On your friends' and family members' computers

    1. Ask your friend or family member to install the TeamViewer Full Version in their computer.
    2. Ask your friend or family member to share their TeamViewer ID and password.
    3. You can connect to your friend's or family member's computer.

    On your computer

    1. Install the TeamViewer full version software.
    2. On your computer, enter the TeamViewer ID of your friend or family member under the heading Control Remote Computer.
    3. Click the Connect to partner button.
    4. Enter the TeamViewer password of your friend or family member.
    5. You can work on that computer as if you were sitting directly in front of it.

     

    Thirdly, with regards to your second question, you do not have to put your remote device information on your computer and partner lists. You can make a connection as the above instruction. (This isn't an unattended access.)

    Finally, as you explained, I understand that you would like to make an unattended access. So you must setup one of the below instructions.

    1) Setup personal password on the remote device.

    Personal password

    The personal password is a password defined by you. If you enter a password, you will be able to use that password anytime in place of the randomly generated temporary password to access this computer (unattended access). 

    Under Extras --> Options --> Security--> Under Personal password (for unattended access) --> Password --> Type in your password --> Confirm password  Repeat your chosen password to confirm it --> click OK

    The password you are choosing will never be visible to you or anybody else. Instead of the password you will see black dots. 

    personal password.png

     

    2) Setup the easy access

    As an alternative option to a password for unattended access, you can also grant your own TeamViewer account Easy access. With this feature, no password is set and you can easily connect to your device when logged in to your TeamViewer account.

    This method can be classified as very secure because such access is only possible via a TeamViewer account, which can be protected additionally with the Two-factor authentication. 

    To activate Easy acces the device must be assigned to your TeamViewer account.

    Watch this video to get a guided tour of how to activate Easy Access: 

     

    Note: You can only assign your device to your account if you have administrative rights and TeamViewer is installed.

    If activated, access to the computer is only possible in the following cases:

    • Easy access without password is only possible with your TeamViewer account.
    • For other connections the TeamViewer ID and the password of the device are required.
    • If in the TeamViewer settings you deactivate the random or personal password, you, and only you, have access to the device via your TeamViewer account. 

    Note: If the device is in a shared group, then all contacts that use the group, also have easy access to the device.

    To activate easy access to a computer, start TeamViewer on the computer and make sure to be logged in to your TeamViewer account.

    Note: If you have never used your TeamViewer account on a device, with an app or within a browser, you have to authorize the account usage at the first login.

    If the device is already assigned to your TeamViewer account: Click Extras --> Options --> Security --> under Personal Password (for unattended access) activate the checkbox Grant easy access --> click OK

    If the device is not yet assigned to your TeamViewer account: Click Extras --> Options --> Security --> click the Configure... button --> The Assign to account dialog box will open --> Click the Assign button --> Under Personal Password (for unattended access) activate the Grant easy access checkbox --> click OK.

    You have activated easy access for this device.

    easyaccess.png

    Note: You must activate this function individually for each computer.

    Hope this will be helpful.

    All the best,
    Yuri

    Former Japanese Community Moderator

Answers

  • Yuri_T
    Yuri_T Posts: 2,256 [Former Staff]

    Hi @JosephusFlavius ,

    Thank you for your post.

    Could you please check if your endpoint device has been setup for Full Access by clicking Extras > Options > Advanced > Advanced options > Access Control - Full Access?Full access.png

    In order to setup unattended access, please read this article.

    Hope this will be helpful.

    All the best, 
    Yuri

    Former Japanese Community Moderator
  • Hi,

    Unfortunately, this issue was not solved by the advice provided earlier.

    All the settings indicated in Yuri_T 's advice were set and confirmed. But, when I try to connect, the remote computer still requires remote confirmation, which is what we want to avoid (because the user is too old and no longer capable of dealing with).

    And, after the remote confirmation was provided, the remote desktop required additional remote confirmation to allow me to make changes to anything. Again, that too must be made automatically or else we cannot use Teamviewer.

    I would greatly appreciate the full set of instructions that allow the main user (me) to  access, make changes, and control the remote desktop without requiring any involvement of the remote user. I would really appreciate a *complete* anwser, with all the details and steps, because we do not go there often enough and need to resolve this over a single visit.

    Please indicate in the instructions whether my being logged onto the remote Teamviewer software (same login as I am on my base station login) helps or prevents it from working as desired. 

    Thank you again,

    JF

  • Hi All,

    This is a follow up to an older query which, unfortunately, is not solved:

    https://community.teamviewer.com/t5/General-Questions/Remote-access-without-remote-user-approval-each-time/m-p/82346/highlight/false#M36535

    Original query:

    Hi,

    Since upgrading TV to ver. 15.2.sxx, I am unable to access my very old father's computer without him having to confirm each time that I am allowed to access it. He's no longer able to do so quickly enough...

    I need to access his computer without any intervention from him. (His computer and his TV are both on at all times.)

    Would someone please direct me to the instructions for this, for ver. 15.2.xxx (the old instructions I find lead to tab items that no longer exist).

    FOLLOW UP/UPDATE

    Unfortunately, this issue was not solved by the advice provided earlier.

    All the settings indicated in @Yuri_T 's advice were set and confirmed. But, when I try to connect, the remote computer still requires remote confirmation, which is what we want to avoid (because the user is too old and no longer capable of dealing with).

    And, after the remote confirmation was provided, the remote desktop required additional remote confirmation to allow me to make changes to anything. Again, that too must be made automatically or else we cannot use Teamviewer.

    I would greatly appreciate the full set of instructions that allow the main user (me) to access, make changes, and control the remote desktop without requiring any involvement of the remote user. I would really appreciate a *complete* anwser, with all the details and steps, because we do not go there often enough and need to resolve this over a single visit.

    Please indicate in the instructions whether my being logged onto the remote Teamviewer software (same login as I am on my base station login) helps or prevents it from working as desired.

    Thank you again,

    JF

     

  • Yuri_T
    Yuri_T Posts: 2,256 [Former Staff]
    Answer ✓

    Hi @JosephusFlavius ,

    Thank you for your reply.

    First, could you please check if you setup "Full access" on a local devices on top of the setting I mentioned ealier?

    TeamViewer software > Extras > Options > Advanced > Show advanced options > Advanced settings for connections to other computers > Full AccessFull access 1.png

    Secondly, with regards to your first question, if you do not setup anything, the answer is Yes as a default.

    This is the basic connection.

    How it Works

    On your friends' and family members' computers

    1. Ask your friend or family member to install the TeamViewer Full Version in their computer.
    2. Ask your friend or family member to share their TeamViewer ID and password.
    3. You can connect to your friend's or family member's computer.

    On your computer

    1. Install the TeamViewer full version software.
    2. On your computer, enter the TeamViewer ID of your friend or family member under the heading Control Remote Computer.
    3. Click the Connect to partner button.
    4. Enter the TeamViewer password of your friend or family member.
    5. You can work on that computer as if you were sitting directly in front of it.

     

    Thirdly, with regards to your second question, you do not have to put your remote device information on your computer and partner lists. You can make a connection as the above instruction. (This isn't an unattended access.)

    Finally, as you explained, I understand that you would like to make an unattended access. So you must setup one of the below instructions.

    1) Setup personal password on the remote device.

    Personal password

    The personal password is a password defined by you. If you enter a password, you will be able to use that password anytime in place of the randomly generated temporary password to access this computer (unattended access). 

    Under Extras --> Options --> Security--> Under Personal password (for unattended access) --> Password --> Type in your password --> Confirm password  Repeat your chosen password to confirm it --> click OK

    The password you are choosing will never be visible to you or anybody else. Instead of the password you will see black dots. 

    personal password.png

     

    2) Setup the easy access

    As an alternative option to a password for unattended access, you can also grant your own TeamViewer account Easy access. With this feature, no password is set and you can easily connect to your device when logged in to your TeamViewer account.

    This method can be classified as very secure because such access is only possible via a TeamViewer account, which can be protected additionally with the Two-factor authentication. 

    To activate Easy acces the device must be assigned to your TeamViewer account.

    Watch this video to get a guided tour of how to activate Easy Access: 

     

    Note: You can only assign your device to your account if you have administrative rights and TeamViewer is installed.

    If activated, access to the computer is only possible in the following cases:

    • Easy access without password is only possible with your TeamViewer account.
    • For other connections the TeamViewer ID and the password of the device are required.
    • If in the TeamViewer settings you deactivate the random or personal password, you, and only you, have access to the device via your TeamViewer account. 

    Note: If the device is in a shared group, then all contacts that use the group, also have easy access to the device.

    To activate easy access to a computer, start TeamViewer on the computer and make sure to be logged in to your TeamViewer account.

    Note: If you have never used your TeamViewer account on a device, with an app or within a browser, you have to authorize the account usage at the first login.

    If the device is already assigned to your TeamViewer account: Click Extras --> Options --> Security --> under Personal Password (for unattended access) activate the checkbox Grant easy access --> click OK

    If the device is not yet assigned to your TeamViewer account: Click Extras --> Options --> Security --> click the Configure... button --> The Assign to account dialog box will open --> Click the Assign button --> Under Personal Password (for unattended access) activate the Grant easy access checkbox --> click OK.

    You have activated easy access for this device.

    easyaccess.png

    Note: You must activate this function individually for each computer.

    Hope this will be helpful.

    All the best,
    Yuri

    Former Japanese Community Moderator
  • Thank you, @Yuri_T. We will review the settings you pointed to again as soon as someone is there to do it.

    Much appreciated,

    JF

  • This one worked for me. Also, I believe is required to have the full acccess setup in case you are using wake on lan functionality.

     

    Thanks

  • Robyw1
    Robyw1 Posts: 10 ✭✭

    @Yuri_T Hi I have a similar issue. I have 2 remote windows 10 PCs at my remote location. From home I can access 1 of those without team viewer app open but with the second one unless I have the team viewer app open the computer is showing offline and I can't access it. I have all the settings applied on all computers eg easy access and I am signed in with my account on all computers. Can you assist?

  • SterilizSales
    SterilizSales Posts: 1 Newbie

    We've tried everything listed in this thread from Full access, Easy access to personal passwords. Every time the remote computer is prompted with a Remote Desktop popup to Share.

    "Select monitor to share with the requesting application" with a slider bar "Allow remote Interaction"

    How do we bypass this popup. The remote device is unattended.

  • OlaSC
    OlaSC Posts: 3 ✭✭
    edited June 28

    I have the same problem.

    After a recent Teamviewer update(?) I get " Please wait for your partner to confirm the request" and on the unattended PC it says "Do you want to grant your partner access to view your screen?" and then another to let the "partner" have mouse authority.

    As far as I can tell I have added all possible authority and grants on the unattended PC. Easy access, white listed account, added the PC to my support account, it is managed. Full Teamviewer on both PCs.

    I had connected to it without issue for years and recently it just stopped letting me in.

    What to do?

  • QsparkICT
    QsparkICT Posts: 1 Newbie

    Hi All,

    I just downloaded the latest version and I can verify I have the same issue.

    I've checked all settings but no go. I have to grant access on the device itself.

    After that I can't even click on anything or do anything...


    Seems like a bug.

    I hope you (Teamviewer) can fix this!

  • mikey99
    mikey99 Posts: 1

    If no user is logged on to the remote computer, then access is granted without permission...but if a user is logged on to the remote computer, then permission is required...this was not required in the past before the recent update...can't the update be reversed so access can be as it was?

    Was this update even beta tested for these issues, before it was rolled out?

  • .Carol.fg.
    .Carol.fg. Posts: 919 Moderator

    Hi all,

    If you're using the newest version and layout of TeamViewer Remote (v15.44.4), please make sure you have on both sides of the connection Full Access configured:

    • Remote side:

    You must configure Full Access to the field Advanced settings for connections to this computer.


    • Local side:

    You must configure Full Access to the field Advanced settings for connections to other computers.

    I hope it helps. 🍀

    Best, Carol


    Portuguese Community Moderator

  • Monarte
    Monarte Posts: 1 Newbie

    If your remote PC is running on Linux and you would like to bypass the screen depicted below, take a look at this https://askubuntu.com/questions/1409536/how-to-stop-ubuntu-from-prompting-for-confirmation-for-remote-desktop

    In my case, Ubuntu asked for additional approval.