teamviewer.com link icon
or
Ask The Community

After upgrading TeamViewer on Mac to version 12.0.78517 from earlier 12.x, sound turns way down

Dear TeamViewer community,

I've been using TeamViewer for a couple of years now and I mostly use it on my MacBook Pro, currently running osSierra 10.12.5, to remote access my Dell laptop, currently running Windows 10 Enterprise.  I always carry my MacBook Pro with me and leave the Dell laptop at home.  When I need to access the latter, I use TeamViewer and I've been very happy with this setup during the past years.

Before upgrading to TeamViewer 12.0.78517 on both my MacBook Pro and Dell laptops no later than yesterday, I could listen to music or watch a YouTube video on my Mac even while a remote control session was open to access my Dell laptop.

Since the upgrade, however, as soon as I begin a session, the sound volume on my Mac turns down to a level which almost makes it imperceivable (at first I thought there was no sound at all coming from my Mac).  I tried increasing the volume on my Mac, applications and YouTube in all possible ways I could think of, but even with all the sliders set to the maximum, the sound remains way too low...  Connecting headphones doesn't resolve the problem either. 

As soon as I close the remote session, the volume on my Mac is automagically restored to a normal level.

Anyone else experienced this issue ?  Any advice on what I could possibly try, besides uninstalling TeamViewer on both computers and re-install the previous 12.x version ?

Thank you in advance for your kind replies !

Regards,

SkyLukeQc

Best Answer

«134

Answers

  • Same problem here.  It occurs because for whatever reason, TV is now turning on our webcams/microphones when we make remote control connection.  When the webcam/mic is enabled, local media playback volume is automatically lowered.  I don't know why TV is now doing this but I am really concerned by this behavior and have filed a ticket with support to try to get to the bottom of it.

  • RoxTeddy
    RoxTeddy Posts: 6

    Same here (Mac OS X Sierra with TV 12.0.78517) !  It doesn't simply mess up with audio output but with input as well so I can't use Teamspeak or discord and teamviewer at the same time.

    I don't even use any of TV sound feature...

     

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Thanks for sharing this with us, @pplaisance

    When you say that TV is "turning on" (or initializing them without actually turning them on, possibly?) our webcams and microphones when launching a remote control connection, do you mean those that belong to the remote computer (e.g. the Dell laptop in my example), the local computer (Ex: MacBook Pro) or both?

    I'll investigate further at my end.  Thanks for pointing this out and let me know if I can be of any assistance (e.g. provide my own settings to the support team) to help you get that ticket resolved quickly.

    All the best !

    SkyLukeQc

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Thanks for sharing this, @RoxTeddy.

    Wow, that's quite inconvenient.  I haven't tried making a Skype call or similar using my Mac while remote controlling my Dell laptop with TeamViewer.  There's a great chance that I'll experience the same symptoms when I'll do...

    Let's hope TV's support and maintenance teams will find a solution to this very quickly.

    All the best !

    SkyLukeQc

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Ah, found something interesting.

    There's no need to establish a remote connection in order to reproduce the issue.  

    Right after launching the TeamViewer app on my MacBook Pro, without establishing a remote connection to any computer, if I open up the Preferences window (TeamViewer > Preferences.... from the top menu) and then click on the Audio icon, the sound level is affected immediately.  Clicking on any other icon (General, Security, Remote Control, etc., even Video) in this same window restores the sound to its normal level, and vice-versa.

    Tried changing all the possible settings under the Audio section, even saving and closing the Preferences window in between each of these changes.  Problem persists...

    Can any of you guys reproduce this behavior as well ?

    Thanks in advance !

    Regards,

    SkyLukeQc

  • Scotty
    Scotty Posts: 494 Staff

    Hi everyone!

    This is caused by "Audio Ducking". Baiscally, this is caused if you have the VoIP Feature inside the connection turned on. Like many other VoIP services, this lowers the sound of all other output devices during a conversation to allow the Voice to be raised higher than the volume of other programs (As the audio cannot go above max).

    If you aren't using TeamViewer VoIP, the only way I can find to stop the audio from lowering is to change the default audio device output for TeamViewer before making a connection as only the audio device it is trying to play through should get ducked.

    This can be done under "Audio Confrencing" in the options of TeamViewer

    I have tested this and the audio does play at the correct volume during the connection (It does dip just as the connection is being established)

    I hope this helps!

    -Scotty

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Ducam
    Ducam Posts: 2

    No, this does not help. :smileysad:

    Change it back to how it was before, please!

  • There is no "audio conferencing" setting in TeamViewer for Mac preferences that I can find.  There is an Audio tab, which will duck the audio when you open, but I've tried every combination of settings imaginable and nothing stops it from activating my webcam's microphone and ducking the audio when making remote connections.Audio settingsAudio settings

  • @SkyLukeQc

    When I make a remote connection from my Mac Mini to any other computer, windows or Mac, TV 11 or 12, the light on my MS Lifecam on my Mac turns on, likely because it has activated its microphone.  Audio on my Mac is ducked for the duration of the connection.

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Hi @Scotty,

    Thanks for joining this thread !

    Is this audio ducking feature new on the latest Mac version of TeamViewer (12.0.78517) ?  I've never experienced this problem in earlier 12.x versions, but I might have skipped one or two. I didn't write down the version I was using before updating it to 12.0.78517, unfortunately...

    You wrote :

    «[...] the only way I can find to stop the audio from lowering is to change the default audio device output for TeamViewer before making a connection as only the audio device it is trying to play through should get ducked.

    This can be done under "Audio Conferencing" in the options of TeamViewer.»

    As @pplaisance already pointed out, the "Audio Conferencing" settings are simply called "Audio" in the Mac version of TeamViewer :


    Windows version of TeamViewerWindows version of TeamViewer

    Mac version of TeamViewerMac version of TeamViewer

    Most of the time, the only audio devices that I use on my MacBook Pro are the built-in microphone and speakes.  So I don't have many options regarding the selection of a different audio device, as you suggested, to use for VoIP in TeamViewer.  Even if I try to change the devices above from "Built-in In/Out" to "Standard recording/palyback device" and apply the changes :

    1. it doesn't change anything to the audio ducking problem
    2. the settings come back to their original values when I later reopen the audio preferences (see below)

     

    Attempting to change to Standard devicesAttempting to change to Standard devices

    Devices are reset to original values next time the Audio preferences window is openedDevices are reset to original values next time the Audio preferences window is opened

    I also tried clicking on the "Configure" button to change the "Conference Call" settings :

    BEFOREBEFORE

    AFTERAFTER

    Still no luck, only "duck"....  :smileywink:

    The ONLY way I was able to circumvent this problem was to attach an external audio device to my Mac and then, after selecting this device for "audio conferencing", I was able to hear sound loud and clear from my built-in speakers (no audio ducking) :

    Adding external audio device to avoid audio ducking...Adding external audio device to avoid audio ducking...

    I swear something's changed, as I didn't need to do this in earlier versions.  Also, maybe it would be a good idea to add a checkbox allowing users to enable or disable "Audio Conferencing" altogether in TeamViewer, or add an item to the Speakers and Microphone dropdown list named "Disabled" so as to not initialize and apply audio ducking to any audio devices.  Just my two cents...

    Thank you in advance for considering this as an annoying side-effect, if not a bug, of an otherwise useful feature (for some other users and customers, I guess) you tried to introduce in TeamViewer.

    Regards,

    SkyLukeQc

  • SkyLukeQc
    SkyLukeQc Posts: 47

    That's actually kind of scary too, isn't it @pplaisance ?

    I mean, how can we be sure someone isn't actually hearing audio through the built-in or webcam's microphone or, even worse, accessing the webcam's video feed ?  

    An unexperienced user may think he's being spied or something while using TeamViewer.  **bleep**, had I seen my webcam's led lighting up (which I don't, as the built-in microphone on a MacBookPro isn't linked to the webcam), I would have been quite worried even if I don't consider myself being too paranoid about these things...

    Thanks again @pplaisance for your input !!

    Regards,

    SkyLukeQc

  • RoxTeddy
    RoxTeddy Posts: 6

    I fixed the problem by downgrading to a previous v12 build.

    I can still reproduce the bug by going into settings > audio. If I had a session opened, I have to close it to get back the sound. If I hadn't, I just have to go the another setting panel or close the settings.
    That audio ducking story is weird. I see the interest in limiting other programs sound output to hear the voice over but why would it duck the microphone input too ?
    I don't even use any sound feature of TV. No Meeting or Voip. Only remote control with the remote sound disabled.
    Obviously, something has changed in the last build that triggers some conference/voip functions that aren't really needed.

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Thanks for your input, @RoxTeddy !

    I'm thinking about taking that path as well (downgrading TeamViewer to its previous version), although I wasn't sure if it would actually solve the problem.  Your post gives me hope that it will.

    Thank you !!

    Regards,

    SkyLukeQc

  • Ducam
    Ducam Posts: 2

    This has always been the problem with Teamviewer since I started using it from somewhere around v5. The TeamViewer staff doesn't use Macs themselves and painfully obvious bugs like these keeps coming up every year.

    Just look at the moderator answering this thread, he/she gave a direct advice from their PC, in a thread about a Mac problem... :smileysad: 

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Hi @Ducam,

    Thanks for joining the conversation !

    I wouldn't know if what you say regarding the TeamViewer staff not using Macs is accurate or not, but one thing is certain, they've done an incredible job with this application so far.

    It's fast, has a small footprint on data usage, works beautifully across platforms and it's completely free for personnal use.  Yes, I'm totally addicted to it !  :smileywink:

    No software is absolutely bug-free.  IMHO, the important thing is to see how quickly and diligently the support and development teams react when this type of bugs are reported to them by us, the end users.  Let's hope for the best !  :smileyvery-happy:

    All the best,

    SkyLukeQc

  • Devotee
    Devotee Posts: 3

    Oh well, I guess I should have posted my message here... I'm sure both reports are related, anyway.

    Same problem here (I think). I'm using version 12.0.78517 on OS X Yosemite 10.10.5. I started having this issue yesterday. I was playing some music on Spotify and suddenly the volume was VERY low, I had to increase the system volume to maximum to barely hear anything on the speakers connected to my Mac Mini computer. I first thought that the speakers were broken because I couldn't find anything on the system to change the output mixing/master volume, etc.

    But as soon as I closed Teamviewer I got the normal volume again. So it turns out that every time I open a new Teamviewer session with a remote computer, the system volume is barely audible. As soon as you close the remote session, volume goes back to normal (no need to actually exit Teamviewer). I tried to disable the remote audio option while in a session, but it doesn't fix the issue.

    Another weird issue, if you go to Preferences > Audio when you have anything playing in the background (Spotify, for example) Teamviewer will either crash or volume will almost mute (until you leave the preferences panel).

    If you mess with the volume controls it somehow gets better. You can slide the volume of the Speakers up to the top and the master system volume will increase almost back to normal (not really). But as soon as you close the audio preferences the volume will just boost up to the maximum.

    My guess? The volume scale on Teamviewer doesn't match the system's volume. A 100% volume on Teamviewer's audio preferences is about 60-75% of the real system volume. Meaning that if your system volume is at about 25-40%, when you launch a Teamviewer remote session, it will get a -25%-40% "increase", leaving it to almost 0% (mute).

    Screenshots of system volume level and Teamviewer's audio preferences (sound barely audible in that scenario, but will go back to normal if I just close the audio preferences or simply switch to another preferences' section). The slider on Teamviewer's audio preferences should be way lower (first/second mark) but it's in the middle:

    2017-06-03 13.26.18.png2017-06-03 13.26.40.png

  • Devotee
    Devotee Posts: 3

    I'm not sure I can edit my post, so I'm replying to myself (haha). I've played a bit more with the audio preferences and since I've used Soundflower in the past, I thought I should give it a try. By setting the output to Soundflower, everything works fine (this is, of course, related to SkyLukeQc's solution of attaching an external audio device to the computer but without the need to actually have a "physical" device).

    I still have a brief "fade-out, fade-in" effect every time I start the first remote session (or I play with the audio preferences) after I have got a remote session active, opening new sessions won't disturb the sound. I also obviously have no sound from the remote sessions.

    I'm curious of what would happen if you attach an external USB soundcard and set it as the output device for Teamviewer. I'm sure the system volume would work like a charm while being able to play the remote session's audio through the external soundcard (at what volume, that I don't know). So, again, I'd say there's some bug here with the mixing of Teamviewer and system audio (Teamviewer's volume messing with the system's "master volume" level).

    2017-06-03 13.54.03.png

  • RoxTeddy
    RoxTeddy Posts: 6

    @Scotty

    Your solution of changing output might work but most of us have only a single ouput.

    I insist that before the last update, if we weren't using Teamviewer voip/conferene part, it was not affecting our experience. I can remember now it always hapenned in conference and thats why I stopped using it but at least the remote control wasnt messing with other programs' sound.
    In my opinion, TeamViewer developpers should rollback the code to a previous commit when it was not affecting the remote control.

  • quad_bx
    quad_bx Posts: 2

    Hi,

    Which v12 older build? 12.0.75813? I can't seem to find it anywhere to download it... :( My issue is similar, in a way that TeamViewer crashes completely, but the error message points to audio issues: 

    Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000020
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Segmentation fault: 11
    Termination Reason: Namespace SIGNAL, Code 0xb
    Terminating Process: exc handler [0]

    /Applications/TeamViewer.app/Contents/MacOS/TeamViewer

    Application Specific Information:
    dyld: in dlopen()
    /System/Library/Components/CoreAudio.component/Contents/MacOS/CoreAudio

    Later edit: I uninstalled Boom 2 from www.globaldelight.com, everything is back to normal for me. :)

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Hi @Devotee,

    Thank you so much for your very useful contribution to this thread !!  Using Soundflower was a brillant idea to diagnose the issue and run your tests !

    To answer your comment below :

    "I'm curious of what would happen if you attach an external USB soundcard and set it as the output device for Teamviewer. I'm sure the system volume would work like a charm while being able to play the remote session's audio through the external soundcard (at what volume, that I don't know)."

    Since I do have an external USB sound card available that I can use on my Mac, I'll try to run a few tests later today to see how that works.  I'll post my results here as soon as I can.

    Kind regards,

    SkyLukeQc

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Hi @quad_bx,

    Thank you for joining this thread and sharing your issues and workarounds with us !!

    I can't answer your question about the specific earlier version @RoxTeddy used to "fix" the issue.

    In my case, TeamViewer never crashed, at least not in relation to the issue at hand (audio related issue).  @Devotee mentioned that TeamViewer would sometime crash in his case.  Don't know if the cause and error message were the same for him, however.

    Thanks for pointing out the "Boom 2" application, I din't know this app.  From my understanding, it allows you (among other things) to "boost" the audio volume coming out of your audio devices beyond their normal max levels, is that correct ?  So I can imagine that after installing this app, you're able to boost back up the sound that was ducked by TeamViewer's audio conferencing feature.  Does it also add virtual sound devices in a similar way of what Soundflower does ?

    I have a few questions that came to mind :

    • You said TeamViewer would crash.  Did this started happening after you've upgraded to version 12.0.78517 ?  Did it ever happen before ?
    • Would it crash when launching TeamViewer, before any remote connection was made, or after trying to establish such connection ?  
    • Was it crashing every single time, or more in a random fashion ?  
    • Were there any settings you changed in TeamViewer's preferences to make things work after installing "Boom 2" ?  For example, did you change the Microphone and Speakers settings under the Audio preference window ?

    Thank you in advance for your valuable input.  I'm sure that with all this info, TeamViewer's team will be able to nail the problem down and correct the issue in the next release.

    Regards,

    SkyLukeQc

  • quad_bx
    quad_bx Posts: 2

    Hi,

    Actually, it was the other way around. Boom 2 boost audio level by adding a virtual output device and rerouting audio to be boosted. So by UNinstalling it removed said device and now TeamViewer no longer crashes. I was able to make it crash just by visiting Preferences -> Audio tab. It is my understanding that Boom 2 takes control of the audio output device and said device was no longer matching the manually selected TeamViewer audio output device in Preferences. Trying to connect to a remote computer also made it crash.

    I have a few questions that came to mind :

    • You said TeamViewer would crash.  Did this started happening after you've upgraded to version 12.0.78517 ?  Did it ever happen before ?
      Yes, after the upgrade. No, never.
    • Would it crash when launching TeamViewer, before any remote connection was made, or after trying to establish such connection ?  
      No, it crashed after trying to establish a connection or when visiting Preferences, Audio tab.
    • Was it crashing every single time, or more in a random fashion ?  
      Yes, everytime. Completely removing TeamViewer files with CleanMyMac and reinstalling from scratch with reboot did not solve the issue, either.
    • Were there any settings you changed in TeamViewer's preferences to make things work after installing "Boom 2" ?  For example, did you change the Microphone and Speakers settings under the Audio preference window ?
      No, actually I had to uninstall Boom 2 to make it work.

     

     

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Hi @quad_bx,

    Oh, sorry.  I misread the edit you wrote on your first post.  

    Uninstalling "Boom 2", not installing it, fixed your problem !!

    So now you're basically at the same level as all of us : no more crashes, but sound ducking when starting a remote connection or accessing the Audio settings.

    Thank you once again for your valuable input and taking the time to answer all my questions, I appreciate it !!

    All the best,

    SkyLukeQc

  • RoxTeddy
    RoxTeddy Posts: 6

    @SkyLukeQc

    for the version, I rolled back to 12.0.72647 . I have found a page on the official website to get previous major versions (v11, v10..) but not previous v12 builds so google gave me this site instead : http://teamviewer.fr.uptodown.com/mac/old

    But I cannot garantee the file are leggit, that's the first time I use this website.

    Edit : Oh and for newcomers, as I said the audio ducking happens in this version too but only if you trigger audio/voip functionnalities, not just using remote control. That's pretty much all I need from TeamViewer.

  • Scotty
    Scotty Posts: 494 Staff

    Hi again everyone.

    @ apologise, I say audio/confrencing as there is both settings in here. But on Mac the title was shortened due to the lateral layout of options, although we still refer to it as Audio Confrencing internally I apologise for any confusion.

    I have tested this on a MacBook Air running Sierra 10.12.1
    In my testing, if you change the default audio output in here, the audio still ducks at the beginning of a connection, but then returns to normal. But I can confirm that this behaviour has been occuring well before V12.

    @SkyLukeQc Thank you for your calm help on this page, it's fantasic to have users like you :)

    @Ducam I am sorry if it seems like we don't care. However I did not test this on a windows device. There would have been no point and if I cared so little, I simply would have let this post be rather than respond.

    I do have support looking at this as well and we will monitor for any updates here and I will respond if I can make any headway from our side.

    -Scotty

     

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Mcbrauns
    Mcbrauns Posts: 1

    How is it that there is no ability to disable audio conferencing altogether?  I have a single audio in source and that is my Skype polycom phone.  It starts an audio session when I log into one of my computers via teamviewer.  As mentioned above it ducks audio from other sources.  It also blocks incoming calls since the phone thinks it is in another call.  Since I cant turn the stupid thing off as there is no settings to do so in Teamviewer, this is not sustainable.  This is aboslutely rediculous and you guys need to change it back or I will find other option.  

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Thank you @RoxTeddy !!

    "Oh and for newcomers, as I said the audio ducking happens in this version [12.0.72647] too but only if you trigger audio/voip functionnalities, not just using remote control. That's pretty much all I need from TeamViewer."

    I agree with you, same here.  Rolling back TeamViewer to this pre-12.0.78517 behavior would be ideal for me too as well as many others, IMHO.  Even better would be to have a way to disable Audio Conferencing altogether in the Audio preferences panel, at least for those of us that do not need or use this functionality or who'd rather use an external audio conferencing solution, such as Skype or similar for example.

    A huge thank you to everyone who has contributed to this thread so far !!  I believe we've caught the support team's attention.  :smileywink:

    Also, thank you very much @Scotty for your very nice words.  I appreciate it !  :smileyvery-happy:

    All the best,

    SkyLukeQc

  • SkyLukeQc
    SkyLukeQc Posts: 47

    Hello @Mcbrauns,

    Thanks for your contribution on the subject at hand.

    IMHO, using words such as "stupid" and "ridiculous", or threatening to look for a different solution if a bug isn't solved as quickly as you'd like, isn't very constructive.

    The part that is constructive, though, is your description on how you use TeamViewer in conjuction with other software and/or hardware.  I believe we all use it a bit differently depending on our own needs.  So I'm glad you shared that with us.

    Let's keep this thread "clean" by remaining calm.  I'm sure something good will come out of it !  :smileywink:

    Best regards,

    SkyLukeQc

  • Julia
    Julia Posts: 292 Staff

    Hi all,
    Thank you for your contribution.

    I would like to share an update with you which I got from our development.
    We got the confirmation that this is a bug in the current version – we are already working on a fix and I will inform you when we published it.
    We want to say a big THANK YOU for your feedback because also the input from this thread helped us to identify the problem.

    Cheers,

    Julia
    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • SkyLukeQc
    SkyLukeQc Posts: 47

    Hi @Julia,

    Thank you for sharing this information with us !  These are excellent news !!!

    Looking forward to the next release of TeamViewer !  :smileyvery-happy:

    All the best,

    SkyLukeQc

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!