Commercial use - Connection time out



  • jbarnett12
    jbarnett12 Posts: 28 ✭✭

    This is actually insane why are we not getting information from TeamViewer

    I filled out the form  and got the restruction lifted. I am trying to get onto a headless Raspberry PI. I am npt getting the pop- up back and my access to the PI bloked in spite of TeamViewer so my id had been reset to free.

    The other question I would ask is why the person monitoring this forum for TV is delete references to a third party product rather than addressing our concerns.

    This seem to border on the insane?

  • When I connect to my PC from my Android phone, I get a message stating that I'm using it for commercial usage instead of personal use, when I'm clearly not. I'm literally sitting in my backyard, connecting to my PC for personal use, but since the app seems to think otherwise, the session terminates after 5 minutes.
  • I have the same issue, I've not used it for months, now I turn the laptop on and try to work on my desktop from the garden, for my only purpose, anything commercial, and now I cannot use it for more than 5 minute.

  • sornord
    sornord Posts: 16

    Small blessings dept:  I could do a file transfer normally from my main PC to my tablet, so I can at least practice with the tablet on the audio tracks needed for an upcoming audition.  No "commercial use" nags.  Tried a remote control session, however, and still got them.  Again, these are the same tablet and PC that worked normally, but only for an hour or so, on the 8th when TV restored my free license.

  • Looks like anyone experiencing this issue should fill out the form at to resolve things.
  • Yershov
    Yershov Posts: 11 ✭✭


  • Habe das Problem bei meinem Rechner auf dere Arbeit. Möchte dann zu Hause zugreifen und werde nach 5 min. raus geworfen. Angeblich Kommerziell. Was tun?

  • I have been using TeamViewer for several years, mainly to help my now-94-year-old father and another elderly friend, and occasionally to log in to my home computer while traveling. It's a great program, works beautifully, better than I thought it could, and apparently has cool features I haven't even tried yet. Earlier this year I was locked out due to suspected commercial use, pleaded my case, eventually reinstated. Now I often find I am temporarily locked out because of too frequent connections? For instance I tell my Dad I can't connect because his computer needs to be restarted. I try again in a minute, computer still not ready; try again, TeamViewer kicks me off. Yes, it's temporary, but also completely disruptive and almost enraging. It happened again today, and then I got the message I could only connect for five minutes; about one minute later kicked off. I understand TeamViewer is in business to make money - more power to you. If your enforcement policy makes the free product unusable, so be it. Now I'll learn to use RemotePC. And I can't really recommend the free TeamViewer to anybody -- but who cares, I guess you lose money for every free user. (BTW, paid version? -- no way I can afford [The price has been removed in accordance with the community guidelines.] to help a couple of friends with their computer problems.) Gracias y adios, muchachos!

  • I am receiving error messages within TeamViewer, telling me that I need to purchase the product because it appears that I am using it for commercial purposes. I am a power home user - we are a ten computer household, with units scattered around the house. I am NOT using TeamViewer for commercial purposes,but the program keeps kicking me out because it “thinks” I am. To say that I’m annoyed is putting it politely. While I would like to get this issue dealt with, I have absolutely no problem moving to another platform if it comes to that.

    Thank you.

  • bazbsg
    bazbsg Posts: 112 ✭✭

    Today I tried to connect to my downstairs television PC, the one which TV claimed was commercial use. I no longer get the warning / error from connecting to it. I sent the form in, I think, on July 30. Hard to be sure because they only say how long ago a post was made, not when it was made, and they rounded that off to two weeks. My email shows me the message after mine was on July 30. Today is August 12. So less than two weeks. I didn't get any email or notification telling me they had restored the private use status. Just had to try until the problem cleared up.

  • Yershov
    Yershov Posts: 11 ✭✭

    You could notice that your ID changed

  • This thread is huge and I won't read it all. But from reading so far, I am not seeing what I need to do. I have been using it for years from my same remote computer and have only ever used it to connect to home computers and my mom's computer. Never any commercial use and never any work computers. And today I am getting this message and I haven't even used it today. So what do I do? I don't see a way to create a ticket from the app.

  • I have never used my Teamviewer account to connect to a company or business computer. I have only used it for the same home computers and my mom's computer for years. And now today it says I am using it commercially and won't let me remote my home computer. I don't even use it that much. But now I can't find a way to get support. I tried to Submit a ticket, but it just takes me to this forum.

  • I had that happen too - and when the window popped up on my laptop that indicated I was being locked out, there was a place where I could have a live chat with someone. I did that and four days later they reinstated my free account.


  • I started getting this message today when I only use Teamviewer for my home computers (everyone in the family has one) and for my parent's computers (because they're old and need a lot of hand holding). 

    Every time I log into my secondary computer now, it shuts down after a minute and says I can't log in for another 10 minutes when I go to log back in. 

    I submitted a personal use form for each of the main home computers I use. If this isn't resolved by tomorrow I'm looking into alternatives.

  • I've been getting the message for just over a week after almost 2 years of normal usage.  I can't get any answers.

  • I wish that was the case for me. All I get is a window with a Buy Now button and an X to close.


    Thank you for choosing TeamViewer. You have regularly used the service to access computers in business environments. This is considered a professional use of the product. You need to purchase a subscription to continue.

    This is false. All of the systems I connect to are my personal computers or my mom's computer. And I haven't added a computer to my account in over a year. 

    WOW, talk about rude. So I called the main number. It says to press 1 for support as a free user. It then just says to visit this website and hangs up.

  • Just hit me too.

    A few years ago they blocked my work computer (connecting to my PERSONAL COMPUTER), and my personal phone (probably for using my works wifi?).

    Just today you blocked my personal laptop from personal computer!??!?!

    Good thing for ***Third Party Product*** - all though less capable, it is improving. Just hate being false flagged and accused of commercial use. I bet it is because I have a google work account profile, that is logged into all my personal devices... WHICH WE USE ***Third Party Product*** FOR YOU **BEEP** !!!!!! UNBLOCK MY ID's PLEASE.

  • judyg26
    judyg26 Posts: 1

    Have been using this for over 2 years now for a non-profit - high school alumni association.  There are 3 of us maintaining the database of 38000 names .  This is strictly a volunteer operation and 2 of us access the main computer at scheduled times throughout the day and night.  Now I am having issues with getting blocked out and only can use for 5 minutes at a time.  Getting a message stating that this is being used for commerial use .  When I set this up  - did NOT indicate that nor has our volunteer status changed.  I recently had to wipe my cookies - so did that alter my access?  How do I get back my regular connection - as I do MOST of the daily updating!!!!!!!!!!!!!!!!



  • 2000SVT
    2000SVT Posts: 2
    edited March 2022

    Not a single reponse? This support method **bleep**. Time to find an alternative to TeamViewer.

  • RobT
    RobT Posts: 3

    The company behind Teamviewer **bleep** so badly, that I can’t even fully express it! They have plagued most of their “free” customers with this “commercial use” timeout, which effectively renders your entire Teamviewer account completely worthless! What’s even worse than that, is that they make it nearly impossible to contact them to inquire or try to resolve this incorrectly imposed limitation, by only offering you one single online form to complete (NOT a person) to beg them to reconsider marking your account as actually personal in nature. Once I found this form, I completed it, and after several days have still not received any response and my account is still effectively disabled. Please do yourself a favor BEFORE even considering doing business with Teamviewer, and read the posts by their upset customers in their “community”, which is the absolutely only support avenue that you will have as a free customer.

  • @RobT wrote:

    ... by only offering you one single online form to complete (NOT a person) to beg them to reconsider marking your account as actually personal in nature. Once I found this form, I completed it, and after several days have still not received any response and my account is still effectively disabled. ....

    Thanks for your info. What form? Where is it? Obviously they don't care about the forum, so I guess I am suppose to find some form to fill out that is NOT meantioned anywhere. I don't get why they don't have the form part of the TV app when it pops up that false accusation. 

  • pv7721
    pv7721 Posts: 151 ✭✭

    @Xenon2000 here you go:

    Fill out this form to request the unblocking of your TeamViewer ID:

    It was somewhat buried in the links from the 1st post.

    Stupid (will be edited to bleep) forum software won't allow paste of own TV text... then if I remove and attempt to post again, I get an error...

    LE: Absolutely hilarious, after posting I got a survey: was I able to find what I was looking for, no, what will I do about, come back later, will I buy, no, make a suggestion: STOP THE FREE USERS HUNT!

  • Thanks. Without knowing about that forum, I would never even search for it. Thanks for pointing it out. They should have a sticky on the forum and really should have the form presented when they are accusing you with the popup in the app.

  • Help! My TeamViewer keeps timing out and disconnecting me. It thinks its being used "in a commercial environment," but it's just me, connecting from my Mac desktop computer to my Windows network storage computer. The Windows computer doesn't have a monitor or mouse, so the only way I can control it and manage my backup app, music app, and my video library is with TeamViewer.

    **Please do not discuss price**

  • a1cmugs
    a1cmugs Posts: 2 ✭✭

    I keep getting the commerical usage message again.. I use it only personal usage.. I thought you had this fixed from the last time.. Please fix this.. I am a ham radio operator and use team viewer to configure my laptops st the ham radio sites.. Ham radio is not commerical it is my hobby..

    tommie taylor
  • a1cmugs
    a1cmugs Posts: 2 ✭✭

    me troo

    tommie taylor
  • I'm having this same issue; I connect to one computer only. All of a sudden, I am unable to connect for more than 5 minutes. I am annoyed; I am connecting to my personal computer. 

    I've tried to open a ticket, but when I click on the link to open a ticket, it continuously loops me back to the message board. 

    Mods, please assist, or DM me.

  • Josh, I did not see a solution provided. I am experiencing a 5-minute time limit while connecting to my personal computer. 

  • I have been using teamviewer 14 for about 5 months to connect and control my telescope at a remote location.    Last week i was having a issue with my telescope and asked a friend to assist by remoting into my computer.     The next time i went to talk to my remote computer i got the message "Teamviewer thinks i'm using the software commercially".    I found out later that  my friend has a commercial teamviewer.    If he used that acount to remote to my computer would that of been the flag that i was using teamviewer commercially?    If so, then this should be made clear on your website currently that is not clear and only  got that thought after reading posts of using free and commercial accounts on the same computer.     hopefully my free account will be reset......and i will be more careful when asking friends to remote to my computer.    If this was not the flag.....then something else is wrong with the teamviewer flagging software?   What could it be?